php funktionert nach server restart nicht mehr

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

php funktionert nach server restart nicht mehr

Postby xb7 » 03. April 2007 11:09

im grunde ist es wies in der topic steht, der server war ne zeit lang aus und läuft jetzt wieder
habe dann lampp gestartet aber wie es scheint wird php code nicht mehr geparsed, statt dessen versucht der browser die scripts runterzuladen

als beispiel einfach mal auf www.xb7.org gehen

stuert man direkt irgendwelche bilder oder html dateien an, funktionierts, auch alles andere auf dem server läuft wie vorher....

jemand ne idee?
xb7
 
Posts: 4
Joined: 03. April 2007 11:03

Postby moinmoin666 » 03. April 2007 12:01

Erstmal gibts ne Fehlermeldung bei starten?
WEnn du den apache startest, steht dann da (mit php5)

gib einfach mal
Code: Select all
sudo /opt/lampp/lampp php5
ein, könnte das problem beheben (oder php4 kommt eben drauf an was du willst).

Nen par logfiels wären echt super![/code]
moinmoin666
 
Posts: 30
Joined: 29. May 2006 22:53

Postby xb7 » 04. April 2007 16:38

es gibt keine fehlermeldung beim starten allerdings steht da auch nicht
starting apache bla (mit php5)

wenn ich /opt/lampp/lampp php5 eingebe, zeigt er mir folgendes:

XAMPP: Activate PHP 5.1.2...
XAMPP: Stopping Apache with SSL...
XAMPP: Starting Apache with SSL ...

funktioniert aber trotzdem nicht.

allerdings hab ich jetzt mal in das errorlogfile geguckt und auch wenn ich mich da nicht wirklich mit auskenne, steht da doch was sehr eigenartiges, seit gestern (also dem tag an dem ich xampp wieder gestartet habe, nach restart des servers)

[Tue Apr 03 11:37:15 2007] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Apr 03 11:37:15 2007] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Apr 03 11:37:15 2007] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Tue Apr 03 11:37:17 2007] [notice] Digest: generating secret for digest authentication ...
[Tue Apr 03 11:37:17 2007] [notice] Digest: done
[Tue Apr 03 11:37:18 2007] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Apr 03 11:37:18 2007] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Tue Apr 03 11:37:18 2007] [notice] Apache/2.2.0 (Unix) DAV/2 mod_ssl/2.2.0 OpenSSL/0.9.8a mod_apreq2-20050712/2.1.3-dev mod_perl/2.0.2 Perl/v5.8.7 configured -- resuming normal operations
[Tue Apr 03 11:43:02 2007] [notice] caught SIGTERM, shutting down
[Tue Apr 03 11:45:28 2007] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Apr 03 11:45:28 2007] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Apr 03 11:45:28 2007] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Tue Apr 03 11:45:29 2007] [notice] Digest: generating secret for digest authentication ...
[Tue Apr 03 11:45:29 2007] [notice] Digest: done
[Tue Apr 03 11:45:31 2007] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Apr 03 11:45:31 2007] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Tue Apr 03 11:45:31 2007] [notice] Apache/2.2.0 (Unix) DAV/2 mod_ssl/2.2.0 OpenSSL/0.9.8a mod_apreq2-20050712/2.1.3-dev mod_perl/2.0.2 Perl/v5.8.7 configured -- resuming normal operations
[Tue Apr 03 11:47:21 2007] [notice] caught SIGTERM, shutting down
[Tue Apr 03 11:47:36 2007] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Apr 03 11:47:36 2007] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Apr 03 11:47:36 2007] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Tue Apr 03 11:47:37 2007] [notice] Digest: generating secret for digest authentication ...
[Tue Apr 03 11:50:44 2007] [notice] Digest: done
[Tue Apr 03 11:50:45 2007] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Apr 03 11:50:45 2007] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?

könnte es also daran liegen, dass der servername irgendwo falsch ist? und wenn ja wo? oder hat das mit dem ganzen nichts zu tun? ich dachte eigentlich, dass man es sich sparen kann den servernamen explizit anzugeben, wenn man einfach localhost angibt?
xb7
 
Posts: 4
Joined: 03. April 2007 11:03

Postby xb7 » 08. April 2007 15:55

hmm keiner?
xb7
 
Posts: 4
Joined: 03. April 2007 11:03

Postby xb7 » 20. April 2007 18:04

ich bins wieder

inzwischen habe ich folgendes versucht:

update auf neue xampp version: nichts

xampp komplett löschen und neuinstallieren: nichts

d.h. nicht mal die xampp anfangstestseiten sind zu sehen s.h. -> www.xb7.org

kann mir niemand helfen?
xb7
 
Posts: 4
Joined: 03. April 2007 11:03


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests