Mysql Script-Fehler /var/lib/mysql/mysql.sock' (mysqldumper)

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Mysql Script-Fehler /var/lib/mysql/mysql.sock' (mysqldumper)

Postby mr_swell » 08. March 2007 17:36

Hallo,
ich habe Probleme mit einem Script (Mysqldumper) und suche jetzt schon sehr lange......
XAMPP 1.6 mit Opensuse 10.2

crondump.pl: DBI connect('essensbestellung:localhost','root',...) failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (111) at /opt/lampp/cgi-bin/crondump.pl line 231

habe schon mehrer Ansätze getestet, aber noch keine Lösung gefunden!
Wer hat noch einen Tip, der Datenbank connect geht ja, nur springt er dann auf den falschen Pfad.
Ordner mysql+socket in /var/lib angelegt, keine Änderung (Fehler 111)
ohne den Ordner Fehler (2)

mfg
JO
mr_swell
 
Posts: 3
Joined: 08. March 2007 17:17

Postby Wiedmann » 08. March 2007 18:08

Dieses Perlscript muss beim Connect halt einfach den richtigen Socket nehmen (also den vom XAMPP MySQL-Server).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby mr_swell » 09. March 2007 07:26

ja, genau dies hätte ich gerne ;)
leider finde ich keine Option im Script wo ich dieses hinterlegen kann...

anstatt, wo er hinwill/sucht
'/var/lib/mysql/mysql.sock'
hier wo meine Socket liegt
'/opt/lampp/var/lib/mysql/mysql.sock'

Viele Grüsse und Dank für weitere Tips
JO

(Script=Mysqldumper V1.21)
Opensuse 10.2 XAMPP 1.6
mr_swell
 
Posts: 3
Joined: 08. March 2007 17:17

Postby Wiedmann » 09. March 2007 11:02

eider finde ich keine Option im Script wo ich dieses hinterlegen kann...

Das sollte ja der Author/Support von diesem Script wissen...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby mr_swell » 12. March 2007 08:32

ich habe die Lösung für mein Problem und stelle Sie gerne allen zur Verfügung, das Tool Mysqldumper ist auch sehr zu empfehlen für Datenbanken.....

es gibt in dem Script crondump.pl zwei Zeilen, die mit DBI->connect beginnen.
Hinter der Variablen $dbname folgendes einfügen: ";mysql_socket=/opt/lampp/var/mysql/mysql.sock"
Hier die gesamte Zeile:
DBI->connect("DBI:mysql:$dbname;mysql_socket=/opt/lampp/var/mysql/mysql.sock:$dbhost","$dbuser","$dbpass") || die "Database connection not made: $DBI::errstr";


Besten Dank an alle....
JO
mr_swell
 
Posts: 3
Joined: 08. March 2007 17:17


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests