WebDav installieren / aktivieren unter xampp1.5.5a

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

WebDav installieren / aktivieren unter xampp1.5.5a

Postby chamaelon879 » 16. February 2007 19:01

ich weiß, jetzt wird gleich einer Sagen, da gibts doch Anleitungen im Netz. oder warum googelst du nicht...
hab ich aber...
Also im Internet findet man folgende Anleitung:

Dateien von www.webdav.org herunterladen und dann mit ./configure Konfigurieren, was ich wie folgt gemacht habe:

Code: Select all
laptop:/home/markus-l/Desktop/mod_dav-1.0.3-1.3.6 # ./configure --with-apxs=/opt/lampp/bin/apxs


Danach erscheint folgende Fehlermeldung:
Code: Select all
checking for dynamic Apache module support (via APXS)... found at /opt/lampp/bin/apxs
configure: error: Your APXS installation is broken and cannot be used.
    Please see http://www.webdav.org/mod_dav/install.html#apxs for
    more information.

Dieser Fehler ist Bekannt auf den Seiten von webdav.org. Man muss anscheinend die apxs Datei editieren.
Problem ist nur, dass die dinge, die zu dem Fehler fürhen (lt. der hilfe) in der Datei die ich habe überhaupt nicht enthalten sind, bzw. korrekt sind..

Es wird hier bestimmt einen geben, der webdav unter xampp Linux zum laufen gebracht hat oder ?? ein klitze kleines Tutorial für mich wäre SUPER!!!!!!!!!!!!! VIELEN DANK schon mal.

hier die "Lösungsmöglichkeiten" von http://us2.php.net/manual/en/faq.build.php

Code: Select all
54.13.     When I try to build PHP using --with-apxs I get strange error messages.
   

There are three things to check here. First, for some reason when Apache builds the apxs Perl script, it sometimes ends up getting built without the proper compiler and flags variables. Find your apxs script (try the command which apxs), it's sometimes found in /usr/local/apache/bin/apxs or /usr/sbin/apxs. Open it and check for lines similar to these:

my $CFG_CFLAGS_SHLIB  = ' ';          # substituted via Makefile.tmpl
my $CFG_LD_SHLIB      = ' ';          # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = ' ';          # substituted via Makefile.tmpl

     

If this is what you see, you have found your problem. They may contain just spaces or other incorrect values, such as 'q()'. Change these lines to say:

my $CFG_CFLAGS_SHLIB  = '-fpic -DSHARED_MODULE'; # substituted via Makefile.tmpl
my $CFG_LD_SHLIB      = 'gcc';                   # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = q(-shared);              # substituted via Makefile.tmpl

     

The second possible problem should only be an issue on Red Hat 6.1 and 6.2. The apxs script Red Hat ships is broken. Look for this line:

my $CFG_LIBEXECDIR    = 'modules';         # substituted via APACI install

     

If you see the above line, change it to this:

my $CFG_LIBEXECDIR    = '/usr/lib/apache'; # substituted via APACI install

     

Last, if you reconfigure/reinstall Apache, add a make clean to the process after ./configure and before make.
chamaelon879
 
Posts: 6
Joined: 16. February 2007 17:33

Postby Oswald » 17. February 2007 16:29

Hallo chamaelon879!

mod_dav ist bei XAMPP schon mit dabei. :wink:

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby chamaelon879 » 17. February 2007 18:22

:oops:

Also Unter Windows, ahbe ich es ja gelesen ..inkl. WebDav, unter Linux hatte ich da nix gelesen..

reicht es dann, einfach in der httpd.conf entsprechende Einträge vorzunehmen ? denn das Modul, mod_webdav (oder so ähnlich wird in der httpd:conf nicht geladen.. oder wie kann ich es aktivieren ?
chamaelon879
 
Posts: 6
Joined: 16. February 2007 17:33

Postby Oswald » 17. February 2007 18:42

Hallo chamaelon879!

Ja, einfach die Einstellungen vornehmen.

Vielleicht sollte ich das mit WebDAV auch noch bei Linux mit hinschreiben. :wink:

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby chamaelon879 » 19. February 2007 10:17

wäre supi!!! Vielen Dank für deine Infos und die schnelle Hilfe
chamaelon879
 
Posts: 6
Joined: 16. February 2007 17:33


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest