Perl-addon für xampp, wo ist es hin?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Perl-addon für xampp, wo ist es hin?

Postby neelix » 13. February 2007 23:00

Hallo zusammen,

vielen Dank für das Lesen.

Ich fange gerade an mich mit Webserver, CMS, PHP ... zu beschäftigen.

Ich möchte u.a. auch mich mit Perl befassen. Zunächst wunderte ich mich, warum meine Perl-Skripte im CGI-Bin von xampp-Ordner nicht funktionierten. Ich meine aber es richtig verstanden zu haben, dass Xampp in der ursprünglichen Version Perl nur "rudimentär" unterstützt. Nun habe ich das Perl-Addon zwar für Windows gefunden, aber nichts für Linux. Unter xampp-addon finde ich unter dem Punkt perl nichts mehr. Bin ich blind, suche ich an der falschen Stelle?

Ich benutzte Xampp 1.55a, habe ein Debian-SID Linux System (SIDUX.com) und habe ich Kopf meiner .pl-Dateien bisher immer einfügt:

#!/opt/lampp/bin/perl -w

Aber leider läuft die übliche Datei:

#!/opt/lampp/bin/perl -w
use CGI qw(:standard);
print header();
print "Hallo WorldWideWeb!";

damit eben nicht. Leere Seite im besten Fall.

Auch ein Verweis auf nach

#!/usr/bin/perl -w

läuft nicht.

Vielen Dank schon einmal
Grüße
neelix
User avatar
neelix
 
Posts: 2
Joined: 13. February 2007 11:19

Postby Wiedmann » 13. February 2007 23:07

error_log?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby neelix » 13. February 2007 23:17

Danke für die schnelle Nachfrage:

error.log-Auszug:
[...]
[Mon Feb 12 18:15:44 2007] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Mon Feb 12 18:15:44 2007] [notice] Apache/2.2.3 (Unix) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d PHP/5.2.0 mod_apreq2-20051231/2.5.7
================================================
mod_perl/2.0.2 Perl/v5.8.7 configured -- resuming normal operations
================================================
[Mon Feb 12 20:06:31 2007] [notice] caught SIGTERM, shutting down
[Mon Feb 12 20:08:00 2007] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)

Sieht für mich "normal" aus, oder. Alle Browser die ich verwende, wollen die Datei lediglich downloaden. Nur Opera zeigt mir den "Quelltext" der Datei an.

Gruß, neelix
User avatar
neelix
 
Posts: 2
Joined: 13. February 2007 11:19

Postby Wiedmann » 13. February 2007 23:34

Also theoretisch sollte das gehen (einen XAMPP/Linux hab ich leider keinen).

Alle Browser die ich verwende, wollen die Datei lediglich downloaden. Nur Opera zeigt mir den "Quelltext" der Datei an.

Dann kommt wohl ein falscher Content-Type beim Browser an?

Kannst auch nochmals festlegen, dass wirklich Fehler ausgegeben werden:
Code: Select all
#!/opt/lampp/bin/perl -w

use strict;
use CGI qw/:standard/;
use CGI::Carp qw{fatalsToBrowser};

print header;
print "Hallo WorldWideWeb!";
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest