Probleme mit XAMPP 1.5.5a (Linux) unter kubuntu 6.10 64 bit

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme mit XAMPP 1.5.5a (Linux) unter kubuntu 6.10 64 bit

Postby AxasBraxas » 12. February 2007 21:55

Hallo Leute,

ich wollte hier auf meinem neu installierten kubuntu 6.10 (64 Bit) gerne XAMPP laufen lassen, aber irgendwie will es nicht laufen!

Ausgepackt habe ich es wie in der Anleitung stand, allerdings statt einem su eben ein sudo.

Wenn ich "sudo /opt/lampp/lampp start" aufrufe kommt nach der PW eingabe folgende Fehlermeldung:

Starte XAMPP fuer Linux 1.5.5a...
/opt/lampp/share/lampp/phpstatus: line 4: /opt/lampp/bin/php: No such file or di rectory
XAMPP: Starte Apache mit SSL ...
XAMPP: Fehler 127 beim Starten vom Apache!
XAMPP: Starte Diagnose...
XAMPP: Sorry, ich weiss nicht was da schief laeuft.
XAMPP: Bitte wende Dich ans Forum http://community.apachefriends.org/f/
XAMPP: Starte MySQL...
/opt/lampp/bin/mysql.server: 228: /opt/lampp/bin/my_print_defaults: not found
/opt/lampp/bin/mysql.server: 231: /opt/lampp/bin/my_print_defaults: not found
XAMPP: Starte ProFTPD...
XAMPP: /opt/lampp/lampp: line 302: /opt/lampp/sbin/proftpd: No such file or dire ctory
XAMPP: Fehler 127 beim Starten von ProFTPD!
XAMPP fuer Linux gestartet.

Nun gut ich soll mich hier ans Forum wenden - hier bin ich! :)

Wer kann mir nun sagen was da schief läuft und was ich da falsch gemacht habe? Wäre super wenn ich das hier zum Laufen bekäme!

Besten Dank vorab.

Viele Grüße

Sascha
Mein System: kubuntu 6.10 (Notebook 32 Bit mit KDE 3.5.5 | Haupt-PC 64 Bit mit KDE 3.5.6)
AxasBraxas
 
Posts: 3
Joined: 12. February 2007 21:41

Postby AxasBraxas » 13. February 2007 10:10

Hallo Leute,

irgendwie hat sich das Problem behoben ...

Hatte zwischenzeitlich noch hier in meinem kubuntu 6.10 (64 bit) die ia-32libs nachinstalliert - vielleicht hat das nun das Problem behoben? Auf jedenfall xampp läuft nun.

Konsole sagt mir:

Starte XAMPP fuer Linux 1.5.5a...
XAMPP: Starte Apache mit SSL (und PHP5)...
XAMPP: Starte MySQL...
XAMPP: Starte ProFTPD...
XAMPP fuer Linux gestartet.

Und wenn ich per Browser localhost aufrufe bekomme ich die Seite von xampp zu sehen, scheint also so zu funktionieren.

Viele Grüße

Sascha
Mein System: kubuntu 6.10 (Notebook 32 Bit mit KDE 3.5.5 | Haupt-PC 64 Bit mit KDE 3.5.6)
AxasBraxas
 
Posts: 3
Joined: 12. February 2007 21:41

Postby kleinweby » 13. February 2007 15:51

AxasBraxas wrote:Hatte zwischenzeitlich noch hier in meinem kubuntu 6.10 (64 bit) die ia-32libs nachinstalliert - vielleicht hat das nun das Problem behoben? Auf jedenfall xampp läuft nun.


jo genau, Xampp läuft nur auf 32bit, deswegen brauchst du auf einem 64bit system die 32bit libs.

kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Postby SMILIE » 16. February 2007 18:48

Ich habe das selbe Problem!

Wie kann ich diese ia-32libs installieren?
SMILIE
 
Posts: 2
Joined: 16. February 2007 18:45

Postby kleinweby » 16. February 2007 20:35

hey,

dies kannst du per apt-get z.b. tun oder Synaptic.

kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Postby SMILIE » 17. February 2007 14:26

Danke!

Jetzt funktioniert es!!
SMILIE
 
Posts: 2
Joined: 16. February 2007 18:45

Postby Kismet » 22. March 2007 13:13

hi bin ziemlich neu bei Linux dabei... frage, welche sind die 32 bit libs?
Kismet
 
Posts: 4
Joined: 22. March 2007 12:50

Postby kleinweby » 22. March 2007 14:22

hallo,

du musst das Paket ia-32libs instalieren.

kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Lampp Kubuntu Feisty Missing package ia-32libs

Postby Webmania » 20. April 2007 03:10

Feisty 7.04 for AMD64 hat in kein package ia-32libs in dem Repository!
Hoffe das jemand eine Idea hat wie LAMPP zum laufen gebracht werden kann.
Resolved. See below!
Last edited by Webmania on 20. April 2007 09:28, edited 1 time in total.
Webmania
 
Posts: 6
Joined: 01. April 2006 19:23

Feisty and Lampp

Postby Webmania » 20. April 2007 09:26

See above. Its resolved. Use Synaptic, install all relevant lib32 packages and it works. Search 32lib and NOT 32libs!
But any idea on how to write some scripts that that start and restart Lampp without to use terminal with a simple click in Feisty? I am a newcomer to Kubunto, so any help and advise warmly welcomed.
Webmania
 
Posts: 6
Joined: 01. April 2006 19:23


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests