WebDav verursacht Fehler beim Schreiben

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

WebDav verursacht Fehler beim Schreiben

Postby maxhb » 22. January 2007 23:42

Hallo!
Habe XAMPP mit WebDav eingerichtet und der lesende zugriff auf die Daten klappt auch wunderbar. Bei dem Versuche eineDatei auf den Server zu schieben erscheinteine Fehlermeldung und unter Windows finde ich folgenden Logfile-Eintrag:

01/22/2007 23:26:22
HTTP 404 Not Found
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>404 Not Found</title>
</head><body>
<h1>Not Found</h1>
<p>The requested URL /_vti_bin/shtml.exe/_vti_rpc was not found on this server.</p>
<hr>
<address>Apache/2.2.3 (Unix) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d PHP/5.2.0 mod_apreq2-20051231/2.5.7 mod_perl/2.0.2 Perl/v5.8.7 Server at intranet Port 443</address>
</body></html>

Seltsamerweise wir die Datei shtml.exe auf dem Server vermisst, was bei einem Linux-System kein Wunder ist :lol:

Ist das ein Fehler in XAMP 1.5.5a (vielleicht falsch kompiliert?) oder liegt ein Konfigurationsproblem vor?

Alle notwendigen Module werden in der httpd.conf geladen udn WebDav ist auch aktiviert. WebDav-Config sieht folgendermaßen aus (XAMPP Standard):
#
# Distributed authoring and versioning (WebDAV)
#
# Required modules: mod_dav, mod_dav_fs, mod_setenvif, mod_alias
# mod_auth_digest, mod_authn_file
#

# The following example gives DAV write access to a directory called
# "uploads" under the ServerRoot directory.
#
# The User/Group specified in httpd.conf needs to have write permissions
# on the directory where the DavLockDB is placed and on any directory where
# "Dav On" is specified.

DavLockDB "/opt/lampp/var/DavLock"

Alias /webdav "/opt/lampp/uploads/"

<Directory "/opt/lampp/uploads/">
Dav On

AuthType Digest
AuthName DAV-upload
# You can use the htdigest program to create the password database:
# htdigest -c "/opt/lampp/user.passwd" DAV-upload admin
AuthUserFile "/opt/lampp/user.passwd"

# Allow universal read-access, but writes are restricted
# to the admin user.
<LimitExcept GET OPTIONS>
require user admin
</LimitExcept>
</Directory>

#
# The following directives disable redirects on non-GET requests for
# a directory that does not include the trailing slash. This fixes a
# problem with several clients that do not appropriately handle
# redirects for folders with DAV methods.
#
BrowserMatch "Microsoft Data Access Internet Publishing Provider" redirect-carefully
BrowserMatch "MS FrontPage" redirect-carefully
BrowserMatch "^WebDrive" redirect-carefully
BrowserMatch "^WebDAVFS/1.[0123]" redirect-carefully
BrowserMatch "^gnome-vfs/1.0" redirect-carefully
BrowserMatch "^XML Spy" redirect-carefully
BrowserMatch "^Dreamweaver-WebDAV-SCM1" redirect-carefully


CU
maxhb
User avatar
maxhb
 
Posts: 17
Joined: 18. January 2007 15:08
Location: Bremen

Re: WebDav verursacht Fehler beim Schreiben

Postby maxhb » 23. January 2007 15:40

Hallo!
Mittlerweile haeb ich herausgefunden, dass der o.g. Fehler vermutlich verursacht wird, weil die "Frontpage Server Extension" fehlt.
Ist diese Erweiterung wirklich notwendig, um von Windows (XP) aus auf WebDav-Verzeichnisse zugreifen zu können?

Ich habe mich nun noch einmal am Setup versucht und mich dabei and die Anleitung von heise.de gehalten: http://www.heise.de/netze/artikel/77605

Dort wird auch ohne "Frontpage Server Extension" gearbeitet, leider funktioniert aber auch nach dieser Anleitung der schreibende Zugriff auf die WebDav-Verzeichnisse nicht.

Hat jemand eine Idee, warum lesen funktioniert, schreiben jedoch nicht?

CU
maxhb
User avatar
maxhb
 
Posts: 17
Joined: 18. January 2007 15:08
Location: Bremen

mit Auth Basic geht es

Postby mauwot » 14. February 2007 23:20

Hi

bei mir funkts mit Auth Basic statt Digest. Hast du die Benutzerrechte auch angepasst im Verzeichnis "upload" - mir geht das bei Linux immer unter und legt der im Logs-Verzeichnis die DB.logs an?

Mal noch ne andere Frage: Warum kann ich Dateien in den Webdav kopieren und löschen aber bei Verzeichnissen streikts, die kann ich nur anlegen nicht löschen (nur direkt auf dem Server - nehme mal an wieder son Zugrifsrechte-Problem bei Linux)? Wer weis da was?

Saludos
mauwot
mauwot
 
Posts: 1
Joined: 14. February 2007 23:01

Postby chamaelon879 » 16. February 2007 17:58

@maxhb, also ich bin gerade daran, webdav mit xampp (1.5.5a Linux) zu installieren. aber er bringt mir immer die Fehlermeldung beim kompilieren:

Code: Select all
configure: error: Your APXS installation is broken and cannot be used.
    Please see http://www.webdav.org/mod_dav/install.html#apxs for
    more information.


gestartet habe ich ./configure wie folgt:
Code: Select all
laptop:/home/markus-l/Desktop/mod_dav-1.0.3-1.3.6 # ./configure --with-apxs=/opt/lampp/bin/apxs

Der Fehler wird auch beschrieben bei webdav.org

könntest du mal schnell posten, wie du es installiert bekommen hast ?!? wäre wirklich supi!!
chamaelon879
 
Posts: 6
Joined: 16. February 2007 17:33

Postby maxhb » 16. February 2007 18:05

chamaelon879 wrote:könntest du mal schnell posten, wie du es installiert bekommen hast ?!?

Kann ich leider nicht sagen, habe XAMPP nicht kompiliert, sondern die fertige Distri verwendet.

CU
maxhb
User avatar
maxhb
 
Posts: 17
Joined: 18. January 2007 15:08
Location: Bremen


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest