PHP Dateien werden teilw. nicht abgearbeitet

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

PHP Dateien werden teilw. nicht abgearbeitet

Postby TimeBandit » 20. January 2007 15:08

Hallo zusammen,

ich verzweifle hier schon seit Tagen an einem wirklich blöden Problem. Es werden - jedoch nur teilweise - PHP Dateien zum Download angeboten statt ausgeführt.

Ich benutze XAMPP 1.5.5.a, also neueste Version. Mein Betriebssystem ist Kubuntu 6.06 und ich habe eine lokale Kopie des CMS Joomla installiert. Auf dem Live-Server läuft mein CMS einwandfrei. Die Daten sind per FTP gedownloaded, die Datenbank per phpMyAdmin gesichert und wieder eingespielt. Die configuration.php ist angepasst und die Site wird auch angezeigt. Auch die Administration der Site funktioniert - aber nur teilweise! Hier kann ich einzelne Menüpunkte nicht aufrufen. Da wird mir dann die PHP-Datei zum Download angeboten.

Besitzer und Gruppe der Dateien laufen unter meinem Useraccount. Die Dateien habe ich mittlerweile einfach komplett auf 777 umgestellt, damit ich hier keine Rechteprobleme habe.

Das CMS verlangt PHP4, dieses ist auch eingestellt. Die Datenbank auf dem Live-Server ist eine MySQL 4er Datenbank und der Apache ist noch aus der 1er Serie. Kann es hier zu Problemen kommen wegen der abweichenden Versionen, vor allem bei MySQL?

Die register-globals sollen auf "off" gestellt werden, habe ich in der php.ini auch gemacht.

Auch eine Testinstallation des CMS scheitert - die Installationsdatei wird nicht gefunden. Ich weiß einfach nicht mehr wo ich noch suchen soll. Liegt der Fehler nun bei XAMPP, den Rechten oder ist hier mit Joomla! ein Problem? Wobei ich Joomla! eigentlich ausschließe, denn live läuft es, bringt keine Fehlermeldungen bzgl. der Server und hat mit den Dateirechten 777 nirgends Zugriffprobleme.
TimeBandit
 
Posts: 2
Joined: 20. January 2007 14:03
Location: Saarbrücken

Postby TimeBandit » 28. January 2007 11:43

Hallo,

wollte ich mal nochmal in Erinnerung bringen. Ich komme mit diesem Problem definitiv nicht weiter und dieses Forum ist meine letzte Hoffnung. Wenn ich hier keine Hilfe bekomme, dann ist mir nicht möglich, eine lokale Kopie und Testumgebung einzurichten.

Bin für jeden Tipp oder auch Link zu anderen Foren und/oder Tutorials, die mir bei der Problemlösung helfen sehr dankbar.

Gruß TimeBandit.
TimeBandit
 
Posts: 2
Joined: 20. January 2007 14:03
Location: Saarbrücken

Re: PHP Dateien werden teilw. nicht abgearbeitet

Postby trudodyr » 23. February 2007 21:59

TimeBandit wrote:ich verzweifle hier schon seit Tagen an einem wirklich blöden Problem. Es werden - jedoch nur teilweise - PHP Dateien zum Download angeboten statt ausgeführt.

Ich habe ein ähnliches Problem mit XAMPP 1.6 unter Ubuntu 6.10 - einige php-Dateien werden korrekt ausgeführt (etwa die kleinen Demo-Programme oder phpSQLiteAdmin), bei anderen kommt jedoch nur das Download-Fenster (phpMyAdmin, VideoDB).

Das Problem tritt nur dann auf, wenn ich von einem anderen Rechner im Intranet auf den Webserver zugreife, und dann auch nur, wenn ich die IP (192.168.1.2) angebe, als localhost bzw. unter Verwendung des Hostnames ("archiv") besteht dieses Problem nicht. Jemand ne Idee?
trudodyr
 
Posts: 1
Joined: 23. February 2007 21:55


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests