keine Seite erreichbar auch xampp nicht

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

keine Seite erreichbar auch xampp nicht

Postby mraia » 04. December 2006 17:48

hallo xampp-gurus,

ich habe ein debian system mit webmin installiert, leider ist weder xampp noch eine andere domain auf dem server erreichbar! xampp ist gestartet!

jetzt beschäftige ich mich seit 1 woche damit und kriegs einfach nicht gebacken! im forum finde ich auch nichts was mich wirklich weiter hilft!

habe auch vieles getest:
EnableSendfile off/on, IE Cache geleert ect.

im logfile steht:
[Mon Dec 04 17:52:33 2006] [error] [client 194.158.241.198] File does not exist: /opt/lampp/htdocs/nova/xampp

was sicher merkwürdig ist, ist dass der server das xampp verzeichnis im /opt/lampp/htdocs/nova/xampp sucht, obwohl es im /opt/lampp/htdocs/xampp ist!

hat jemand ne idee was da falsch sein könnte?

danke und gruss marco
mraia
 
Posts: 5
Joined: 04. December 2006 17:13

Postby deepsurfer » 04. December 2006 17:59

Im logfile steht:
[Mon Dec 04 17:52:33 2006] [error] [client 194.158.241.198] File does not exist: /opt/lampp/htdocs/nova/xampp

was sicher merkwürdig ist, ist dass der server das xampp verzeichnis im /opt/lampp/htdocs/nova/xampp sucht, obwohl es im /opt/lampp/htdocs/xampp ist!


Nicht wirklich, denn was das Logfile dort beschreibt ist ja die Abfrage die man mit dem Browser durchführt.

In diesem speziellen Fall wurde http://domain/nova/xampp aufgerufen.
Und dieses wird negative Quitiert und im Logfile verewigt.

Hast du denn etwas an den Configdateien des XAMPPs geändert ?
Wenn ja, was genau !!
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby mraia » 04. December 2006 18:14

hallo chirio,

danke für deine schnelle antwort! nein geändert habe ich nichts, wie schon gesagt nur die tests mit den EnableSendfile off/on durchgeführt!

merkwürdigerweise ist http://193.246.200.40/phpmyadmin/ über web erreichbar!

die fehlermeldung kommt, wenn ich xampp über web erreichen will http://193.246.200.40/xampp

ich verstehe einfach nicht warum der server das im /opt/lampp/htdocs/nova/xampp sucht!

danke und gruss marco
mraia
 
Posts: 5
Joined: 04. December 2006 17:13

Postby deepsurfer » 04. December 2006 18:28

ich verstehe einfach nicht warum der server das im /opt/lampp/htdocs/nova/xampp sucht!

Ok...kann man reproduzieren.

Schau mal bitte in die httpd.conf ob Zeile 179
Code: Select all
#
# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "/opt/lampp/htdocs"

so aussieht.

Und Zeile 207:
Code: Select all
#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "/opt/lampp/htdocs">
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby mraia » 04. December 2006 20:07

hallo chirio,

die einstellungen:
DocumentRoot --> "/opt/lampp/htdocs"
Directory --> "/opt/lampp/htdocs"

sind richtig!

gruss marco
mraia
 
Posts: 5
Joined: 04. December 2006 17:13

Postby deepsurfer » 04. December 2006 20:51

Lösche mal deinen Browser-Cache !

seite testen und melden
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Da wirst Du wohl einiges mehr ändern müssen

Postby schnullerbacke » 09. December 2006 08:34

Zunächst mal, der XAMPP lädt die http_vhosts.conf nicht. Ich würde aber die virtuellen Hosts grundsätzlich nur dort anlegen. Um das zu erreichen mußt Du in der /opt/lampp/etc/httpd.conf im Abschnitt:

#Supplemental configuration

die Kommentierung (#) vor den Includes beseitigen.

Du kannst da einfach alles wegnehmen, das richtet keinen Schaden an.

Wenn Deine virtuellen Hosts nur von einer bestimmten IP (192.168.xxx.xxx) aus erreichbar sein sollen, dann mußt in /opt/lampp/etc/extra/http_vhosts.conf:

NameVirtalHost 192.168.xxx.xxx:80

setzen.

Danach definierst Du deine virtuellen Server:

# der hier wird aufgerufen wenn keine passende URL vom Browser kommt
<Vitualhost 192.168.xxx.xxx:80>
ServerName localhost
DocumentRoot /opt/lampp/htdocs
<Directory "/opt/lampp/htdocs">
allow from all
Options FollowSymLinks Indexes
</Directory>
</Vitualhost>

# der hier, wenn die URL stimmt
<Vitualhost 192.168.xxx.xxx:80>
ServerName www.nova.de
ServerAlias *.nova.de
DocumentRoot /opt/lampp/htdocs/nova
<Directory "/opt/lampp/htdocs/nova">
allow from all
Options FollowSymLinks Indexes
</Directory>
</Vitualhost>

Wenn Du an allen Schnittstellen den Zugriff erlauben willst, dann kannst die IP in den Definitionen durch * ersetzen. Das hängt von deiner Firewall-Konfig ab, wie Sinnvoll das ist. Wenn nur eine Schnittstelle nach außen geführt wird ist die Bindung an diese IP besser.

Das ist die IP von Deiner Netzwerkkarte, also die interne.

Nun haben aber die XAMPP-Leute in der httpd.conf ganz am Ende:

NameVirtualHost *:80

eingetragen und damit die vhosts.conf praktisch zurückgesetzt. Die Zeile mußt Du auskommentieren (# davor setzen).

Bei den virtuellen Hosts mußt Du mit den verschiedenen Direktiven mal etwas rumprobieren. Bei Options lassen sich noch ne Menge andere Sachen setzen, das ist Geschmackssache.

Du kannst dir aber zur Vereinfachung auch den webmin runterladen und installieren. Da muß nur die Modulkonfiguration auf den XAMPP angepaßt werden. Das ist zwar etwas lästig, weil man die Verzeichnisse ändern muß und die Aufrufparameter für den apachen an den XAMPP anpassen muß. Aber dann kann man den Server schick verwalten. Du kannst aber symbolische Links in /etc:

ln -s /opt/lampp/etc/httpd.conf httpd.conf

und:

ln -s /opt/lampp/etc/extra apache2

legen. Vorher natürlich:

cd /etc. Dann sollte webmin das sofort richtig finden.
schnullerbacke
 
Posts: 8
Joined: 08. December 2006 15:58

Postby mraia » 10. December 2006 20:12

hallo schnullerbacke

die tips sind sehr ausführlich, aber bringen mich nicht wirklich weiter, da ich keinen eintrag #Supplemental configuration im httpd.conf file habe und auch kein verzeichnis das der name opt/lampp/etc/extra hat! das muss bei einer neueren version der fall sein!

nun habe ich webmin und xampp deinstalliert und xampp 1.4.16 neu installiert ohne webmin!

trotzallem ist xampp immer noch nicht erreichbar, das heisst die startseite von xampp kommt und wenn ich auf die sprachauswahl klicke kommt dieser fehler: HTTP 404 - Datei nicht gefunden!
aber mein webangebot und phpmyadmin funktionieren eiwandfrei!

NameVirtualHost nova02.novaweb.ch
<VirtualHost nova02.novaweb.ch>
ServerAdmin info@novaweb.ch
DocumentRoot "/opt/lampp/htdocs/xampp"
ServerName nova02.novaweb.ch
ErrorLog /opt/lampp/logs/error_log
CustomLog /opt/lampp/logs/access_log common
</VirtualHost>

NameVirtualHost www.nova-handel.ch
<VirtualHost www.nova-handel.ch>
ServerAdmin info@nova-handel.ch
DocumentRoot "/opt/lampp/htdocs/nova"
ServerName nova-handel.ch
ErrorLog /opt/lampp/logs/error_log
CustomLog /opt/lampp/logs/access_log common
</VirtualHost>


im logfile steht:
[Sun Dec 10 20:19:35 2006] [error] [client 194.158.241.198] File does not exist: /opt/lampp/htdocs/xampp/xampp, referer: http://nova02.novaweb.ch/splash.php

merkwürdig ist, dass der server das xampp verzeichnis im /opt/lampp/htdocs/xampp/xampp sucht, obwohl es im /opt/lampp/htdocs/xampp ist!

hat jemand ne idee was da falsch sein könnte?

danke und gruss marco
mraia
 
Posts: 5
Joined: 04. December 2006 17:13

Postby mraia » 10. December 2006 20:33

hallo

habe mit meinem zweiten server, der genau gleich konfiguriert ist noch einmal die xampp verzeichnisse verglichen! dabei ist mir aufgefallen, dass sich die lang.tmp files mit der grösse unterscheiden!
beim öffnen der files habe ich festgestellt, dass der funktionierende server ein eintrag mit "de" hat und habe dies auf dem nichtfunktionierende server angepasst!
jetzt komme beim starten von xampp über den browser direkt ohne sprachauswahl und fehler auf die gewünschte seite!

weiss zwar immer noch nicht was dies für auswirkungen hat aber es funktioniert jetzt einwandfrei!

gruss marco
mraia
 
Posts: 5
Joined: 04. December 2006 17:13

Postby deepsurfer » 11. December 2006 14:18

Dann hast du sicherlich nach der Installation von XAMPP direkt mit den VHOST Einträgen gearbeitet ohne zuvor die Installation des XAMPPs (Willkommenscreen) zu prüfen, denn damit wird erst die lang.tmp nach der Sprach auswahl angelegt.

Das du eine Fehlermeldung erhalten hast bezüglich aufruf des VHOSTs hast du nicht näher geschrieben, denn sicherlich stand in der Fehlermeldung das ein Fehler in der index.php Zeile 2 vorhanden ist.

Allein diese Meldung hätte die Hilfe hier im Forum um etliches Verkürzt, da damit direkt zu sehen ist das es sich um die lang.tmp Datei handelt.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests