mysql speichert keine Datensätze

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

mysql speichert keine Datensätze

Postby Mueckensturm » 15. August 2003 21:13

Hi,

ich habe ein Problem mit mySQL in xampp.
Ich habe mir ein kleines Skript geschrieben, dass Datensätze aus einer MySQL Datenabank ausliest und eben auch einfügt. Und letzteres geht nicht. Ich bin mir allerdings nicht mehr so sicher ob das an meinem Skript liegt. Ich bekomme nämlich
1.) keinerlei Fehlermeldung und
2.) hat es schon einmal funktioniert nämlich unter lampp-0.9.8pre.1 Dann habe ich nach einem PC-Wechsel lampp-1.1 installiert und jetzt funktioniert es nicht mehr.
Damit ich die alten Daten weiter nutzen kann habe ich einfach das Verzeichniss mit meinem Datenbanknamen aus der alten Installation in die neue nach /opt/lampp/var/mysql/ kopiert.
Was mich ja wundert ist das das Auslesen ohne Probleme geht aber das speichern eben nicht.
Ich hoffe ihr könnt mir da etwas helfen.
Ich benutze Suse8.1 personal, falls das wichtig ist.
Vielen Dank für die Hilfe.


Gruß Mücke
Mueckensturm
 

Postby Pc-dummy » 16. August 2003 09:19

Hi

Ich schätze mal das Problem entweder an den Rechten liegt oder daran das sich die MySQL Version sich seit 0.9.8pre1 vielfach geändert hat!

Am besten du installierst dir nochmal 0.9.8pre1 machst dann ein Dump deiner SQL-DB's und installierst dann wieder 1.1 und importierst da die daten wieder!

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby Oswald » 16. August 2003 13:10

Huhu Mücke,

ich glaube auch, dass es an den Zugriffsrechten liegt.

Ruf bitte einfach folgendes mal auf:

chown -R nobody /opt/lampp/var/mysql

Danach noch mal probieren, evtl. MySQL noch mal neu starten.

Viel Erfolg,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Mueckensturm » 17. August 2003 14:00

Danke das mit dem Berechtigung ändern hat funktioniert.
Vielen Dank.

Gruß Mücke
Mueckensturm
 


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests