aufruf von privaten webseiten -> geht das so?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

aufruf von privaten webseiten -> geht das so?

Postby pir187 » 14. August 2003 14:48

servus,

ich betreibe meinen webserver, der seine dateien aus "/opt/lampp/htdocs" bezieht.

nun will ich, daß bei aufruf von "http://<ip_des_servers>/~nutzer1" die datei "/home/nutzer1/public_html/index.html" aufgerufen wird.

ich habe den eintrag "UserDir public_html" schon gefunden, und bei manueller Config, d.h., als ich einmal privat den apachen + php + ... manuell kompiliert und installiert hatte, öffnete sich dann auch dieser Ordner, nur leider kommt in meinem fall mit lampp der fehler:

Forbidden
You don't have permission to access /~nutzer1 on this server.


die rechte für alle ordner bis zum ziel "/home/nutzer1/public_html" stehen auf 755, woran liegt es denn dann?

ich dachte, ich bin mit dem linux-rechtesystem nicht gerade auf kriegsfuß - weit gefehlt anscheinend :?


thx 4 ur help!
der pir
pir187
 
Posts: 76
Joined: 13. August 2003 00:15
Location: Struppen / Sachsen

Postby Oswald » 14. August 2003 14:49

In dem public_html ist auch eine index.html?
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

thx 4 the hint!

Postby pir187 » 14. August 2003 14:54

ach na sowas, ich hätte das fehlen der index.html als letztes als ursache in betracht gezogen, nachdem ich die erstellt habe, geht es!

komischerweise hat er mir, als ich das "/opt/lampp/htdocs" leer geräumt hatte, dann wenigstens den apache-ordner, der drunter liegt, angezeigt, ich habe deshalb schlußgefolgert, daß er mit nun wenigstens den ordner im "ftp-server-im-browser" - stil anzeigt!

deshalb meine frage :shock: ...


trotzdem danke, man lernt eben nie aus!
gruß, pir187
pir187
 
Posts: 76
Joined: 13. August 2003 00:15
Location: Struppen / Sachsen

Postby Oswald » 14. August 2003 14:57

Huhu Pir!

Da liegt daran, dass /opt/lampp/htdocs anders konfiguiriert ist. Siehe die <Directory>-Blöcke in der httpd.conf.

Um das gleiche Verhalten auch bei den Benutzern zu haben einfach folgende Änderung an der httpd.conf vornehmen (ab Zeile 369):

<Directory />
Options FollowSymLinks Indexes
AllowOverride None
</Directory>

(die Änderung ist hervorgehoben)

Sollte so funktionieren. Habs aber nicht ausprobiert.

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby pir187 » 14. August 2003 15:32

thx, werde ich gleich mal testen...

mann, mann, mann, du bist ja omnipräsent hier im forum :!: :!: :!: was machst du eigentlich beruflich (wenn ich mal fragen darf), daß du immer gleich zur stelle sein kannst (zeitlich gemeint)?

pir187
pir187
 
Posts: 76
Joined: 13. August 2003 00:15
Location: Struppen / Sachsen

Postby Oswald » 14. August 2003 16:40

Huhu Pir!

Ich arbeite als Administrator und Software-Entwickler und hab meistens schon die Zeit hier ab und zu mal reinzuschauen. Aber so oft ist es auch nicht. Sieht vielleicht "schlimmer" aus als es wirklich ist. ;)

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests