PHP-Problem!!!!

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

PHP-Problem!!!!

Postby Guest » 30. January 2003 15:06

Hallöchen!

Habe LAMPP installiert und nach anfänglichen Schwierigkeiten lief es dann auch eigentlich ohne Probleme. Ausser folgendes:

Image
Image
Image

Kann mir einer sagen woran das liegen könnte?
Ich hab mir Debian Linux per Netz installiert.
Guest
 

Postby spider » 30. January 2003 15:09

:D Der Eintrag oben ist von mir, das mit dem einloggen hatte irgendwie nicht ganz geklappt, sry! :oops:
User avatar
spider
 
Posts: 7
Joined: 30. January 2003 14:50
Location: Essen

Postby Oswald » 30. January 2003 15:28

Hallo spider!

Das ist in der Tat nicht schön.

Wie hast Du LAMPP installiert? Mit dem Befehl aus der Installationsanleitung oder irgendwie anders?

Was gibt der Befehl md5sum /opt/lampp/htdocs/xampp/status.php
für einen Wert aus?

Grüß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby spider » 30. January 2003 15:40

Das ging ja flott! :)

Also ich hab unter meinem XP-Rechner das lampp-file gezogen. Auf meinem kleinen Debian-Server hatte ich zuvor Samba installiert und dann das File von XP auf den Server kopiert. Dann bin ich per ssh auf den server gegangen und hab tar xvfz lampp.... eingegeben. Dann noch die kleine Änderung in der httpd.conf, weil der immer ne Fehlermeldung ausgab (die mit dem suexec... blablabla stand ja auf der FAQ-Seite).
Ja und das war es auch schon

md5sum gibt mir folgendes aus:
0664c8dcc2a36ab931dcc57999f56759 /opt/lampp/htdocs/xampp/status.php
User avatar
spider
 
Posts: 7
Joined: 30. January 2003 14:50
Location: Essen

Postby spider » 30. January 2003 15:50

Ach, nochwas zur kleinen Information!

Ich hab mir mal den Quelltext im Browser anzeigen lassen, nachdem ich die status.php aufgerufen habe. Da steht der komplette <? ...?> php-Teil in voller Pracht, ohne das der bearbeitet wurde. vielleicht hilft das ja auch weiter. Also es scheint als wenn das PHP-Modul gar nicht geladen wurde. Hab ich vielleicht bei meiner debian Installation irgendwelche libs oder so nicht mitinstalliert die von nöten sind, oder irgendwelche Progs??
User avatar
spider
 
Posts: 7
Joined: 30. January 2003 14:50
Location: Essen

Postby Oswald » 30. January 2003 16:09

Huhu spider!

Das mit dem PHP-Code ist ne gute Information.

Hmm.. nein, eigentlich brauchst Du nichts weiter. Ich stelle LAMPP auch unter Debian zusammen und daher sollte es gerade mit Debian keine Probleme geben. Aber schauen wir mal...

Was hast Du in der httpd.conf bzgl. suexec genau geändert?
Welche Debian-Version hast Du?

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby spider » 30. January 2003 16:14

http.conf-Änderung wie in FAQ beschrieben:

#ScoreBoardFile logs/apache_runtime_status

Das Doppelkreuz (#) am Anfang wegnehmen und daraus folgendes machen:

ScoreBoardFile logs/apache_runtime_status

Welcher Debian Verion ich hbe ist ne gute Frage! :) Ich habe mir getsern abend die 6 Installationsdisketten gezogen die reingeschoben und dann die Quellen aus dem Netz genommen. Sollte also eigentlich das neuste sein was auf dem Server rumliegt.
User avatar
spider
 
Posts: 7
Joined: 30. January 2003 14:50
Location: Essen

Postby Oswald » 30. January 2003 16:21

Achso... ScoreBoardFile.. klar. Du hattest suexec geschrieben... ;)

Debian wird dann wohl die akutelleste Version sein. Gut.

1. Kannst Du mal md5sum /opt/lampp/etc/httpd.conf aufrufen? Wenn was anderes als ca8d9a749853a552dbb8c3af19a9070c rauskommt, dann mail mir bitte mal die Datei an oswald@apachefriends.org.

2. Mach mal bitte telnet localhost 80 und tipp dann ein GET /xxx HTTP/1.0 und zwei mal Return. Dann sollte eine Ausgabe kommen, wo unter anderem drin steht:

Server: Apache/2.0.44 (Unix) mod_ssl/2.0.44 OpenSSL/0.9.6h PHP/4.3.0 DAV/2

Sieht diese Zeile bei Dir auch so aus oder fehlt da evtl. das PHP/4.3.0?

Bin gespannt... ;)

Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby spider » 30. January 2003 22:36

Hallöchen!

Also ich habe beides ausprobiert! die checksum stimmt überein und GET ... liefert mir als Server:

Apache/2.0.44 (Unix) mod_ssl/2.0.44 OpenSSL/0.9.6h PHP/4.3.0 DAV/2
User avatar
spider
 
Posts: 7
Joined: 30. January 2003 14:50
Location: Essen

Postby Oswald » 31. January 2003 12:16

Okay. Okay. Auch dieses Problem kriegt wieder die Goldmedaille für Ungewöhnlichkeit. ;)

Nächster Test:
Kannst Du noch mal auf ein PHP-Programm (secuity check oder status) zugreifen und dann mal tail /opt/lampp/logs/error_log aufrufen. Steht da irgendwas fehlermeldungenmäßiges?

Grüße,
Bughunter-Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Morpheus » 01. February 2003 15:39

Könnte nicht auch einfach PHP in der httpd.conf ausgeschaltet sein?
Morph
Morpheus
 
Posts: 218
Joined: 17. January 2003 20:58

Postby Oswald » 01. February 2003 15:51

Moin Morpheus!

Das ist auch meine erste Vermutung gewesen.

Aber spider hat ja gesagt, er hätte an der httpd.conf nichts weiter geändert und auch die Checksumme, die ich weiter oben über die httpd.conf gemacht hat, konnte er auch bestätigen. Die httpd.conf entspricht also bis auf das # bei ScoreBoardFile genau der Standard-httpd.conf und halt also PHP eingeschaltet.

Ein seltsames Probleme. Aber ich hoffe im error_log steht irgendwas aussagekräftiges drin.

Schönes Wochenende,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Morpheus » 01. February 2003 16:18

hi spider
kannst du den mal nachschaun, ob dies in der httpd.conf forhanden ist.

Unter <directory /pfad/zu/docroot>
ein Eintrag wie dieser:
Options All MultiView

Morph
Morpheus
 
Posts: 218
Joined: 17. January 2003 20:58

Postby spider » 02. February 2003 20:07

So sieht die error_log aus:

[Sun Feb 02 20:23:33 2003] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Feb 02 20:23:34 2003] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Sun Feb 02 20:23:38 2003] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Feb 02 20:23:39 2003] [notice] Digest: generating secret for digest authentication ...
[Sun Feb 02 20:23:39 2003] [notice] Digest: done
[Sun Feb 02 20:23:40 2003] [notice] Apache/2.0.44 (Unix) mod_ssl/2.0.44 OpenSSL/0.9.6h PHP/4.3.0 DAV/2 configured -- resuming normal operations

@morpheus:
Ein solcher Eintrag steht nicht drin! was da steht ist folgendes:
Options Indexes FollowSymLinks ExecCGI Includes
User avatar
spider
 
Posts: 7
Joined: 30. January 2003 14:50
Location: Essen

Postby Oswald » 03. February 2003 00:13

Huhu spider!

Okay, auch keine Fehlermeldung in der error_log (die Meldungen, die bei Dir drin stehen sind quasi normal). Mein letzter Rat: ich installier mir morgen ein Debian 3.0 und schau mal ob ich bei mir auch sowas feststellen kann.

Eine Frage noch: Läuft das Debian auf einem richtigen PC oder auf irgendeinem Software-Simulations-PC?

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Next

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests