Firefox will index.php runterladen

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Firefox will index.php runterladen

Postby VinceWindel » 29. September 2006 15:57

Hallo,

bin noch ziemlich neu in Linux. Hab heute Xampp draufgemacht.
Es läuft soweit alles.
Aber wenn ich jetzt localhost im Browser aufruf will mein Firefox Die Datei runterladen
(application/x-httpd-php). Konqueror auch. (Susue 10.1).
Was muss ich ändern, dass dies nicht mehr der Fall ist?
chmod hab ich auch schon gemacht

Gruß

Vincent
VinceWindel
 
Posts: 10
Joined: 27. August 2006 21:32

Postby deepsurfer » 29. September 2006 16:15

Vorab !
Meinst du eine eigen index.php oder passiert es schon nachdem du den XAMPP gestartet hast und im Browser http://localhost aufrufst ??

Zusatsfrage:
Sicher gestellt das XAMPP auch richtig gestartet ist ??
Ich frage deswegen weil bei einer Ottonormal-Suse10.1-Installation der Apache von SuSE gestartet wird.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby VinceWindel » 29. September 2006 16:20

schon bei localhost die index.php. Noch keine eigene

Ich hab damals mein Linux recht klein gehalten und ohne Apache installiert. Der Server scheint auch problemloß zu laufen. Kommt zumindest keine Fehlermeldung.. außer wenn ich das Panel starten will:

Traceback (most recent call last):
File "xampp-control-panel.py", line 21, in ?
import gtk
ImportError: No module named gtk


Gruß, Vincent

eidt: (glaub zwar net dass es einen unterschied macht aber) ich hab mit suse schon mySql installiert...
VinceWindel
 
Posts: 10
Joined: 27. August 2006 21:32

Postby deepsurfer » 29. September 2006 16:31

Ok.. zu dem Panel vermute ich das du das Lampp-Control von Kleinweby aus dem Addon bereich benutzt.

Die Fehlermeldung beruht darauf das auf deinem SuSE keine gtk Libarys installiert sind.

--------------

Ok..back to the roots:

Fragen nerven, aber müssen sein.

1) XAMPP für Linux original von apachefriends downgeloaded ?
- welche Version

2) XAMPP mit <root> Rechten und dem richtigen Befehl entpackt ?

3) XAMPP mit <root> Rechten und dem richtigen Befehl gestartet ?

4) auch wenn eine eigene Minimal Installation, möglicherweise SuSE10.1 Firewall am laufen die Port 80 blockiert

5) Hast du eventuell Änderungen an der httpd.conf des XAMPP-Apachen durchgeführt ?

6) versuch mal wenn XAMPP gestartet ist http://localhost/xampp/phpinfo.php
- wenn hier auch ein Download kommt, stimmt gewaltig etwas nicht.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby VinceWindel » 29. September 2006 16:48

also... na ja gtk war installiert^^
Aber das brauch ich ja nicht unbedingt glaub ich...

1) von apachefriends runtergeladen, version 1.5.4

2) xampp mit root (anders geht's gar nicht: bei der installation als "nicht-root" wird man dazu ermahnt sich als root anzumelden). Befehle von der Homepage.

3) xampp als root gestartet... befehl auch von der Homepage: /opt/lampp/lampp start

4) Suse Firewall? - neee da is nichts

5) http.conf hab' ich noch nich gefunden^^ aber gesucht -> Hab' was über MIME Type gelesen.

6) und......... luftsprung .................. http://localhost/xampp/phpinfo.php funktioniert

Gruß Vincent
VinceWindel
 
Posts: 10
Joined: 27. August 2006 21:32

Postby deepsurfer » 29. September 2006 17:00

zu 6....

Wenn das nun geht sollte auch der normale Aufruf http://localhost funktionieren.

Es wird hierbei eine index.html ausgeführt die einen null sekunden META weiterlerleitung in das http://localhost/xampp vornimmt.

Dort wird wiederrum durch eine automatische abfrage die darin befindliche
index.php gestartet.

Diese veranlasst zu prüfen ob eine lang.tmp vorhanden ist, wenn nein, dann Sprachauswahl, wenn ja dann weiter mit dem Willkommenscreen.

Da aber nun bei dir sich das PHPinfo meldet muss es gehen.

Bitte nochmal testen und zuvor auch den BrowserCache leeren, denn darin kann es auch zu problemen kommen wenn zuvor fehler auf Loclahost waren.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby kleinweby » 29. September 2006 17:07

deepsurfer wrote:Ok.. zu dem Panel vermute ich das du das Lampp-Control von Kleinweby aus dem Addon bereich benutzt.


Das ist nict mein Programm sondern das Panel was von hausaus mitgeliefter wird. Dieses ist in Python geschrieben und braucht deswegen pygtk. Dies müsste noch instalier werden damits geht.

*Werbung* Aber du kannst auch gerne mein Lampp Control benutzen dies kann etwas mehr als das Hauseigenepanel klick!

kleinweby :)

Edit: irgentwie binn ich heute zzu doof bbcode richtig einzusetzen *g*
Last edited by kleinweby on 29. September 2006 17:10, edited 2 times in total.
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Postby VinceWindel » 29. September 2006 17:08

JUHUUUUUUUUUUUUUU!!!!!!!!!!!
Es geht!!!
War so wie's aussieht nur der Cache... *schäm* :oops: :oops: :oops:
Sorry
aber danke dass es jetzt funzt

Grüßle und thx,
Vincent

edit: Mit dem Panel werd' ich doch glatt mal ausprobiern ;-)
VinceWindel
 
Posts: 10
Joined: 27. August 2006 21:32

Postby deepsurfer » 29. September 2006 17:21

huuuiiii das panel kannte ich ja noch garnicht....tztztztz...zigmal den xampp auseinander genommen und immer wieder übersehen.....




happy XAMPP @VinceWindel
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests