MySQL Server will nicht starten

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Postby Prophet05 » 18. September 2006 17:18

deepsurfer wrote:Womit und wie ??? (mit "nmap localhost" ??)

Ich habe das Administrationstool "Netzwerkdiagnose" verwendet und einen Portscan auf 127.0.0.1 durchgeführt.
Das Programm "nmap" gibt es auf meinem Rechner scheinbar nicht. Wenn ich es versuche kommt nur ein: "Befehl nicht gefunden."

deepsurfer wrote:netstat -lntu

Habe ich gemacht jedoch wurde Port 3306 dort nicht aufgeführt.

Wurde mein MySQL Server vll falsch Konfiguriert? Wo kann ich das überprüfen?
Prophet05
 
Posts: 17
Joined: 09. April 2006 12:29

Postby deepsurfer » 19. September 2006 11:43

Wurde mein MySQL Server vll falsch Konfiguriert? Wo kann ich das überprüfen?

Bei dieser Frage tu ich mich unheimlich schwer, denn.....

Diese Frage suggeriert mir das du ausser XAMPP (incl. dessen MyMSQL) noch einen weiteren MySQL Server installiert hast.
Das aber aufgrund der Tests wohl nicht gestartet ist, sonst würde Port 3306 in den "netstat" auftauchen.

Und wenn ich davon ausgehe das du im XAMPP nichts geändert hast, so kann ja nichts Verstellt sein sonst würde das Forum überfüllt mit dieser Frage sein.

---------

Was mit noch in den Sinn kommt.

Startest du den XAMPP auch mit dem richtigen Befehl und wird dieser startbefehl auch mit <root> Rechten vollzogen ????
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Prophet05 » 19. September 2006 15:04

deepsurfer wrote:Und wenn ich davon ausgehe das du im XAMPP nichts geändert hast, so kann ja nichts Verstellt sein sonst würde das Forum überfüllt mit dieser Frage sein.

Ich habe nur etwas an der httpd.conf und der php.ini verändert. Kann also nicht sein, wei du bereits sagtest.

deepsurfer wrote:Startest du den XAMPP auch mit dem richtigen Befehl und wird dieser startbefehl auch mit <root> Rechten vollzogen ????

Ja, ich starte dazu immer eine Root-Terminal und verwende den befehl lampp start

Soll ich vll einfach mal versuche XAMPP neuzuisntallieren?
Prophet05
 
Posts: 17
Joined: 09. April 2006 12:29

Postby deepsurfer » 19. September 2006 15:10

Ja, ich starte dazu immer eine Root-Terminal und verwende den befehl lampp start

Rootfenster is OK, befehl so wie du ihn da schreibst kann nicht gehen.

Soll ich vll einfach mal versuche XAMPP neuzuisntallieren?

Machen kannst du es ja....aber ich vermute einfach das dieses Problem trotzdem wieder auftaucht.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Prophet05 » 19. September 2006 15:32

Das ist der Startbefehl oder?
Code: Select all
/opt/lampp/lampp start


deepsurfer wrote:Machen kannst du es ja....aber ich vermute einfach das dieses Problem trotzdem wieder auftaucht.


Hast du sonst irgendeine andere idee weshalb das nicht geht?
Prophet05
 
Posts: 17
Joined: 09. April 2006 12:29

Postby deepsurfer » 19. September 2006 15:50

jupp. jetzt ist der befehl richtig....

Ich war deswegen so pedannt, weil es einige Künstler gibt die es falsch machen und es nicht verstehen.

Eine weitere Idee.....hhhmmm....
Eigentlich jetzt nicht, die notwendigen tests haste ja durchgegangen.

Versuch mal folgendes:
(root konsole)

/etc/init.d/mysql stop
eventuell aber
/etc/init.d/mysqld stop

wenn ein MySQL im System installiert und läuft sollte er damit beendet werden.
Erhältst du eine Fehlermeldung ("Datei oder Verzeichnis nicht gefunden")
kann es daran liegen das es nicht Installiert ist oder auf einen anderen Pfad liegt. Hier wäre dann ein
updatedb das läuft einige Minuten bis die Eingabe wieder möglich ist (platten geräuche sollten zu hören sein)
danach mal locate mysql.

Es erscheint entweder nur eine Liste bezogen auf den XAMPP (/opt/lampp/..)
oder es erscheint sogar der mögliche Installierte MySQL.
Wenn dem so ist kannst du den Pfad herausbekommen wie man den MySQL-Server mit Pfadangabe abschaltet.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Prophet05 » 19. September 2006 16:05

Hat alles nichts ergeben. Es war genau wie von die hervorgesagt.

/etc/init.d/mysql stop
Not found.

/etc/init.d/mysqld stop
Not found.

updatedb
Lief...

locate mysql
Gab ur einträge aus xampp und ein paar in usr/share/doc verzeichnis...
Prophet05
 
Posts: 17
Joined: 09. April 2006 12:29

Postby deepsurfer » 19. September 2006 16:27

ok...boote mal dein Linux neu....


Dann testen ob XAMPP startet...

Wenn nicht den MD5 Wert des XAMPP-Downloadfiles checken.(Ich weiss jetzt nicht welche Version du da benutzt)

Beim XAMPP 1.5.4 = MD5 checksum: 50f23159f43ac2e0eccb10e9874436b6

Beim XAMPP 1.5.3a = MD5 checksum: 422ab1faa4ab7afb3be8918ab8223b6b

Es könnte sein das auch das Downloadfile nicht in Ordnung ist, wenn die Zahl übereinstimmt wäre ein erneuter Download hinfällig.

Dann Backup deines HTMLcodes (sofern vorhanden)
Dann rm -rf /opt/lampp/ (lampp Ordner wird komplett gelöscht)

XAMPP neu entpacken mit <root> Rechten und dem richtigen befehl.

XAMPP start testen und hoffen das nun alles funktioniert.
Was anderes fällt mir jetzt nicht mehr ein.

EDIT:
Du hast geschrieben das du in der httpd.conf und in der PHP.INI etwas geändert hast... was ???
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Prophet05 » 19. September 2006 16:44

XAMPP start auch nach dem Rebooten nicht.

Die MD5 Summe kann ich nicht checken da ich die ZIP-Datei bereits gelöscht habe. Oder geht das auch wenn ich es einfach nochmal verzippe?
Oder soll ich das einfach gleich nochmal installieren?

deepsurfer wrote:Du hast geschrieben das du in der httpd.conf und in der PHP.INI etwas geändert hast... was ???

httpd.conf :
Hier habe ich nur einen kleinen Alias hinzugefügt.

php.ini :
Art der Fehlermeldung.
Prophet05
 
Posts: 17
Joined: 09. April 2006 12:29

Postby deepsurfer » 19. September 2006 18:11

Die MD5 Summe kann ich nicht checken da ich die ZIP-Datei bereits gelöscht habe. Oder geht das auch wenn ich es einfach nochmal verzippe?

ZIPdatei ??? sorry, das XAMPP für Linux kommt als TAR.GZ Datei..
Der MD5 Check mit der schon gedownloadeten Datei machen...
rootfenster --> in das Verzeichnis wo das downloadfile liegt --> md5sum dateiname.tar.gz
Nach einen Augenblick erscheint eine Zahl, diese muss mit der Zahl (eben geschrieben) übereinstimmen.
Ist nur eine Zahl/Zeichen anders bei dir als der MD5check anzeigt dann ist das Downloadfile defekt.

Oder soll ich das einfach gleich nochmal installieren?

hhmm... Wenn du also die Datei gelöscht hast musst du diese natürlich erst wieder downloaden und dann entpacken.
Jo...das wäre mein jetziges Vorgehen, wüsste dann auch nicht weiter.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Prophet05 » 22. September 2006 13:32

Ich habe es jetzt neuinstalliert und es läuft wieder einwandfrei... Komisch...

Danke für deine Hilfe! :D
Prophet05
 
Posts: 17
Joined: 09. April 2006 12:29

Previous

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest