"Ulimit: Bad non-numeric....." - Teil 2

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

"Ulimit: Bad non-numeric....." - Teil 2

Postby yves » 07. August 2003 11:48

Bezugnehmend auf http://community.apachefriends.org/f/viewtopic.php?t=249&highlight=nonnumeric .... ich hab genau dasselbe problem. (siehe unten)
gabs für das problem schon ne lösung (ausser distri ändern)?
ich hab ne redhat... welche weiss ich eigentlich gar nicht... ist aber von 2000 - distri ändern kommt leider nich in frage, weil der server am anderen ende von deutschland steht... und seit 2000 läuft der zuverlässig

Code: Select all
[root@www lampp]# ./lampp start
Starting LAMPP 1.1...
LAMPP: Starting Apache...
ulimit: bad non-numeric arg `file'
LAMPP: LAMPP-MySQL is already running.
LAMPP started.
[root@www lampp]# ./lampp startapache
LAMPP: Starting Apache...
ulimit: bad non-numeric arg `file'
[root@www lampp]# [

[...]

[root@www bin]# ./apachectl start
file size (blocks)       unlimited
ulimit: bad non-numeric arg `file'
[root@www bin]#


das scheint also gleich aus der apachectl zu kommen

irgendwelche tips? oder gibts ne möglichkeit n online-update der redhat zu machen??
[/url]
yves
 
Posts: 4
Joined: 07. August 2003 11:35

Postby yves » 07. August 2003 12:00

hab grad mal unter logs in die error_log geschaut... wenn´s hilft - da kommt bei jedem start folgendes hinzu (mir sagt das nix)
Code: Select all
[Thu Aug 07 12:42:51 2003] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Aug 07 12:42:52 2003] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Thu Aug 07 12:42:52 2003] [notice] Digest: generating secret for digest authentication ...
[Thu Aug 07 12:42:52 2003] [notice] Digest: done
[Thu Aug 07 12:42:53 2003] [crit] (22)Invalid argument: Unable to create scoreboard (anonymous shared memory failure)
[marcel@www logs]$
yves
 
Posts: 4
Joined: 07. August 2003 11:35

Postby Oswald » 07. August 2003 12:06

Huhu yves!

Ich befürchte das RedHat ist wirklich zu alt. Aber geben wir noch nicht auf.

Was gibt der folgende Befehl bei Dir aus?

/opt/lampp/bin/httpd -l

Lieben Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby yves » 07. August 2003 12:27

Es läuft!
wollte Euch nicht unnötig das Board voll-spammen....

aber auch für die anderen, die vielleicht dasselbe Problem haben:
in der httpd.conf nach "ScoreBoadFile" suchen - die Zeile aus den beiden Bedingungsklammern lösen und das Kommentarzeichen vor der Zeile entfernen

Bin aufgrund folgender Seite zu dieser Lösung gekommen:
http://httpd.apache.org/docs-2.0/de/mod/mpm_common.html#scoreboardfile
und die andere find ich nimmer - da stand sinngemäss, dass alte linuxversionen keinen shared_memory unterstützen.... - also scoreboad-file benutzen

@oswald: dank dir trotzdem für deine schnelle antwort....
übrigens steht dann da (falls das nachträglich noch wichtig sein sollte)
Code: Select all
[root@www bin]# ./httpd -l
Compiled in modules:
  core.c
  mod_ssl.c
  prefork.c
  http_core.c
  mod_so.c
[root@www bin]#
yves
 
Posts: 4
Joined: 07. August 2003 11:35

Postby Oswald » 07. August 2003 12:30

siehe auch http://www.apachefriends.org/faq-lampp.html#score

Aber das das auch den "ulimit: bad non-numeric arg `file' "-Fehler behebt ist mir wirklich neu.

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby yves » 07. August 2003 12:41

hm, irgendwie schein ich das vorher überlesen zu haben.... sorry

ne, die fehlermeldung is noch da - stört aber nicht, weil apache läuft jetzt wunderbar inkl. meinem domain-zertifikat, dass ich vom alten übernommen hab. echt klasse!
yves
 
Posts: 4
Joined: 07. August 2003 11:35


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests