Lampp geht nicht !

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Lampp geht nicht !

Postby Clown » 28. January 2003 14:46

Ich hab mir mal Lampp auf meinen Server gezocken.
Aber ich bekomme nei Starten nen Fehler weis eine Rad ?

Code: Select all
debian:/opt/lampp# ./lampp start
Starting LAMPP 0.9.7...
LAMPP: Starting Apache with SSL...
LAMPP: Error 1! Couln't start Apache!
LAMPP: Starting MySQL...
LAMPP: Starting ProFTPD...
debian - Fatal: unable to determine IP address of 'debian'.
LAMPP: Error 1! Couln't start ProFTPD!
LAMPP started.
debian:/opt/lampp#



Und nun die error_log
Code: Select all
[Tue Jan 28 15:44:58 2003] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Tue Jan 28 15:44:58 2003] [alert] (EAI 2)Name or service not known: mod_unique_id: unable to find IPv4 address of "debian"
Configuration Failed

Kann mir einer sagen was da falsch ist ?
Clown
 

Postby Oswald » 28. January 2003 15:31

Huhu Clown!

Schreib bitte mal folgendes in Deine /etc/hosts:

Code: Select all
127.0.0.1 debian


Einfach ans Ende der Datei ranhängen...

Dann sollte es gehen... hoffe ich. ;)

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Clown » 28. January 2003 15:54

Er Startet es aber ist nicht unter seiner IP ereichbar
Clown
 

Postby Oswald » 28. January 2003 16:01

Dann änder die 127.0.0.1, die Du gerade in die /etc/hosts geschrieben hast, bitte in die IP-Adresse Deines Rechners.

Viel Erfolg,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Clown » 28. January 2003 16:36

Erst mal Danke für die Schnelle Hilfe :)
Aber leider geht es so immer noch nicht.
Clown
 

Postby Oswald » 28. January 2003 16:56

Huhu Clown!

Seltsam. Eigentlich hätte es auch schon mit der ersten Variante funktionieren sollen. Was für eine Fehlermeldung kommt, wenn Du versuchst den Apache über's Netz zu erreichen?

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Guest » 28. January 2003 17:56

Es kommt die normale I-Explorer Meldung
Die Seite kann nicht angezeigt werden.
Guest
 

Postby Oswald » 28. January 2003 18:03

Seufz, die IE-Fehlermedungen sind immer so aussagekräftig. :(

Was gibst Du als URL im IE ein? Den Rechnernamen oder die IP-Adresse Deines Linux-Rechnes?

Kommt die Fehlermeldung sofort oder dauert es einen Moment?

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Clown » 28. January 2003 18:05

Ich gebe die IP ein und es dauert eingendlich nicht lang.
Clown
 

Postby Kristian Marcroft » 28. January 2003 21:23

Hi,

schon mal ne Firewall in erwägung gezogen?
Ansonsten sollte es ohne Probs laufen...
Was hasten fürn Debian?
Ich habs erst gestern auf woody 3.0 installed...
Wie hast du es entpackt?
Kannst du den apache (falls X auf Server) den vom Debian aus erreichen?
Links bzw. lynx können dir dabei helfen falls kein X installiert ist.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Clowny » 29. January 2003 13:38

Also an ner Firewall kanns nicht liegen.
Wenn ich den normalen Apache inst. geht es aber ich müsste dann halt CGi, PHP und MYSQL inst. wo ich nicht gerade ne leuchte bin :(
Es ist Debian 3.0.
Und wie meinst du das X von aussen ereichen ?
(es ist ein x-server inst.)
Und was meinst du mit Lynx ?
(sry bin Nooby)

MFG

Clown
Clowny
 

Postby Kristian Marcroft » 29. January 2003 14:12

Clowny wrote:Also an ner Firewall kanns nicht liegen.
Wenn ich den normalen Apache inst. geht es aber ich müsste dann halt CGi, PHP und MYSQL inst. wo ich nicht gerade ne leuchte bin :(
Es ist Debian 3.0.
Und wie meinst du das X von aussen ereichen ?
(es ist ein x-server inst.)
Und was meinst du mit Lynx ?
(sry bin Nooby)

MFG

Clown


Hi Clown,
Ok Firewall ausgeschlossen...
Meine frage war eigentlich kannst du den LAMPP Apache vom Debain aus erreichen? mit 127.0.0.1 (oder localhost) oder eigene IP?
Da du X instaliert hast kannste des mim Netscape, Opera oder sonstigem Browser versuchen. Lynx & Links sind textbasierende Browser, die auf der Konsole laufen :)

Der Apache läuft aber nicht wenn du vesuchst Lampp zu starten oder?
Funzt der denn vom Netzwerk aus? bzw. auch vom debian aus?

So das waren erstmal meine Fragen :)
So long

KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Clown » 29. January 2003 14:54

Das ist komisch :/
Ich ich bekomme wenn ich Logal drauf zugreifen will auch fehler

127.0.0.1:80... failed: Connection refused.

??
Clown
 

Postby Oswald » 29. January 2003 15:46

Ahh... das ist doch mal eine konkrete Fehlermeldung. Die Meldung sagt aus, dass der Apache definitiv nicht läuft (zumindest nicht auf 127.0.0.1 und Port 80).

Was kriegst Du bei einem ps -aux | egrep httpd angezeigt?

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Frickler » 24. September 2004 17:38

Hallo,
Ich greif das Thema mal wieder auf.
Ich versuche XAMPP auf einer Debian 3.0 - Kiste zum laufen zu bekommen.

Weder aus dem Netzwerk noch lokal ist der Apache zu erreichen.
Lynx gibt an mit http://localhost oder auch 127.0.0.1:80 "Unable to connect to remote host." aus dem Netzwerk versuche ich den Apache per privat-IP zu erreichen. Leider bin ich eben auch nicht sehr bewandert was Linux oder Debian angeht (brauchte halt eben ein schlankes OS welches auf einem K6-366 noch ordentlich zaubern kann).

Per 'apt-get install apache' habe ich einen Indianer installiert und dieser ist auch erreichbar, ich würde aber trotzdem gern weiter mit XAMPP arbeiten.

der Aufruf von ps -aux lautet:
Code: Select all
Bad syntax, perhaps a bogus '-'?
USER       PID %CPU %MEM   VSZ  RSS TTY      STAT START   TIME COMMAND
root         1  0.4  1.5  1272  484 ?        S    19:48   0:05 init [2]
root         2  0.0  0.0     0    0 ?        SW   19:48   0:00 [kflushd]
root         3  0.0  0.0     0    0 ?        SW   19:48   0:00 [kupdate]
root         4  0.1  0.0     0    0 ?        SW   19:48   0:01 [kswapd]
root         5  0.0  0.0     0    0 ?        SW   19:48   0:00 [keventd]
root       110  0.0  0.9  2164  296 ?        S    19:49   0:00 /sbin/dhclient-2.2.x -q eth0
daemon     114  0.0  1.0  1384  316 ?        S    19:49   0:00 /sbin/portmap
root       187  0.0  2.4  2036  736 ?        S    19:49   0:00 /sbin/syslogd
root       190  0.0  2.4  1656  736 ?        S    19:49   0:00 /sbin/klogd
root       195  0.0  1.9  1444  600 ?        S    19:49   0:00 /sbin/rpc.statd
root       203  0.0  2.1  1988  644 ?        S    19:49   0:00 /usr/sbin/inetd
root       207  0.0  2.2  2044  704 ?        S    19:49   0:00 /usr/sbin/lpd
postgres   246  0.0  5.5  8544 1684 ?        S    19:49   0:00 /usr/lib/postgresql/bin/postmas
postgres   248  0.0  1.8  9536  564 ?        S    19:49   0:00 postgres: stats buffer process
postgres   249  0.0  2.3  8576  728 ?        S    19:49   0:00 postgres: stats collector proce
root       261  0.0  2.2  2784  684 ?        S    19:49   0:00 /usr/sbin/sshd
root       266  0.0  9.4  4180 2908 ?        S    19:49   0:00 /usr/bin/X11/xfs -daemon
daemon     269  0.0  1.1  1388  344 ?        S    19:49   0:00 /usr/sbin/atd
root       272  0.0  2.0  1652  624 ?        S    19:49   0:00 /usr/sbin/cron
root       280  0.0  1.5  1252  468 tty1     S    19:49   0:00 /sbin/getty 38400 tty1
root       281  0.0  1.5  1252  468 tty2     S    19:49   0:00 /sbin/getty 38400 tty2
root       282  0.0  1.5  1252  468 tty3     S    19:49   0:00 /sbin/getty 38400 tty3
root       283  0.0  1.5  1252  468 tty4     S    19:49   0:00 /sbin/getty 38400 tty4
root       284  0.0  1.5  1252  468 tty5     S    19:49   0:00 /sbin/getty 38400 tty5
root       285  0.0  1.5  1252  468 tty6     S    19:49   0:00 /sbin/getty 38400 tty6
root       296  0.0  5.7  6416 1748 ?        S    19:49   0:00 /usr/sbin/sshd
root       298  0.0  4.0  2208 1228 pts/0    S    19:49   0:00 -bash
root       382  0.0  3.2  2060  980 pts/0    S    19:57   0:00 sh /opt/lampp/bin/mysqld_safe -
nobody     390  0.0  5.2  3372 1612 ?        S    19:57   0:00 proftpd: (accepting connections
nobody     413  0.0  6.8 21912 2092 pts/0    S    19:57   0:00 /opt/lampp/sbin/mysqld --basedi
nobody     416  0.0  6.8 21912 2092 pts/0    S    19:57   0:00 /opt/lampp/sbin/mysqld --basedi
nobody     417  0.0  6.8 21912 2092 pts/0    S    19:57   0:00 /opt/lampp/sbin/mysqld --basedi
root       430  0.0  3.6  2948 1108 pts/0    R    20:12   0:00 ps -aux


etc/hosts sieht so aus:
Code: Select all
127.0.0.1       debian  localhost





# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
~
~


Ich hoffe die Infos reichen erstmal.
Und dankeschön schonmal für eine helfende Hand.

Grüße
Patrick
Frickler
 
Posts: 5
Joined: 19. September 2004 21:35

Next

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests