http:localhost wird nicht angezeigt

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

http:localhost wird nicht angezeigt

Postby Schorschie » 31. July 2003 18:43

Tach zusammen,

bei der Installation von lampp steht beim testen drin es würde sich die Startseite von LAMPP melden wenn man http://localhost in den Browser tippt. Da erschein bei mir jedoch die Startseite von SuSE :-(.

Intstalliert ist ein frisches SuSE 7.1 alle Schritte aus der "Apache Friends für Linux" Anleitung; fehlerfrei bis zum Testen.

Zur Info, es ist eine alte P100 Büchse mit 16MB RAM....reicht das für nen ersten Test?

Kann mir bitte jemand sagen was mein Fehler ist?

Gruß
Schorschie
Schorschie
 
Posts: 6
Joined: 31. July 2003 18:31

Postby Oswald » 31. July 2003 19:16

Huhu Schorschie!

Wahrscheinlich läuft bei Dir schon der Apache vom SuSE. Beim Starten von LAMPP hättest Du auch eine entsprechende Meldung bekommen sollen.

Stopp einfach den SuSE-Apache mit rcapache stop und starte dann noch mal LAMPP.

Viel Erfolg,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Kristian Marcroft » 31. July 2003 19:16

Hi,

einfach mal zum testen:

gibt mal an der console ein:
/etc/init.d/apache stop
und anschliessend
/opt/lampp/lampp restart

funzt es jetzt? :)
Wenn ja wars das aber trotzdem noch nicht einfach nochmal hier melden :) wenn nein auch hier melden *g*

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Schorschie » 31. July 2003 19:33

Servus,

thanks für die schnelle Antworten.
Richig es war so,...er Apache von SuSE lief noch. Ich hab ihn, wie Kai beschieben hat, beendet und LAMPP gestartet.

Auch ein weiterer start zeigt:
Starte LAMPP 1.1...
LAMPP: Starte Apache mit SSL...
LAMPP: LAMPP-MySQL läuft bereits.
LAMPP: Ein FTP daemon läuft bereits.
LAMPP gestartet.

Jedoch schickt mich der Netscape bei http://localhost/ jetzt auf eine Onlinepage (http://search.netscape.com/...) ...mmm.
Bitte helft mir - ich will nicht wieder zu Windoof zurück. :-/
Schorschie
 
Posts: 6
Joined: 31. July 2003 18:31

Postby Oswald » 31. July 2003 20:27

Hmm.. probier mal http://127.0.0.1. Geht's so?

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Schorschie » 01. August 2003 15:48

no,...es kommt

"Ntscape´s network connection was refused by the server 127.0.0.1. The server may not be accepting or may be busy. Try connecting again later."

Ein reload aktualisiert den Apache, Mysql und ProFTP. - Also müsste er doch laufen. Kann ich den test nicht von einer anderen Büchse im Netz aus starten?
Gruß
Schorschie
Bitte helft mir - ich will nicht wieder zu Windoof zurück. :-/
Schorschie
 
Posts: 6
Joined: 31. July 2003 18:31

Postby Pc-dummy » 01. August 2003 16:49

das gugt so aus als würde entweder der apache garnicht laufen oder du hast ne firewall die sogar das loopback-interface überwacht (gibts norm. nicht)

ps -aux <-- zeigt dir ob der apache läuft, bzw. netstat -an
iptables -L <-- zeigt dir wenn du dich damit auskennst ob deine firewall spinnt

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby Schorschie » 01. August 2003 17:15

Hi,...
also bei dem ps -aux kommt:
/opt/lampp/sbin/mysqld --basedir=/opt/lampp --d
Das genze 3 mal mit unterschiedlicher PID.
Einmal erscheint:
sh /opt/lampp/bin/mysql_safe --datadir=opt/la...

netstat -an:
unix 0 [ ACC ] STREAM LISTENING 6592 /opt/lampp/var/mysql/mysql.sock
Sonst steht da nix mit lampp, apache oder ähnlichem.

Bei iptables -L kommt "command not fond".
Bitte helft mir - ich will nicht wieder zu Windoof zurück. :-/
Schorschie
 
Posts: 6
Joined: 31. July 2003 18:31

Postby Kristian Marcroft » 01. August 2003 22:30

Schorschie wrote:Kann ich den test nicht von einer anderen Büchse im Netz aus starten?


Was passiert denn wenn du von nem anderem PC im Netz auf den Server zugreiffst?
evtl. könntest du mal im IRC-Chat vorbei schaun, vielleicht können wir dir da helfen...
aber bitte erst morgen, weil ich mach jetzt feierabend :)

So long
und Gute Nacht
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Schorschie » 02. August 2003 10:49

Also von einer anderen Büchse komm ich per FTP auf den Lampprechner. Wenn ich im Browser die IP des Lampprechners eingebe kommt "Diese Seite kann nicht angezeigt werden."

Der Lampprechner zeigt mir:
LAMPP: Starting Apache with SSL...
LAMPP: Starting MySQL...
LAMPP: Starting ProFTPD...
LAMPP startet.
Bitte helft mir - ich will nicht wieder zu Windoof zurück. :-/
Schorschie
 
Posts: 6
Joined: 31. July 2003 18:31

Postby Schorschie » 02. August 2003 12:49

Also,... das Problem ist gelöst.
Vielen dank nochmal an KriS.

Die lösung ist: http://apf.kwm-web.info/faq/index.php?s ... Scoreboard
____________________________________________________
Lampp: Was bedeutet Invalid argument: Unable to create scoreboard?
Die ganze Fehlermeldung ist:

[crit] (22)Invalid argument: Unable to create scoreboard (anonymous shared
memory failure)

In diesem Fall einfach die Scoreboard-Direktive (etwa Zeile 71) in der /opt/lampp/etc/httpd.conf folgendermaßen ändern.

Bisher sollte da stehen:

#ScoreBoardFile logs/apache_runtime_status

Das Doppelkreuz (#) am Anfang wegnehmen und daraus folgendes machen:

ScoreBoardFile logs/apache_runtime_status

Nach dieser Änderung sollte die Fehlermeldung nicht mehr auftauchen.

Letzte Änderung des Artikels: 27.07.2003, 15:05
Verfasser des Artikels: KriS
____________________________________________________

Des isch halt älles net so oifach.
Bitte helft mir - ich will nicht wieder zu Windoof zurück. :-/
Schorschie
 
Posts: 6
Joined: 31. July 2003 18:31


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests