Apache Login-Fehler (500 Internal Server Error)

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Apache Login-Fehler (500 Internal Server Error)

Postby enssenje » 11. July 2006 12:08

hi leute,

hatte die tage schonmal das problem, dass ich mich nicht am ldap anmelden konnte bzw. es wollte aber ich es nicht mit den dso modulen vom apache geschafft habe.

jetzt habe ich mit ach und krach ein modul kompiliert und eingebunden bekommen -> mod-auth_ldap von: -> http://www.muquit.com/muquit/software/m ... .html#conf.

wenn nun die anmeldemaske beim aufruf der webseite erscheint, kommt nach eingabe eines richtigen users mit richtigem passwort (auch mit falschen user und passwort probiert) diese nette seite zum vorschein:

"Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, you@example.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log."


wenn ich in die error_log schaue bekomme ich das zu gesicht:

[Mon Jul 10 16:09:54 2006] [error] Internal error: pcfg_openfile() called with NULL filename
[Mon Jul 10 16:09:54 2006] [error] [client 10.136.50.159] (9)Ungültiger Dateideskriptor: Could not open password file: (null)"

die syntax die ich für die authentifizierung benötige habe ich von der webseite genommen und lautet wie folgt:

"<Directory />
Options Indexes FollowSymLinks
AllowOverride None
order allow,deny
allow from all
AuthName "Mein privater Bereich"
AuthType Basic
LDAP_Server 10.1??.?.??
LDAP_Port 389
BASE_DN "o=pseudo"
UID_Attr uid
require valid-user
</Directory>"


meine frage lautet nun: was ist daran falsch ich kann mir das alles nicht erklären....habe das gefühl das ich kurz vorm ziel stehe aber mich das modul ärgern will Sad

ps.: das modul ist überings geladen!


danke schonmal im vorraus!!!
enssenje
 
Posts: 8
Joined: 21. June 2006 12:47

Postby Wiedmann » 11. July 2006 13:00

[Mon Jul 10 16:09:54 2006] [error] [client 10.136.50.159] (9)Ungültiger Dateideskriptor: Could not open password file: (null)"

"Auth Basic" liest die User aus einer Datei die du nicht konfiguriert hast. Das du gar keine Datei, sondern LDAP verwenden möchtest hast du aber auch nirgends angegeben.

Eigentlich würde ich ja sagen: Schau ins Apache-Manual wie das LDAP-Modul konfiguriert wird, aber du benutzt ja gar nicht das Modul das beim Apache dabei ist (ist's überhaupt ein XAMPP?), sondern ein Third-Party-Tool. Evtl. solltest du da in dessen Support-Forum reinschauen?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby enssenje » 11. July 2006 13:34

ja es ist ein XAMPP, Version 1.5.3a um genau zu sein.
das problem was ich hatte, ist das ich das authnz_ldap modul nicht konfiguriert bekommen habe (entweder hat der apache nicht mehr gestartet oder ebenfalls 500 Internal Server Error -> wo er die datei ebenfalls nicht finden konnte).

also habe ich versucht mehrere module zu kompilieren und bei dem einen, dass ich oben angegeben habe hat es schluss endlich geklappt. nur jetzt will er auch ne datei haben. das nächte problem ist, dass die seite (wo ich die source her habe) keinerlei support hat bzw. kein forum besitzt!

hatte ja auch schonmal angefragt ob mir jemand eine vernünftige config zusammenstellen könnte (für das authnz_ldap modul). aber da kam leider keinerlei regung!

meine konfiguration beim authnz modul sah folgendermaßen aus:

<Directory />
Options FollowSymLinks
AllowOverride All
#AuthName "Geben Sie Benutzernamen und Passwort ein"
#AuthType Basic
#AuthBasicAuthoritative Off
#AuthBasicProvider Off
#AuthLDAPURL ldap://directory.blabla.de:389/o=bla.com?uid
#AuthLDAPGroupAttribute memberUid
#AuthLDAPGroupAttributeIsDN off
#Require valid-user
#XAMPP
#Order deny,allow
#Deny from all
</Directory>


vielleicht kann das ja jemand richten!

danke schonmal im vorraus!!!!
enssenje
 
Posts: 8
Joined: 21. June 2006 12:47

Postby Wiedmann » 11. July 2006 13:45

meine konfiguration beim authnz modul sah folgendermaßen aus:
Code: Select all
<Directory />
Options FollowSymLinks
AllowOverride All
#AuthName "Geben Sie Benutzernamen und Passwort ein"
#AuthType Basic
#AuthBasicAuthoritative Off
#AuthBasicProvider Off
#AuthLDAPURL ldap://directory.blabla.de:389/o=bla.com?uid
#AuthLDAPGroupAttribute memberUid
#AuthLDAPGroupAttributeIsDN off
#Require valid-user
#XAMPP
#Order deny,allow
#Deny from all
</Directory>

Auf die schnelle fallen hier 3 Sachen auf:
- "AuthBasicAuthoritative" sollte hier on sein (beim internen LDAP Modul).
- "AuthBasicProvider" muss ldap sein
- "Require" muss ldap-user sein.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby enssenje » 11. July 2006 14:09

ok danke...das sieht auch jetzt schon etwas besser aus!

jetzt fragt er zumindestens keine datei mehr ab!!!

jetzt kann ich mich aber trotzdem noch nicht anmelden:

Authorization Required
This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required.


die error_log zeigt mir folgendes an:

[Tue Jul 11 14:59:24 2006] [warn] [client 10.154.1.29] [928] auth_ldap authenticate: user enssenje authentication failed; URI / [ldap_simple_bind_s() to check user credentials failed][Invalid credentials]
[Tue Jul 11 14:59:24 2006] [error] [client 10.154.1.29] user enssenje: authentication failure for "/": Password Mismatch


nun frage ich mcih auch wer "client 10.154.1.29" ist!!! wenn ich einen dig auf 10.154.1.29 mache bekomme ich als antwort: A.ROOT-SERVERS.NET. NSTLD.VERISIGN-GRS.COM. 2006071001 1800 900 604800 86400.

noch irgendeine weitere idee! werde mich auch nochmal mit der apache help auseinander setzen?
enssenje
 
Posts: 8
Joined: 21. June 2006 12:47

Postby enssenje » 14. July 2006 13:53

hat sich erledigt!!!
habe den fehler gefunden!
enssenje
 
Posts: 8
Joined: 21. June 2006 12:47

Postby Björn77 » 19. July 2006 14:07

So damit auch andere eine funktionierende Lösung mit authnz_ldap bekommen :wink: :

<Directory "/">
Options None
AllowOverride None
Order allow,deny
Allow from all
AuthName "Please Login with your LDAP Username and Password"
AuthType Basic

AuthBasicProvider ldap
AuthLDAPURL "ldap://server1 server2/o=org?uid"
require ldap-user username1 username2
</Directory>
Björn77
 
Posts: 2
Joined: 13. July 2006 12:31

Postby enssenje » 21. July 2006 07:24

hi,

würde ja gerne die lösung posten....aber ich habe es nicht weiterhin mit dem modul probiert. habe mir ein auth_ldap modul von hier geladen und moduliert. funktioniert einwandfrei!

http://www.muquit.com/muquit/software/mod_auth_ldap/mod_auth_ldap_apache2.html

wenn ich hierfür die lösung posten soll sagt bescheid.
enssenje
 
Posts: 8
Joined: 21. June 2006 12:47


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 6 guests