htaccess wird nicht angezeigt

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Postby R3vo » 10. July 2006 17:54

hier mal der link zu der ganzen error_log...

http://www.python-molurus.de/error_log
R3vo
 
Posts: 17
Joined: 22. May 2006 15:17
Location: Mülheim an der Ruhr

Postby Wiedmann » 10. July 2006 18:53

Als ich fasse mal zusammen:
Du hast ein Verzeichnis:
"/opt/lampp/htdocs/anika/"

In diesem Verzeichnis gibt es 2 Dateien:
"fehlerseite.htm" und ".htaccess"

In der Datei ".htaccess" steht folgendes drin:
Code: Select all
ErrorDocument 404 /anika/fehlerseite.htm


Wen du jetzt im Browser diese URI eingibst:
"http://localhost/anika/foo.htm"
dann bekommst du das Standardfehlerdokument vom Apache zu sehen, und nicht das, was in der Datei "fehlerseite.htm" drin ist.

Die Datei "fehlerseite.htm" kannst du aber direkt über:
"http://localhost/anika/fehlerseite.htm"
aufrufen und bekommst dann den Inhalt dieser Datei zu sehen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby R3vo » 10. July 2006 21:36

Ja, genau so ist es, endlich versteht mich mal jemand :)
R3vo
 
Posts: 17
Joined: 22. May 2006 15:17
Location: Mülheim an der Ruhr

Postby Stefan » 10. July 2006 21:48

Ja, genau so ist es

hey, ganz so genau ist es dann doch nicht.

Vergleiche mal die beiden Zeilen

ErrorDocument 404 /anika/fehlerseite.htm

ErrorDocument 404 /test/fehlerseite.htm

bin weg, Stefan
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Postby R3vo » 11. July 2006 01:28

den test ordner gibt es nicht mehr, ich bin beim 2. versuch immer mit dem Verzeichnis

/opt/lampp/htdocs/anika/fehlerseite.htm

versucht, den "test" ordner habe ich gelöscht.

Es exestiert also nur noch das "anika" verzeichnis

http://www.python-molurus.de/anika/fehlerseite.htm
R3vo
 
Posts: 17
Joined: 22. May 2006 15:17
Location: Mülheim an der Ruhr

Postby Wiedmann » 11. July 2006 01:57

Es exestiert also nur noch das "anika" verzeichnis

Das war nicht die Frage von "Stefan". Die Frage war:
Was steht wirklich in der ".htaccess"?

Tatsächlich hattest du ja schon geschrieben:
- die Fehlerseite ist anika-Verzeichnis
- in der ".htaccess" hast du das test-Verzeichnis abgegeben

Wir haben aber nur deine Aussagen für die Hilfe und keine Glaskugel die uns zeigt was wirklich bei dir ist ,-)

endlich versteht mich mal jemand

Mein Post hätte eigentlich dein Erster sein sollen. Dann hätten wir uns die 10 anderen dazwischen sparen können...

Ja, genau so ist es,

Ich hoffe jetzt mal, dass das was ich geschrieben hab wirklich alles zutrifft (du das also alles verifiziert hast). Bei dieser Ausgangslage mache mal folgenden Test:
- schreibe nur das Wort "Fehler" in die ".htaccess"
- tu diese ".htaccess" ins Verzeichnis "/opt/lampp/htdocs/anika/"
- rufe diese URI auf: "http://localhost/anika/foo.htm"

Was passiert?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby R3vo » 11. July 2006 11:34

Alsoo,


Ich habe jetzt folgendes gemacht, wie gefordert wurde...

Ich habe in die ".htaccess" nur den Begriff "fehler" geschrieben, diese ".htaccess" habe ich dann auf den Server in folgendes Verzeichnis geladen..

/opt/lampp/htdocs/anika

In diesem Verzeichnis ist immer noch die "fehlerseite.htm"

Danach habe ich folgende URL aufgerufen

http://localhost/anika/foo.htm

Leider bekomme ich dann immer noch die Standart Fehlerseite.
R3vo
 
Posts: 17
Joined: 22. May 2006 15:17
Location: Mülheim an der Ruhr

Postby Wiedmann » 11. July 2006 12:50

Leider bekomme ich dann immer noch die Standart Fehlerseite.

Du meinst du bekommst weiterhin einen 404 Error?

Hast du irgendwas in der "httpd.conf" geändert?

Irgendwo in der "httpd.conf" gibt es die Zeilen:
Code: Select all
#
# This should be changed to whatever you set DocumentRoot to.
#
<Directory "/opt/lampp/htdocs">

Ein paar Zeilen danach kommt eine Zeile mit:
Code: Select all
# AllowOverride controls what directives may be placed in .htaccess files.
# It can be "All", "None", or any combination of the keywords:
#   Options FileInfo AuthConfig Limit
#
AllowOverride foo

Was steht dort genau bei "AllowOverride"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Previous

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest