Domain

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Domain

Postby rabby » 08. July 2006 19:55

hallo,
irgendwie kann ich meine domain, die dem vserver, auf dem ich xampp installiert habe, zugewiesen ist, nicht extra ansteuern.
würde gerne bei aufruf von domain.tld den ordner /opt/lampp/htdocs/projekt1 verwenden. derzeit komme ich wohl im /opt/lampp/htdocs/ raus :(
danke für Eure hilfe.
ps: hab mein glück mit etc/extras/httpd-vhosts.conf probiert; aber diese wird irgendwie nicht verwendet: wenn ich einen fehler "einbaue" erscheint beim lampp restart keine fehlermeldung oder sonst was :(
rabby
 
Posts: 28
Joined: 15. December 2003 17:39

Postby rabby » 08. July 2006 21:43

hier der inhalt meiner etc/extra/httpd-vhost.conf
hab apachectl mal manuell gestartet. es hat tatsächlich fehler bemerkt, also ignoriert wird das scheinbar doch nicht... aber das hilft mir nichts, denn wenn ich ./bin/apachectl -t -D DUMP_VHOSTS ausführe, meint er:
VirtualHost configuration:
Syntax OK
=> irgendwie nicht so viele einstellungen, die er sich gemerkt hat :(
hier meine httpd-vhosts.conf, wobei bla.de durch die "richtige" domain ersetzt wurde.
#
# Virtual Hosts
#
# If you want to maintain multiple domains/hostnames on your
# machine you can setup VirtualHost containers for them. Most configurations
# use only name-based virtual hosts so the server doesn't need to worry about
# IP addresses. This is indicated by the asterisks in the directives below.
#
# Please see the documentation at
# <URL:http://httpd.apache.org/docs/2.2/vhosts/>
# for further details before you try to setup virtual hosts.
#
# You may use the command line option '-S' to verify your virtual host
# configuration.

#
# Use name-based virtual hosting.
#
NameVirtualHost *:80

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for all requests that do not
# match a ServerName or ServerAlias in any <VirtualHost> block.
#
<VirtualHost *:80>
ServerAdmin webmaster@dummy-host.example.com
DocumentRoot /www/docs/dummy-host.example.com
ServerName dummy-host.example.com
ServerAlias www.dummy-host.example.com
ErrorLog logs/dummy-host.example.com-error_log
CustomLog logs/dummy-host.example.com-access_log common
</VirtualHost>

#<VirtualHost *:80>
# ServerAdmin webmaster@dummy-host2.example.com
# DocumentRoot /www/docs/dummy-host2.example.com
# ServerName dummy-host2.example.com
# ErrorLog logs/dummy-host2.example.com-error_log
# CustomLog logs/dummy-host2.example.com-access_log common
#</VirtualHost>



#meine domain:
<VirtualHost www.bla.de:80>
ServerName www.bla.de
ServerAlias www.bla.de
ServerAdmin webmaster@www.de
DocumentRoot /opt/lampp/htdocs/www
<Directory "/opt/lampp/htdocs/www">
AllowOverride All
Options IncludesNoExec
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

die domain an sich wird richtig geroutet, denn wenn ich sie aufrufe, wird mit ja /opt/lampp/htdocs/ angezeigt bzw. werde ich in den xampp ordner geschupst.
rabby
 
Posts: 28
Joined: 15. December 2003 17:39

Postby kleinweby » 08. July 2006 21:54

nabend,

du musst in der httpd.conf bei
Code: Select all
#Include etc/extra/httpd-vhost.conf

(Zimlich am Ende)
Die Raute(#) davor entfernen.


kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests