Probleme mit VHosts

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme mit VHosts

Postby Argoran » 08. July 2006 09:14

Hallo,

ich habe 2 Domains, die auf einen Server zeigen sollen, natürlich auf unterschiedliche Verzeichnisse. Leider wird immer nur der erste VHost Eintrag für beide Domains aktiv. Die Domain2 ist eine Weiterleitung auf den Ordner "domain2/". Hier der Auszug aus der httpd.conf:
Code: Select all
NameVirtualHost *:80

<VirtualHost *:80>
ServerAdmin dom1@as.de
DocumentRoot /var/www/domain1
ServerName domain1.de
ServerAlias www.domain1.de
ErrorLog /var/log/domain1.com-error.log
CustomLog /var/log/domain1.com-access.log common
<Directory "/var/www/domain1">
AllowOverride All
Options IncludesNoExec FollowSymLinks
Order allow,deny
Allow from all
</Directory>
</VirtualHost>

<VirtualHost *:80>
ServerAdmin dom2@as.de
DocumentRoot /var/www/
ServerName domain2.de
ServerAlias www.domain2.de
ErrorLog /var/log/domain2.com-error.log
CustomLog /var/log/domain2.com-access.log common
<Directory "/var/www/domain2">
AllowOverride All
Options IncludesNoExec FollowSymLinks
Order allow,deny
Allow from all
</Directory>
</VirtualHost>


Hoffe es kann mir jemand helfen.

MfG
Argoran
 
Posts: 1
Joined: 07. July 2006 17:44

Postby deepsurfer » 10. July 2006 11:59

Weil du im Zweiten VHOST in der Directory Section einen anderen Pfad drinn hast als der, der im DocumentRoot vorgegeben ist.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests