Daten-Quellverzeichnis für MySQL-Server ändern

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Daten-Quellverzeichnis für MySQL-Server ändern

Postby js88 » 07. July 2006 15:37

Hallo,

Zuerst: Ich benutze Suse Linux 10.0 und bin noch Linux-Anfänger.

Ich habe XAMPP installiert und möchte nun das Verzeichnis, in dem die Datenbanken gespeichert sind, ändern, damit ich die Datenbanken sowohl unter Windows als auch unter Linux benutzen kann (unter Windows hab ich es schon geändert). Google war leider nicht hilfreich.[/url]
Ein "Programm", vollständig in PHP geschrieben:
http://www.sudokurechner.de.vu
js88
 
Posts: 3
Joined: 07. July 2006 15:31

Postby deepsurfer » 07. July 2006 16:01

(unter Windows hab ich es schon geändert)

Dann hast du im Windows (gehe von XAMPP auch aus) die my.cnf geändert.

Was hindert dich daran das im XAMPP für Linux auch zu machen ?
ist ja namentlich die selbe datei ;)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby js88 » 07. July 2006 16:07

Dann hast du im Windows (gehe von XAMPP auch aus) die my.cnf geändert.

Was hindert dich daran das im XAMPP für Linux auch zu machen ?
ist ja namentlich die selbe datei


Richtig, hab ich Unter Windows geändert. Unter Linux klappt das aber nicht so einfach. Da ist noch irgendwas mit mysql.sock. Wenn ich das Verzeichnis auch ändere funktioniert gar nichts mehr. Was hat das denn zu bedeuten / was muss ich da machen?
Ein "Programm", vollständig in PHP geschrieben:
http://www.sudokurechner.de.vu
js88
 
Posts: 3
Joined: 07. July 2006 15:31

Postby Stefan » 07. July 2006 23:12

MySQL-Server stoppen, Änderung vornehmen, MySQL-Server starten.

Welches Problem tritt auf? Bitte schreibe dazu wie Du die drei Schritte durchführst.
User avatar
Stefan
 
Posts: 475
Joined: 26. December 2002 22:36
Location: Mitten in der sonnigen Südpfalz

Postby js88 » 09. July 2006 15:53

Hier ist meine my.cnf Datei:

# Example MySQL config file for medium systems.
#
# This is for a system with little memory (32M - 64M) where MySQL plays
# an important part, or systems up to 128M where MySQL is used together with
# other programs (such as a web server)
#
# You can copy this file to
# /etc/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is /opt/lampp/var/mysql) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
#password = your_password
port = 3306
socket = /opt/lampp/var/mysql/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port = 3306
socket = /opt/lampp/var/mysql/mysql.sock
skip-locking
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
#
#skip-networking

# Replication Master Server (default)
# binary logging is required for replication
# log-bin deactivated by default since XAMPP 1.4.11
#log-bin=mysql-bin

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id = 1

# Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
# the syntax is:
#
# CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
# MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
# where you replace <host>, <user>, <password> by quoted strings and
# <port> by the master's port number (3306 by default).
#
# Example:
#
# CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
# MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
# start replication for the first time (even unsuccessfully, for example
# if you mistyped the password in master-password and the slave fails to
# connect), the slave will create a master.info file, and any later
# change in this file to the variables' values below will be ignored and
# overridden by the content of the master.info file, unless you shutdown
# the slave server, delete master.info and restart the slaver server.
# For that reason, you may want to leave the lines below untouched
# (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id = 2
#
# The replication master for this slave - required
#master-host = <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user = <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password = <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port = <port>
#
# binary logging - not required for slaves, but recommended
#log-bin=mysql-bin


# Point the following paths to different dedicated disks
#tmpdir = /tmp/
#log-update = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#bdb_cache_size = 4M
#bdb_max_lock = 10000

# Comment the following if you are using InnoDB tables
skip-innodb
innodb_data_home_dir = /opt/lampp/var/mysql/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = /opt/lampp/var/mysql/
innodb_log_arch_dir = /opt/lampp/var/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
innodb_buffer_pool_size = 16M
innodb_additional_mem_pool_size = 2M
# Set .._log_file_size to 25 % of buffer pool size
innodb_log_file_size = 5M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout

Ich habe folgende Zeilen geändert:
innodb_data_home_dir = /opt/lampp/var/mysql/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = /opt/lampp/var/mysql/
innodb_log_arch_dir = /opt/lampp/var/mysql/

zu:
innodb_data_home_dir = /home/jonas/daten/Datenbank/
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = /home/jonas/daten/Datenbank/
innodb_log_arch_dir = /home/jonas/daten/Datenbank/

(in /home/jonas/daten/ ist meine 3. Partition (FAT32, unter WinXP E:\) gemountet)
Ein "Programm", vollständig in PHP geschrieben:
http://www.sudokurechner.de.vu
js88
 
Posts: 3
Joined: 07. July 2006 15:31

Postby kleinweby » 09. July 2006 20:42

nabend,

müsste eigentlich gehen, ein fehler wegen der mysql.sock halte ich für unwarscheinlich da du diesen eintrag ja nicht geändert hast.

kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

evtl. Rechteproblem?

Postby arne_h » 15. August 2006 22:48

Offenbar kann der Socket im neuen Datenbankverzeichnis nicht angelegt werden. Ich habe Suse Linux 10.1 und XAMPP 1.5.3 installiert und habe ebenfalls Probleme, nachdem ich mein Verzeichnis für die Datenbanken in der /opt/lampp/etc/my.cnf geändert habe. Es scheint ein Problem der Rechte des neuen Datenverzeichnis zu sein.

Auch ich komme hier nicht mehr weiter . Mein Problem:

Mein neues Datenverzeichnis heißt /home/mysql/data, den Eigner habe ich auf „nobody“ gesetzt und die Rechte komplett auf 777.

Ich erhalte weiterhin Folgendes
# /opt/lampp/lampp reloadmysql
XAMPP: Reload MySQL...

l # /opt/lampp/bin/mysql
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/home/mysql/data/mysql.sock' (2)

Unter /opt/lampp/var/mysql kann die mysql.sock ohne Probleme angelegt werden und MySQL läuft bestens.

Hat noch Jemand eine Idee?
arne_h
 
Posts: 1
Joined: 15. August 2006 22:21


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests