Problem mit Chroot

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Problem mit Chroot

Postby cola » 19. June 2006 19:07

Hallo Zusammen,
wollte mein Chroot wider mal updaten und nun kommt folgender Fehler beim starten:

[Mon Jun 19 20:08:31 2006] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Mon Jun 19 20:08:32 2006] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Mon Jun 19 20:08:32 2006] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Mon Jun 19 20:08:35 2006] [notice] Digest: generating secret for digest authentication ...
[Mon Jun 19 20:08:35 2006] [crit] (2)No such file or directory: Digest: error generating secret: No such file or directory
Configuration Failed


kann mir da jemand helfen?

dank
cola
 
Posts: 74
Joined: 19. February 2004 08:38

Postby deepsurfer » 19. June 2006 19:14

jo....diese meldung hab ich auch jedesmals beim starten des XAMPP-apachen.

Er läuft aber trotzdem einwandfrei..
Diesen Logreintrag kannst abhaken.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby cola » 19. June 2006 19:22

ach so.... jedoch startet er bei mir trozdem nicht.... was ich eben komisch finde :) und in den logs steht nur das gepostete..... giebts sonst noch logs?
cola
 
Posts: 74
Joined: 19. February 2004 08:38

Postby deepsurfer » 19. June 2006 19:29

/opt/lampp/logs

error_log
access_log
apachestart.log


Dann kannste auch mal schaun ob ob sich was in der
/var/log etwas tut (eher nicht das die zwar registrieren was passiert aber XAMPP ist nicht im system eingebunden)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 19. June 2006 19:33

Diesen Logreintrag kannst abhaken.

"mod_auth_digest" tut da noch richtig nach diesem Eintrag?

Dem dürfte jedenfalls " /dev/random" (oder was immer ihr da bei Linux habt) fehlen.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby cola » 19. June 2006 19:53

na ja.... hilft mir nicht gerade weiter :)

hat sonst noch jemand eine idee wie ich den fehler ausfindig machen kann?
cola
 
Posts: 74
Joined: 19. February 2004 08:38

Postby deepsurfer » 19. June 2006 19:57

ohh muss mich korrigieren !! SORRY
bei mir läuft die diggest Generierung durch

Code: Select all
[size=9][notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Sat Jun 17 20:56:44 2006] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sat Jun 17 20:56:44 2006] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Sat Jun 17 20:56:46 2006] [notice] Digest: generating secret for digest authentication ...
[Sat Jun 17 20:56:46 2006] [notice] Digest: done
[Sat Jun 17 20:56:47 2006] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sat Jun 17 20:56:47 2006] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Sat Jun 17 20:56:47 2006] [notice] Apache/2.2.2 (Unix) DAV/2 mod_ssl/2.2.2 OpenSSL/0.9.8b PHP/5.1.4 mod_apreq2-20051231/
2.5.7 mod_perl/2.0.2 Perl/v5.8.7 configured -- resuming normal operations
[/size]
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Wiedmann » 19. June 2006 19:58

na ja.... hilft mir nicht gerade weiter

Wegen?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby cola » 19. June 2006 19:59

hm... an was könnte es noch liegen? Das mir diese Fehlermeldung kommt?
cola
 
Posts: 74
Joined: 19. February 2004 08:38

Postby Wiedmann » 19. June 2006 20:01

an was könnte es noch liegen?

Wieso "noch"? Ich hab dir doch gesagt woran es liegt...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby cola » 19. June 2006 20:04

das wegen dem "mod_auth_digest" ?

wo finde ich den?

danke für die hilfe
cola
 
Posts: 74
Joined: 19. February 2004 08:38

Postby Wiedmann » 19. June 2006 20:08

das wegen dem "mod_auth_digest" ?

Wo die Lib beim Linux XAMPP liegt kann ich dir nicht sagen. Das dürftest aber wohl mit "find" herausfinden. Geladen wird dieses Modul in der "httpd.conf" (und dabei tritt der Fehler auf).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby cola » 19. June 2006 20:13

benötige ich das modul? oder wozu dient es?
cola
 
Posts: 74
Joined: 19. February 2004 08:38

Postby Wiedmann » 19. June 2006 20:16

benötige ich das modul?

Keine Ahnung... Das kannst eigentlich nur du wissen.

oder wozu dient es?

Vorlesen kostet extra...
http://httpd.apache.org/docs/2.2/en/mod ... igest.html
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby cola » 19. June 2006 20:21

super danke... ohne das modul funktioniert es.... jedoch finde ich schade das ich den fehler nur so beheben kann....

wen jemand eine bessere lösung hat, bitte melden.....

danke nochmals....
cola
 
Posts: 74
Joined: 19. February 2004 08:38

Next

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests