Probleme mit SSL und Apache

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Probleme mit SSL und Apache

Postby Newland » 19. June 2006 12:00

Hallo Leute.

Ich habe folgendes Problem.
Ich habe SuSe Linux 9.3 installiert, und will darauf nen Webserver laufen lassen.
Dafür habe ich mir das Xampp für Linux besorgte, installiert, und wollte den Apache jetzt starten.

Doch jedes mal wenn ich in der Komandozeile

/opt/lampp/lampp start eingebe, kommt folgende Fehlermeldung.

Starting XAMPP for Linux 1.5.3a...
/opt/lampp/bin/php: error while loading shared libraries: /opt/lampp/lib/libpanel.so.5: file too short
XAMPP: Starting Apache with SSL ...
XAMPP: Error 127! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: XAMPP-ProFTPD is already running.
XAMPP for Linux started.

Da ich von Linux nicht so die Ahnung habe, hoffe ich auf eure unterstützung.

Anmerkung dazu. ich habe auch versucht SSL einfach mit

/opt/lampp/lampp startssl zu starten. da kommt die gleiche Fehlermeldung.

Wenn mit jemand helfen kann, bitte meldet euch

Gruss Newland
Newland
 
Posts: 5
Joined: 19. June 2006 11:30

Postby deepsurfer » 19. June 2006 16:07

Hast du mal XAMPP-Downloadfile überprüft ob die MD5 Checksumme übereinstimmt ?

MD5wert der XAMPP-DEV ausgabe

422ab1faa4ab7afb3be8918ab8223b6b


Öffne eine Konsole, gehe in das Verzeichnis wo du das XAMPP tar.gz file hast.

Tippe folgendes ein:
md5sum xampp-linux-1.5.3a.tar.gz

Auf dem Bildschirm sollte nach einigen Sekunden diese Info wieder erscheinen.
422ab1faa4ab7afb3be8918ab8223b6b xampp-linux-1.5.3a.tar.gz

wenn die ausgebene Nummer mit der da oben übereinstimmt ist das tar.gz file einegentlich in Ordnung, sollte sich aber ein Zahl oder buchstabe bei dir anders sein, so downloade dir das XAMPP bitte nochmal, checke die MD5 ab, dann entpacken nach Anleitung.

checken, testen, melden
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Newland » 21. June 2006 08:31

Die Checksumme stimmt, zum glück lässt sich auch der Apache starten,

Jedoch jedes mal wenn ich dann versuche über den Konqueror auf den Localhost zuzugreifen, kommt folgende Meldung:

Warning: file_get_contents(lang.tmp) [function.file-get-contents]: failed to open stream: Permission denied in /opt/lampp/htdocs/xampp/index.php on line 2

Warning: Cannot modify header information - headers already sent by (output started at /opt/lampp/htdocs/xampp/index.php:2) in /opt/lampp/htdocs/xampp/index.php on line 4

Und ich habe mal wieder keine Ahnung, was da jetzt schiefgelaufen ist.

Habe alles nach Anweisung gemacht, und trotzdem funktioniert nichts.

Vielleicht könnt ihr mir ja auch da noch helfen.

MFG Newland
Newland
 
Posts: 5
Joined: 19. June 2006 11:30

Postby PF4 » 21. June 2006 14:11

Hallo,

ls -l /opt/lampp | grep htdocs

ich wette du hast es nicht als root entpackt.
"2 Dinge sind unendlich die Dummheit der Menschheit und das Universum , aber beim Universum bin ich mir noch nicht sicher“
Albert Einstein
PF4
 
Posts: 528
Joined: 10. March 2003 09:15

Postby sphonyx » 21. June 2006 18:39

Gleiches Problem andere Distribution !
Ich benutze schon seit einiger Zeit Debian und trotz entpacken des tars via superuser -Rechten,
bekomme ich die gleiche Fehlermeldung
Code: Select all
*****:/opt/lampp# ./lampp start
Starting XAMPP for Linux 1.5.3a...
/opt/lampp/share/lampp/phpstatus: line 4: /opt/lampp/bin/php: No such file or directory
XAMPP: Starting Apache with SSL ...
XAMPP: Error 127! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
/opt/lampp/bin/mysql.server: line 1: ./bin/my_print_defaults: No such file or directory
/opt/lampp/bin/mysql.server: line 1: ./bin/my_print_defaults: No such file or directory
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP: ./lampp: line 302: /opt/lampp/sbin/proftpd: No such file or directory
XAMPP: Error 127! Couln't start ProFTPD!


Wie geschrieben, Rechte besitzen die Ordner
Code: Select all
drwxr-xr-x  20 root root 1024 May 30 18:12 lampp


MD5-Summe ist die Selbige wie die oben angegebene ...
Was schlagt ihr vor sollte ich tun ?

@Newland : Benutzt du die AMD64 Version von Suse ?
sphonyx
 
Posts: 1
Joined: 21. June 2006 18:31

Postby Newland » 22. June 2006 13:07

danke leute für eure hilfe.

Nach einer Neuinstallation von Linux und dem neuaufsetzen des Xampp für Linux, fuinktioniert mein Apache jetzt tadellos.

"Jetzt nur noch der Webmin, und ich bin der glücklichste Mensch auf der Welt".


Also vielen danke noch mal und man sieht sich.

MFG Newland
Newland
 
Posts: 5
Joined: 19. June 2006 11:30


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests