XAMPP unter Linux 10.0

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP unter Linux 10.0

Postby DARK_SOLDIER » 18. June 2006 12:37

hi,

ich bekomme folgende Fehlermeldung wenn ich XAMPP starten will

Code: Select all
(none):~ # /opt/lampp/lampp start
Starte XAMPP fuer Linux 1.5.3a...
XAMPP: Starte Apache mit SSL (und PHP5)...
XAMPP: Starte MySQL...
XAMPP: Starte ProFTPD...
XAMPP:  - IPv4 getaddrinfo '_none_' error: Name or service not known
 - warning: unable to determine IP address of '_none_'
 - error: no valid servers configured
 - Fatal: error processing configuration file '/opt/lampp/etc/proftpd.conf'
XAMPP: Fehler 1 beim Starten von ProFTPD!
XAMPP fuer Linux gestartet.


danke schonma für die hilefe


MFG
DARK_SOLDIER
 
Posts: 5
Joined: 18. June 2006 12:29

Postby deepsurfer » 18. June 2006 13:07

deien /etc/hosts datei ist nur _none_ eingetragen, dort dürfte die localhost definition fehlen.

desweiteren mal den inhalt deiner /etc/resolv.conf posten.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby DARK_SOLDIER » 18. June 2006 13:33

die resol.conf weisst folgendes for

Code: Select all
### BEGIN INFO
#
# Modified_by:  dhcpcd
# Backup:       /etc/resolv.conf.saved.by.dhcpcd.eth0
# Process:      dhcpcd
# Process_id:   4427
# Script:       /sbin/modify_resolvconf
# Saveto:       
# Info:         This is a temporary resolv.conf created by service dhcpcd.
#               The previous file has been saved and will be restored later.
#               
#               If you don't like your resolv.conf to be changed, you
#               can set MODIFY_{RESOLV,NAMED}_CONF_DYNAMICALLY=no. This
#               variables are placed in /etc/sysconfig/network/config.
#               
#               You can also configure service dhcpcd not to modify it.
#               
#               If you don't like dhcpcd to change your nameserver
#               settings
#               then either set DHCLIENT_MODIFY_RESOLV_CONF=no
#               in /etc/sysconfig/network/dhcp, or
#               set MODIFY_RESOLV_CONF_DYNAMICALLY=no in
#               /etc/sysconfig/network/config or (manually) use dhcpcd
#               with -R.  If you only want to keep your searchlist, set
#               DHCLIENT_KEEP_SEARCHLIST=yes in /etc/sysconfig/network/dhcp or
#               (manually) use the -K option.
#
### END INFO
domain example.com
nameserver 213.202.193.165
nameserver 213.202.250.188



und die host.conf


Code: Select all
#
# /etc/host.conf - resolver configuration file
#
# Please read the manual page host.conf(5) for more information.
#
#
# The following option is only used by binaries linked against
# libc4 or libc5. This line should be in sync with the "hosts"
# option in /etc/nsswitch.conf.
#
order hosts, bind
#
# The following options are used by the resolver library:
#
multi on

DARK_SOLDIER
 
Posts: 5
Joined: 18. June 2006 12:29

Postby DARK_SOLDIER » 18. June 2006 13:48

könnt ihr mir sagen was ich jetzt tun muss


MFG DARK
DARK_SOLDIER
 
Posts: 5
Joined: 18. June 2006 12:29

Postby kleinweby » 18. June 2006 18:01

nabend,

deepsurfer meinte die datei /etc/hosts nicht die /etc/host.conf das sind unterschiedliche dateien.

kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Postby DARK_SOLDIER » 18. June 2006 18:05

hatt sich erledigt

hab suse linux 9.3 draufgemacht und läuft nun
DARK_SOLDIER
 
Posts: 5
Joined: 18. June 2006 12:29

Postby Kristian Marcroft » 19. June 2006 20:52

Hallo,

folgendes hätte gereicht:

# echo "127.0.0.1 `hostname`" >> /etc/hosts

Gruß
km
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby DARK_SOLDIER » 20. June 2006 12:39

moin,

hatte jetzt funktioniert aber nach nem restart meines roots kam wieder der fehler


Code: Select all
XAMPP: Starting ProFTPD...
XAMPP:  - IPv4 getaddrinfo '_none_' error: Name or service not known
 - warning: unable to determine IP address of '_none_'
 - error: no valid servers configured
 - Fatal: error processing configuration file '/opt/lampp/etc/proftpd.conf'
XAMPP: Error 1! Couln't start ProFTPD!


mit dem befehl

Code: Select all
echo 127.0.0.1 `hostname` >> /etc/hosts


passiert nichts

danke schonma im vorraus
DARK_SOLDIER
 
Posts: 5
Joined: 18. June 2006 12:29

Postby deepsurfer » 20. June 2006 15:23

- deine /etc/hosts datei mal posten.
- da nun ein anderes SuSE auch hier wiederum die /etc/resolv.conf posten
- Was erscheint in der Konsole bei Eingabe von hostname ?

Kann es sein das Du beim Installieren des SuSE, bei der Frage nach dem Rechnernamen "_none_" eingegeben hast, oder gar nichts eingetippt ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby DspT´sA » 30. July 2006 17:00

Also ich habe das gleiche Problem wie Dark Soldier.
Bei mir läuft Xampp auch auf dem OS SuSe 9.3 und nach einem Reboot des Servers setzt er den Rootnamen auf "(none)" und gibt mir ebenfalls die fehlermeldung aus:

Code: Select all
(none):/opt/lampp # lampp start
Starting XAMPP for Linux 1.5.3a...
XAMPP: XAMPP-Apache is already running.
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP:  - IPv4 getaddrinfo '_none_' error: Name or service not known
 - warning: unable to determine IP address of '_none_'
 - error: no valid servers configured
 - Fatal: error processing configuration file '/opt/lampp/etc/proftpd.conf'
XAMPP: Error 1! Couln't start ProFTPD!
XAMPP for Linux started.



hosts datei
Code: Select all
#
# hosts         This file describes a number of hostname-to-address
#               mappings for the TCP/IP subsystem.  It is mostly
#               used at boot time, when no name servers are running.
#               On small systems, this file can be used instead of a
#               "named" name server.
# Syntax:
#
# IP-Address  Full-Qualified-Hostname  Short-Hostname
#

127.0.0.1       localhost

# special IPv6 addresses
::1             localhost ipv6-localhost ipv6-loopback

fe00::0         ipv6-localnet

ff00::0         ipv6-mcastprefix
ff02::1         ipv6-allnodes
ff02::2         ipv6-allrouters
ff02::3         ipv6-allhosts
127.0.0.2       .example.com
127.0.0.1 linux # added by Apache Friends XAMPP
127.0.0.1 (none) # added by Apache Friends XAMPP



resolv.conf
Code: Select all
### BEGIN INFO
#
# Modified_by:  dhcpcd
# Backup:       /etc/resolv.conf.saved.by.dhcpcd.eth0
# Process:      dhcpcd
# Process_id:   5340
# Script:       /sbin/modify_resolvconf
# Saveto:
# Info:         This is a temporary resolv.conf created by service dhcpcd.
#               The previous file has been saved and will be restored later.
#
#               If you don't like your resolv.conf to be changed, you
#               can set MODIFY_{RESOLV,NAMED}_CONF_DYNAMICALLY=no. This
#               variables are placed in /etc/sysconfig/network/config.
#
#               You can also configure service dhcpcd not to modify it.
#
#               If you don't like dhcpcd to change your nameserver
#               settings
#               then either set DHCLIENT_MODIFY_RESOLV_CONF=no
#               in /etc/sysconfig/network/dhcp, or
#               set MODIFY_RESOLV_CONF_DYNAMICALLY=no in
#               /etc/sysconfig/network/config or (manually) use dhcpcd
#               with -R.  If you only want to keep your searchlist, set
#               DHCLIENT_KEEP_SEARCHLIST=yes in /etc/sysconfig/network/dhcp or
#               (manually) use the -K option.
#
### END INFO
search example.com
nameserver 213.202.193.165
nameserver 213.202.250.188


wär für jede hilfe dankbar
DspT´sA
 
Posts: 1
Joined: 30. July 2006 16:41
Location: Stendal

Postby mosaxforum » 06. August 2006 09:50

DARK_SOLDIER wrote:Linux 10.0
Das gibt es nicht. Du meinst sicherlich openSuSe 10.0. Linux ist nur der Kernel, aktuell in Version 2.6.
mosaxforum
 
Posts: 2
Joined: 05. August 2006 23:53


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests