Xampp 1.53a+Oracle 10g

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Xampp 1.53a+Oracle 10g

Postby ollidroll » 12. June 2006 21:13

Hallo,
ich weiß hier gibt es schon einige Beiträge zu diesem Thema.

Ich habe Xampp auf einem SLES9 64bit System installiert.

Xampp (mit OCI8) läuft auch soweit (normale PHP-Seiten werden angezeigt) , wenn ich jedoch auf die Oracle DB zugreifen will, passiert nix, das Browserfenster bleibt weiß.

Jetzt habe ich alle Libarys auf das das lib32 Verz. umgelegt ( ln -s ...), funktioniert aber trotzdem nicht.
Die Umgebungsvariablen sind gesetzt (werden unter PHP-Info korrekt angezeigt).
Habe ich noch irgendwas vergessen?
Welche Xampp Libarys müssten alle umgelinkt werden?
Müssen die Umgebungsvariblen auf das 32 Verzeichniss zeigen oder auf das normale?

Habe das schonmal auf einem älterem (32bit-)System gemacht, da funktioniert alles ohne Probleme.

Kann mir evtl. jemand einen Tipp geben? Bin etwas ratlos....
Danke & Viele Grüße
Olli
ollidroll
 
Posts: 45
Joined: 17. February 2003 10:41

Postby ollidroll » 13. June 2006 14:49

Vielleicht noch als Hinweis:

Im error_log des Apache steht folgendes:
[Tue Jun 13 15:46:56 2006] [notice] child pid 394 exit signal Segmentation fault (11)

Vielen Dank!
Gruß
Olli
ollidroll
 
Posts: 45
Joined: 17. February 2003 10:41

Postby matrix83 » 10. January 2007 16:18

Hallo Oli,

ich habe das genau gleiche Problem wie du beschreiben hast wenn ich auf eine Oracle 10 Datenbank zugreifen will. Hast du mittlerweile ein Lösung für das Problem gefunden?
Wenn ja wärs super, wenn du sie mir schreiben könntest.

ciao
matrix
matrix83
 
Posts: 9
Joined: 28. September 2004 09:10

Postby ollidroll » 10. January 2007 18:17

Hai,
nein, ich habe noch keine Lösung, bin mir aber ziemlich sicher woran es liegt.
Und zwar scheinen die Oracle Umgebungsvariablen nicht angenommen zu werden, warum auch immer.

Ich habe diese in das Startscript von Xampp (lampp) eingebaut, aber es bringt nix.
Habe schon so ziemlich jede Variante ausprobiert.
Es ist bestimmt nur eine Kleinigkeit, aber ich bin schon ein wenig am verzweifeln.

Es kann aber auch an der 64bit Version liegen, das wäre die 2. Möglichkeit, ich denke es liegt aber eher an den Umgebungsvariablen.

Viele Grüße
Olli
ollidroll
 
Posts: 45
Joined: 17. February 2003 10:41

Postby matrix83 » 10. January 2007 22:16

Hallo Olli,

also ich bin mir ganz sicher dass es an den Umgebungsvariablen liegt. Sobald die NLS_LANG nicht gesetzt ist funktioniert es bei mir. Bloß brauche ich den Parameter unbedingt, da sonst keine äöü und ß angezeigt werden.

Ich habe die 32bit Version installiert mit der aktuellen XAMPP Version (1.5.5a) und es bringt au nix...
matrix83
 
Posts: 9
Joined: 28. September 2004 09:10

Postby ollidroll » 11. January 2007 11:25

Hai,
vielen Dank noch mal für deinen Tipp. Habe mich bis eben da noch mal intensiver drum gekümmert. Es funktioniert jetzt bei mir.

Nachdem ich die NLS_LANG Parameter rausgenommen habe, habe ich folgende Fehlermeldung bekommen (vorher hatte ich nur ein "weißes Blatt"):
ocilogon(): _oci_open_server: Error while trying to retrieve text for error ORA-12154

Darauf hin habe ich noch mal geforscht und folgende Seite gefunden:
http://www.oracle.com/technology/tech/p ... g_faq.html

Dort habe ich gelesen, das bei 10G ne andere AnmeldeSyntax gibt und das man ein PUTENV in einem PHP Script nicht mehr braucht.
$c = OCILogon('myusername', 'mypassword', '//mymachine.mydomain/MYDB');

Seit dem geht es einwandfrei (allerdings ohne NLS_LANG, ich schau da noch mal weiter)
Vielleicht hilft Dir das ja auch.
Viele Grüße
Olli

EDIT: hier gibt es Info zu NLS_LANG
http://www.muniqsoft.de/tipps/monatstip ... upport.htm
Ggf. hilft das ja noch
ollidroll
 
Posts: 45
Joined: 17. February 2003 10:41


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests