OpenSSL bei LAMPP??

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

OpenSSL bei LAMPP??

Postby MAD King » 25. July 2003 07:46

Hallo,

erst einmal recht herzlichen Dank für Eure Mühe so ein Paket zu erstellen.
Die Installation war super schnell und einfach.
Mit anderen Worten: Unbezahlbar.

Jetzt habe ich ein Problem. Ich wollte gerade unter dem LAMPP Webmin-Webmin-Konfiguration die SSL-Verschlüsselung einrichten (lief bei meiner vorhergehenden Webmin Version schon) da bekam ich auch schon eine Fehlermeldung:

Das Net::SSLeay Perl-Modul scheint auf Ihrem System nicht installiert zu sein. Um die OpenSSL-Bibliothek und Net::SSLeay zu installieren, folgen Sie diesen Anweisungen von der Webmin-Webseite.
The error message from Perl was :
Can't locate Net/SSLeay.pm in @INC (@INC contains: /opt/lampp/lib/perl5/5.8.0/i686-linux /opt/lampp/lib/perl5/5.8.0 /opt/lampp/lib/perl5/site_perl/5.8.0/i686-linux /opt/lampp/lib/perl5/site_perl/5.8.0 /opt/lampp/lib/perl5/site_perl .) at (eval 5) line 2.
BEGIN failed--compilation aborted at (eval 5) line 2.


Was hat das zu bedeuten und wie kann ich es beheben?

Tausend Dank

Gruss
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Postby Oswald » 25. July 2003 08:35

Huhu Mad!

Das bedeutet, dass das Net::SSLeay Perl-Modul nicht im LAMPP mit enthalten ist und daher der SSL-Server im Webmin nicht aktiviert werden kann.

Mir ist das schon länger klar, aber ich hab es beim Erstellen des Webmin-Add-Ons damals nicht geschafft, dass Perl-SSLeay-Modul übersetzt und installiert zu bekommen.

Ich werd mich wahrscheinlich am Wochenende um eine neue LAMPP-Version kümmern und mich dann auch noch mal mit dem SSLeay-Modul beschäftigen.

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby MAD King » 25. July 2003 08:42

Hallo Kai,

wie kann ich das Problem aus der Welt schaffen?

Gruss
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Postby Pc-dummy » 25. July 2003 09:12

Hi Mad King

Am besten in dem du bis am Wochenende wartest :)

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby MAD King » 25. July 2003 09:19

Na klasse. Jetzt gehen meine Domains nicht mehr.
Aber halt. das Wochende ist ja schon. Ich hoffe Kai meint dieses.
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Postby Pc-dummy » 25. July 2003 09:21

Hi Mad King

Wie meinste Domains gehen nicht mehr?

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby MAD King » 25. July 2003 09:27

Ich kann den Apache nicht mehr starten.
Bekomme diese Meldung:

Fehler beim Starten von Apache :
LAMPP: Starting Apache with SSL...
Syntax error on line 141 of /etc/httpd/vhosts.oldip:
User cannot occur within section
LAMPP: Error 1! Couln't start Apache!

Hängt mit SSL zusammen, das ich benötige.
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Postby Oswald » 25. July 2003 09:28

MAD, Du brauchst SSL-Zugriff auf Webmin zum Betrieb Deiner Domains? Meinst Du nicht eher, dass Du SSL für den Apache brauchst?

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby MAD King » 25. July 2003 09:31

Die Fehlermeldungen sagen mir beides.
Für Webmin OpenSSL und für Apache SSL.

Ist vor der Installation des LAMPP einwandfrei gelaufen. Heul.
Möchte aber Euer Paket nicht mehr missen wollen!!!!
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Postby Oswald » 25. July 2003 09:41

Also "User cannot occur within section" hat definitv nichts mit SSL zu tun. Die User-Direktive wird im Apache 2 einfach nicht in der (ich vermute mal das ist bei Dir der Fall) VirtualHost-Section erlaubt.
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby MAD King » 25. July 2003 09:44

Oha, dass wusste ich nicht. Ich habe einfach meine Virtual Hosts in eine Datei vhosts.oldip gespeichert und diese dann als include in die httpd.conf eingebunden.

Was habe ich zu tun?
Leider habe ich mich noch nicht so mitdem Apache 2 befasst.
Hatte bisher nur Apache 1.3.26

Gruss
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Postby MAD King » 25. July 2003 10:19

Also ich blicke da nicht so recht durch.

In meiner conf stehen die Virtual so:

<Directory "/home/www/domain1/logs">
AllowOverride all
DirectoryIndex index.html index.htm
AuthType Basic
AuthName "Logdateien"
AuthUserFile /etc/userlist.conf
require user domain1
</Directory>
<Directory "/home/www/domain1/html">
DirectoryIndex index.html index.htm index.php index.php3 index.php4 index.shtml index.shtm index.sht
Options +ExecCGI +Includes
</Directory>

Versteh ich nicht, was daran falsch sein soll, zumal die Apache 2 Doc das gleiche sagt.
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Postby Oswald » 25. July 2003 11:46

Huhu Mad!

Such mal nach <VirtualHost>. Dort werden die Virtual Hosts konfiguriert. Das <Directory> hat nichts mit Virtual Hosts zu tun. Und dort wirst Du auch was mit "User" stehen haben und das ist eben nicht richtig.

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby MAD King » 25. July 2003 11:48

Mache ich.

Tausend Dank, Kai für die Hilfe.
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Postby MAD King » 25. July 2003 11:56

Also,

ich kann da aber auch nicht falsches daran entdecken.

<VirtualHost 195.xx.xxx.51>
ServerName server.mein.server.de
DocumentRoot /home/www/user1/html
User user1
Group ftponly
php_admin_value open_basedir /home/www/user1
php_admin_value upload_tmp_dir /home/www/user1/phptmp
CustomLog /home/www/user1/logs/access_log common
CustomLog /var/log/httpd/access_log common
CustomLog /var/log/httpd/http_traffic_log traffic
ServerAlias domain.de
ServerAlias www.domain.de
</VirtualHost>

<VirtualHost 195.xx.xxx.51>
ServerName log.mein.server.de
DocumentRoot /home/www/user1/logs
User user1
Group ftponly
</VirtualHost>

Gruss
User avatar
MAD King
 
Posts: 82
Joined: 25. July 2003 07:41

Next

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests