MySQL startet nicht

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

MySQL startet nicht

Postby Sinai » 19. May 2006 22:07

Hallo zusammen

Ich hab erstmal XAMPP 1.5.2 unter Dawn small linux installiert (Debian). Installation klappte problemlos, Apache startet, aber der start von MySQL ergibt keine Fehlermeldung und MySQL läuft trotzdem nicht.

Ich hab unten das Logfile box.err gepostet, aber eine mysql.sock im entspr. Verzeichnis existiert nicht

Vielleicht liegt es ja am Kernel 2.4.26?

Kann mir jemand helfen?

Danke

Andy

Code: Select all
060519 20:00:59  mysqld started
060519 20:00:59 [ERROR] Can't start server : Bind on unix socket: Permission denied
060519 20:00:59 [ERROR] Do you already have another mysqld server running on socket: /opt/lampp/var/mysql/mysql.sock ?
060519 20:00:59 [ERROR] Aborting
Sinai
 
Posts: 4
Joined: 19. May 2006 21:57

Postby deepsurfer » 20. May 2006 00:37

aber der start von MySQL ergibt keine Fehlermeldung und MySQL läuft trotzdem nicht.

Diese Aussage verwirrt, denn wenn der MySQL startet und keine Fehlermeldung hervorbringt, so läuft dieser auch.

Der gepostete Fehlerbericht bezieht sich auf den XAMPP MySQL.

Daraus schliesse ich das du im D-S-L einen MySQL server mit installiert ist/wurde und du diesen gestartet hattest, wenn nun der XAMPP versucht seinen MySQL zu starten so blockiert der schon existierende und laufende MySQL-Server den XAMPP-MySQL.

Folglich: erst abchecken das kein anderer MySQL läuft, wenn nun immer noch der XAMPP-MySQL-Server beim hochfahren diese Meldung ausgibt, muss geklärt werden was für ein Programm bei dir den Port 3306 blockiert.

Gedankengang:
Hast du eventuell ein Filesharing tool auf dem SmallLinux laufen ??
Diese Filesharing tools benutzen zur Communizieren und Downloading auch die normalen Ports und wenn grad ein Downloadpaket auf dem Port 3306 läuft so blockiert das den XAMPP-MySQL
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Sinai » 20. May 2006 18:12

MySQL läuft meines erachtens nicht unter DSL.

top:

Mem: 138312K used, 53124K free, 0K shrd, 5664K buff, 76388K cached
Load average: 0.11, 0.09, 0.09 (State: S=sleeping R=running, W=waiting)

PID USER STATUS RSS PPID %CPU %MEM COMMAND
312 root S 12M 311 5.9 6.7 Xvesa
436 dsl S 22M 431 0.0 12.0 firefox-bin
439 dsl S 22M 438 0.0 12.0 firefox-bin
441 dsl S 22M 438 0.0 12.0 firefox-bin
438 dsl S 22M 436 0.0 12.0 firefox-bin
324 dsl S 2712 1 0.0 1.4 xtdesk
316 dsl S 1856 311 0.0 0.9 fluxbox
264 root S 1788 1 0.0 0.9 bash
280 dsl S 1780 264 0.0 0.9 bash
500 dsl S 1552 1 0.0 0.8 aterm
501 dsl S 1540 500 0.0 0.8 bash
329 dsl S 1500 316 0.0 0.7 fluxter
330 dsl S 1300 316 0.0 0.6 docked.lua
411 dsl S 1160 1 0.0 0.6 firefox
431 dsl S 1156 411 0.0 0.6 run-mozilla.sh
298 dsl S 1088 280 0.0 0.5 startx
351 dsl S 1012 1 0.0 0.5 dpid
341 dsl S 888 1 0.0 0.4 torsmo
353 dsl S 880 351 0.0 0.4 file.dpi
355 dsl S 880 353 0.0 0.4 file.dpi
561 dsl R 796 501 0.0 0.4 top
52 root S 720 1 0.0 0.3 cardmgr
332 dsl S 696 330 0.0 0.3 wmswallow
311 dsl S 644 298 0.0 0.3 xinit
248 root S 580 1 0.0 0.3 syslogd
1 root S 76 0 0.0 0.0 init
2 root SW 0 1 0.0 0.0 keventd
322 dsl Z 0 316 0.0 0.0 iconsnap.lua
3 root SWN 0 1 0.0 0.0 ksoftirqd_CPU0
4 root SW 0 1 0.0 0.0 kswapd
5 root SW 0 1 0.0 0.0 bdflush
6 root SW 0 1 0.0 0.0 kupdated
91 root SW 0 1 0.0 0.0 khubd
314 root SW 0 1 0.0 0.0 kapmd

Starte ich synaptics erscheint mysql auch als nicht installiert.

Trotzdem bekomme ich keine Fehlermeldung wenn ich XAMPP starte. Auch das alleinige starten von mysql bringt keine Fehlermeldung.

Aber soeben habe ich sqlite gefunden. Aber ein daemon läuft da imo nicht, oder?

Kann es daran liegen? Wenn ja, wie bekomme ich bei einer Debiandistri sqlite deinstalliert? Bisher hatte ich nur rpm-basierte Syteme.

Danke

Andy
Sinai
 
Posts: 4
Joined: 19. May 2006 21:57

Postby Sinai » 20. May 2006 20:24

Hallo nochmal

Ich hab jetzt XAMPP nochmal entfernt und nochmals per tar xzvf ... extrahiert und jetzt startet MySQL plötzlich. Wird sich wohl nicht klären lassen, warum es plötzlich geht. Vielleich ein Fehler beim ersten entpacken?

Ich weiß es nicht, aber es geht jetzt wenigstens

Andy
Sinai
 
Posts: 4
Joined: 19. May 2006 21:57


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest