eAccelerator with Lampp 1.5.2

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

eAccelerator with Lampp 1.5.2

Postby neilljones » 02. May 2006 14:54

Hi everyone

I am trying to get eaccelerator working with Lampp 1.5.2, and have downloaded the latest version, and compiled it with the instructions given by eaccelerator. I get the following error when I run

PHP Warning: [eAccelerator] This build of "eAccelerator" was compiled for PHP version 5.1.1. Rebuild it for your PHP version (5.1.2) or download precompiled binaries.

I have just upgraded lampp 1.5.1 to lampp 1.5.2 and checked the php.config file, which says it is php 1.5.2, and I configured the eaccelerator with the command

./configure --enable-eaccelerator=shared --with-php-config=/opt/lampp/bin/php-config

before compiling. On installation it installed the executable into

Does the latest eaccelerator work with lampp 1.5.2 does anyone know?
If it does, how do I get it to compile against the correct version of php?

Thanks for any help, pointers etc


Neill Jones
Posts: 3
Joined: 02. May 2006 14:31

Postby deepsurfer » 02. May 2006 15:05

Have you download the XAMPP-DEV package ? you need this to compile anything for XAMPP
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
AF Moderator
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby neilljones » 02. May 2006 15:58

Thanks! I did download it for the previous version so I think you have hit the nail on the head :-) I'll get back to this if that doesn't work.

Best regards

Neill Jones
Posts: 3
Joined: 02. May 2006 14:31

Problem with eAccelerator under PHP5

Postby ancoma » 04. May 2006 21:34

take a look to,

and then take a look to the ReleaseVersion 0.9.4, last line


Release 0.9.4 ¶

This release only contains some bugfixes and code cleanups. This release is still the old codebase. It doesn't contain any new code yet.

* Some fixed were made to the encoder. The format changed a bit so I bumped up the encoder version. Because the encoder still isn't functional for PHP version other than PHP 4 you should only use this encoder if you want to have line numbers encoded.
* In the next versions we will try to fix the encoder for PHP 5 and 5.1.
* eA should be PHP 5-compatible except for some very unusual cases.
* This version *DOESN'T* support PHP 5.1. For that, see Release-0.9.5-beta1.

i hope that helps..

Posts: 26
Joined: 14. March 2006 21:51
Location: Freiburg

Postby neilljones » 05. May 2006 01:31


Thanks for that. I did have the new beta version, and the problem was that I had forgotten to download the latest Xampp development code and still had the old one.


Posts: 3
Joined: 02. May 2006 14:31

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest