LDAP Zugriff in Apache aktivieren

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

LDAP Zugriff in Apache aktivieren

Postby Fluke » 06. April 2006 15:45

Hallo kann mir jemand sagen wie man in XAMPP für Linux 1.5.1 die LDAP Unterstützung so aktivieren kann, dass in der httpd.conf Befehle wie beispielsweise "AuthLDAPAuthoritative on" etc. Verfügbar sind und vom Apache erkannt werden?

Irgendwo beim googeln im Internet habe ich gelesen, dass man dazu zuvor die beiden Module "mod_auth_LDAP.so" und "util_ldap.so" im Apache einladen muss. Die beiden Module sind bei mir im Verzeichnis "/opt/lampp/modules" jedoch gar nicht vorhanden!
Somit kann ich diese auch nicht so einfach in die httpd.conf aufnehmen, da sie dann logischerweise nicht gefunden werden können.

Muß außer Xampp sonst noch zusätzlich etwas installiert werden. Als Betriebssystem kommt Suse 10 Professional zum Einsatz. Falls die beiden oben genannten Module zwingend dazu benötigt werden wo kann ich diese dann ggf. herbekommen?
Das einzige Backup, das du wirklich brauchst ist das wofür du keine Zeit hattest
Fluke
 
Posts: 7
Joined: 09. February 2006 19:42
Location: Talheim

Postby Fluke » 07. April 2006 09:06

Das Modul "mod_auth_ldap.so" habe ich mittlerweile im Standardmodulverzeichnis des Suse internen Apache2-Servers (also nicht des Xampp Apache2-Servers!) finden können und hab die Datei einfach in das Verzeichnis "/opt/lampp/modules" herüberkopiert und anschließend in die Xampp "httpd.conf "mit eingebunden. Soweit sogut.
Wenn ich jetzt allerdings Xampp mit dem Befehl "/opt/lampp/lampp restart" neu starte erhalte ich die Fehlermeldung:

"Cannot load /opt/lampp/modules/mod_auth_ldap.so into server: /opt/lampp/modules/mod_auth_ldap.so: undefined symbol: util_ldap_connection_close"

Kann jemand mit der Fehlermeldung etwas anfangen und mir ggf. einen Tipp geben woran das liegen könnte? Als Anmerkung möchte ich noch hinzufügen, dass das in Xampp enthaltene Modul "mod_ldap.so" problemlos eingeladen werden kann.
Das einzige Backup, das du wirklich brauchst ist das wofür du keine Zeit hattest
Fluke
 
Posts: 7
Joined: 09. February 2006 19:42
Location: Talheim

Postby Fluke » 10. April 2006 11:20

Da ja hier enscheinend niemand etwas mit der beschriebenen Fehlermeldung anfangen kann stelle ich meine Frage nun etwas anders herum.
Ich setzte, wie bereits erwähnt, Suse Linux 10 Professional als Betriebssystem ein. Daher die folgende Frage.
Kann mir hier jemand ein "XAMPP für Linux" Paket zusammenbasteln in welchem der vollständige LDAP-Support, also inklusive LDAP-Authentifizierung für den Apache etc., bereits lauffähig enthalten ist!? Ich kämpfe jetzt nämlich schon fast 3 Tage damit herum und bin selbst anscheinend, man entschuldige das Wort, zu dumm es hinzubekommen.

Im voraus besten Dank dafür.
Das einzige Backup, das du wirklich brauchst ist das wofür du keine Zeit hattest
Fluke
 
Posts: 7
Joined: 09. February 2006 19:42
Location: Talheim

Postby ManUnix » 16. April 2006 15:25

Hi Fluke,

Fluke wrote:"Cannot load /opt/lampp/modules/mod_auth_ldap.so into server: /opt/lampp/modules/mod_auth_ldap.so: undefined symbol: util_ldap_connection_close"


die Fehlermeldung rührt daher, dass ihm das zweite Modul fehlt, nämlich
Code: Select all
LoadModule ldap_module modules/mod_ldap.so


Den Eintrag noch dazu und dafür sorgen, dass das Modul auch existiert und dann sollte es gehen.

cu,
Manu
User avatar
ManUnix
 
Posts: 113
Joined: 16. April 2006 15:14

Postby Fluke » 18. April 2006 07:38

@ManUnix:

Das Modul "mod_ldap.so" wird bereits eingeladen und existiert auch unter "/opt/lampp/modules". Trotzdem kommt die beschriebene Fehlermeldung.
Das einzige Backup, das du wirklich brauchst ist das wofür du keine Zeit hattest
Fluke
 
Posts: 7
Joined: 09. February 2006 19:42
Location: Talheim

Postby ManUnix » 18. April 2006 11:45

Hi Fluke,

hm, na sowas.

Ich kann mich erinnern, dass ich da auch ein wenig tüfteln musste, bis ich das drin hatte.

Wenn ich bei mir "LoadModule ldap_module" auskommentiere kommt der von Dir beschriebene Fehler.

In welcher Reihenfolge lädst Du die 2 Module?

Die ist nämlich ausschlaggebend.

Code: Select all
LoadModule ldap_module modules/mod_ldap.so
LoadModule auth_ldap_module modules/mod_auth_ldap.so


Andersrum bringt's bei mir dann auch wieder den Fehler.

Wenn die Reihenfolge auch stimmt, dann sag nochmal bescheid, dann baue ich das selber mal in den neusten XAMPP ein.

cu,
Manu
User avatar
ManUnix
 
Posts: 113
Joined: 16. April 2006 15:14

Postby Fluke » 18. April 2006 14:03

Genau in der Reihenfolge steht es bei mir in der httpd.conf meiner XAMPP-Umgebung drin. Daraufhin läßt sich mein XAMPP Apache nun aber leider gar nicht mehr starten.

Code: Select all
Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/


Testweise habe ich den Apache Server meines Suse Systems (also nicht den in XAMPP enthaltenen Apache Server!) mal auf die aktuelle Version 2.2.0 aktualisiert und daraufhin sämtliche Module der XAMPP-Umgebung in die httpd.conf dieses Servers eingebunden und siehe da die beiden von dir genannten Module ließen sich problemlos einbinden und starten.

Woran kann es also liegen, dass es mit dem "systeminternen" Apache geht und mit dem in XAMPP für Linux enthaltenen Apache nicht? Das würde mich doch schon brennend interessieren. Ich nutze wie bereits erwähnt die XAMPP Version 1.5.1 für Linux. Komisch fand ich dabei jedoch schon von vornherein, dass das Modul "mod_auth_ldap.so" standardmäßig gar nicht im Modulverzeichnis dieser XAMPP Version enthalten war. Vielleicht hilft das ja jemand hier weiter!?
Das einzige Backup, das du wirklich brauchst ist das wofür du keine Zeit hattest
Fluke
 
Posts: 7
Joined: 09. February 2006 19:42
Location: Talheim

Postby PF4 » 18. April 2006 14:34

Hallo,

naja XAMPP für Linux ist halt einfach nicht mit LDAP Support compiliert. So einfach ist das. Mit LDAP ist auch ned so ohne ging zumindest bei mir nicht.
Was die Module angeht du darfst nicht einfach irgendwoher Apache Module benutzen das geht nicht. Du musst MINDESTENS die gleiche Version des Apache haben. Wenn du die LDAP-Mods von suse apache 2.2 benutzt sollte es auch gehen.
"2 Dinge sind unendlich die Dummheit der Menschheit und das Universum , aber beim Universum bin ich mir noch nicht sicher“
Albert Einstein
PF4
 
Posts: 528
Joined: 10. March 2003 09:15


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 5 guests