phpmyadmin

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

phpmyadmin

Postby pws32 » 18. March 2006 03:10

Hallo,

ich benutzte Slackware und habe die neuste lampp inst.
läuft auch soweit alles sehr gut, nur wenn ich auf php4 umstelle
läuft phpmyadmin nicht mehr und gibt folgende Fehler aus

Code: Select all
Warning: session_write_close(): The session id contains invalid characters, valid characters are only a-z, A-Z and 0-9 in /opt/lampp/phpmyadmin/index.php on line 51

Warning: session_write_close(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in /opt/lampp/phpmyadmin/index.php on line 51

Warning: Cannot modify header information - headers already sent by (output started at /opt/lampp/phpmyadmin/index.php:51) in /opt/lampp/phpmyadmin/index.php on line 60

Warning: Cannot modify header information - headers already sent by (output started at /opt/lampp/phpmyadmin/index.php:51) in /opt/lampp/phpmyadmin/index.php on line 121


kann jemand helfen ?

Gruss Peter
pws32
 
Posts: 4
Joined: 06. September 2004 22:19
Location: Erkrath bei D.Dorf

Postby deepsurfer » 19. March 2006 17:52

Welche XAMPP Version genau ??
Die aktuelle 1.5.1 oder hast du die 1.5.2beta ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Timo76 » 29. July 2006 14:09

Also bei mir trit fast der gleiche Fehler auf. Nachdem ich auf PHP4 umgestellt habe.

Warning: session_write_close(): The session id contains invalid characters, valid characters are only a-z, A-Z and 0-9 in /opt/lampp/phpmyadmin/index.php on line 44

Warning: session_write_close(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in /opt/lampp/phpmyadmin/index.php on line 44

Warning: Cannot modify header information - headers already sent by (output started at /opt/lampp/phpmyadmin/index.php:44) in /opt/lampp/phpmyadmin/index.php on line 101


Ich benutze den XAMPP 1.5.3a für Linux frisch installiert. Noch nichts auser auf php4 umgestellt gemacht. Auf php5 lief es. erläst sich auch jetzt nicht mehr auf php5 umstellen.

Woran kann das liegen? Ist in der Version ein Fehler?

Gruß Timo
Timo76
 
Posts: 15
Joined: 03. October 2005 10:55

Postby kleinweby » 29. July 2006 14:26

moin,

um bei der aktuelle version wieder auf php5 wechseln zu können
änderst du in der /opt/lampp/lampp in zeile 471
von:
Code: Select all
/opt/lampp/share/lampp/activatephp 5.1.3

in
Code: Select all
/opt/lampp/share/lampp/activatephp 5.1.4

speicher und /opt/lampp/lampp php5 aufrufen fertig.

kleinweby
User avatar
kleinweby
AF Moderator
 
Posts: 393
Joined: 03. August 2005 19:52
Location: Magdeburg
Operating System: Mac OS X 10.7

Postby Timo76 » 29. July 2006 17:02

Das Problem lag bei mir scheinbar an der Version die ich gezogen habe.
Leider weiß ich nicht mehr auf welchem Server die defekte Datei war. Sie endete jedenfalls mit tar.tar und nicht mit tar.gz.

Mit dem jetzigen Download geht es jedenfalls.

Nur noch die Datenbank mit dem MySQLDumper einspielen und es läuft wieder. Zumindest das erste Forum geht wieder. Die anderen Folgen.

Gruß Timo
Timo76
 
Posts: 15
Joined: 03. October 2005 10:55


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests