Zlib?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Zlib?

Postby Vogelbecker » 12. February 2006 17:54

hiho

normalrweise wird die perl zlib bibiothek automatich mitinstalliert oder?
Wenn ich bei mir aber ein script ausführen will kommt:
Code: Select all
Can't locate Compress/Zlib.pm in @INC (@INC contains: /usr/lib/perl5/5.8.1/i586-linux-thread-multi /usr/lib/perl5/5.8.1 /usr/lib/perl5/site_perl/5.8.1/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.1/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl .) at ./auswert.pl line 47.
BEGIN failed--compilation aborted at ./auswert.pl line 47.


kann mir da jemand helfen oder liegt das problem an was anderem??

Bitte um hilfe, danke
Vogelbecker
Vogelbecker
 
Posts: 13
Joined: 08. February 2006 13:51

Postby Wiedmann » 12. February 2006 20:37

normalrweise wird die perl zlib bibiothek automatich mitinstalliert oder?

AKAIK nicht.

Can't locate Compress/Zlib.pm @INC

Die Meldung sagt ja auch, dass es bei deinem Perl nicht installiert ist.

(@INC contains: /usr/lib/perl5/5.8.1/i586-linux-thread-multi /usr/lib/perl5/5.8.1 /usr/lib/perl5/site_perl/5.8.1/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.1/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl .)

Diese Meldung sagt uns, dass du das Perl von deinem System benutzt und nicht das vom XAMPP. Über dein System-Perl könnten wir aber eh keine Aussage treffen.


BTW:
Egal welches Perl du benutzt, über "cpan" kannst du jedes fehlende Modul nachinstallieren.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Vogelbecker » 14. February 2006 14:19

hi

mmhh aha, sry wenn ich auch nerver, muss aber gerade mal sein :?

habe das leider immernoch nciht hinbekommen. kannst du mir erklähren wiede das mit cpan geht?
Fände es super duper nett wenn jemend schnell antworten konnte, brauche den server am donnerstag, spätestens freitag..

DANKE an alle!

MfG
Vogelbecker
 
Posts: 13
Joined: 08. February 2006 13:51

Postby Wiedmann » 14. February 2006 15:01

kannst du mir erklähren wiede das mit cpan geht?

http://cpan.org/misc/cpan-faq.html#How_ ... rl_modules

Ansonsten bleibt immer noch die Frage offen, ob du absichtlich das Perl von deinem System nimmst und nicht das vom XAMPP (kann dir aber nciht sagen ob da zlib mit drin ist)?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Vogelbecker » 14. February 2006 21:51

hiho

bitte schlag mich. ich bin zu doof dafür.
Ich gebe ein:
Code: Select all
linux:/ # perl -MCPAN -e 'Compress::Zlib '

dauert kurz, dann kommt wieder
Code: Select all
linux:/ #

aber keine fehlermeldung oder so.

Mhh bei dem Xampp steht bei das Zlib dabei ist.
aber wie aktiviere ich das und nutze das andere?


und vielen dank für die hilfe
MfG[/code]
Vogelbecker
 
Posts: 13
Joined: 08. February 2006 13:51

Postby Oswald » 15. February 2006 09:01

Hallo Vogelbecker!

Du verwendest das Perl von Deinem Linux-System und nicht das Perl von XAMPP. Das sieht man deutlich in der ersten Fehlermeldung. Nirgendwo taucht dort /opt/lampp auf.

Ruf bitte mal folgenden Befehl auf:

/opt/lampp/bin/cpan install Compress::Zlib

(Alle Fragen, die Dir nun gestellt werden, mit der Vorgabe beantworten, also einfach immer Return drücken.)

Damit solltest Du dann Zlib haben.

Liebe Grüße
Oswald

PS: zlib ist beim XAMPP dabei, aber nicht das Perl-Modul Zlib.
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Vogelbecker » 15. February 2006 17:30

hiho

jepp ich brauche das perl modul zlib.

ich habe /opt/lampp/bin/cpan install Compress::Zlib ausgeführt, und immer schön yes eingegeben, aber ich bekomme immernoch fehler.

würde es was bringen wenn ich das perl von meinem system einfach mal deinstelliere`?
Wie kann ich auf das perl von xampp umstellen?

bitte um eure hilfe ihr seit meine letzte rettung.
DANKE!

MfG
Vogelbecker
 
Posts: 13
Joined: 08. February 2006 13:51

Postby Oswald » 15. February 2006 17:41

Hallo Vogelbecker!

Das kriegen wir schon hin! ;)

Gab es beim Aufruf von /opt/lampp/.. usw. Fehler oder gibt es die Fehler woanders?

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Vogelbecker » 15. February 2006 18:48

hiho

das hoffe ich :-/

ne da komm ich überall rein, hab das auchs o ausgeführt wie das soll.
aber wenn ich jetzt ein script strarte kommt wieder
Code: Select all
Can't locate Compress/Zlib.pm in @INC (@INC contains: /usr/lib/perl5/5.8.1/i586-linux-thread-multi /usr/lib/perl5/5.8.1 /usr/lib/perl5/site_perl/5.8.1/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.1/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl .) at ./auswert.pl line 47.
BEGIN failed--compilation aborted at ./auswert.pl line 47.


was kann das sein, bitte help me....
Vogelbecker
 
Posts: 13
Joined: 08. February 2006 13:51

Postby Oswald » 15. February 2006 18:51

Hallo Vogelbecker!

Okay, nun muss Dein Skript nur noch das Perl von XAMPP benutzen. Im Moment benutzt es das Perl Deines Systems.

Am Anfang des Skripts findest Du etwa folgende Zeile

#!/usr/bin/perl

Mach daraus:

#!/opt/lampp/bin/perl

Damit sollte es klappen.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Vogelbecker » 15. February 2006 20:02

hiho

jetzt kommt wieder sowas:
Code: Select all
linux:/opt/lampp/htdocs/TEMP # ./auswert.pl
Can't locate Compress/Zlib.pm in @INC (@INC contains: /opt/lampp/lib/perl5/5.8.7/i686-linux /opt/lampp/lib/perl5/5.8.7 /opt/lampp/lib/perl5/site_perl/5.8.7/i686-linux /opt/lampp/lib/perl5/site_perl/5.8.7 /opt/lampp/lib/perl5/site_perl .) at ./auswert.pl line 47.
BEGIN failed--compilation aborted at ./auswert.pl line 47.


ich dreh ab, warum bin ich zu dumm dafür, WARUM??

Weist du was man noch machen könnte?

MfG + Danke
Vogelbecker
 
Posts: 13
Joined: 08. February 2006 13:51

Postby Oswald » 16. February 2006 08:05

Hallo Vogelbecker!

Ich vermute mal, dass der Aufruf von CPAN (Du erinnerst Dich?) doch nicht funktioniert hat. Kannst Du mal den folgenden Befehl aufrufen:

find /opt/lampp -name 'Zlib.*'

Was wird ausgegeben?

Wenn nichts ausgegeben wird, dann ruf bitte noch mal

/opt/lampp/bin/cpan install Compress::Zlib

auf. Und veröffentliche hier mal die - sagen wir mal - letzten 10 Zeilen der Ausgabe dieses Befehls.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Oswald » 16. February 2006 08:09

Hallo Vogelbecker!

Ich hab eine Idee, warum der CPAN-Befehl bei Dir nicht funktioniert hat. Hast Du das Entwicklungspaket installiert? Ohne das, kannst Du keine eigenen Übersetzungen/Installationen für XAMPP machen.

Du bekommst es hier:
http://www.apachefriends.org/de/xampp-linux.html

Das bitte installieren und dann noch mal den CPAN-Befehl aufrufen.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Vogelbecker » 16. February 2006 18:10

Kai 'Oswald' Seidler wrote:Hallo Vogelbecker!

Ich vermute mal, dass der Aufruf von CPAN (Du erinnerst Dich?) doch nicht funktioniert hat. Kannst Du mal den folgenden Befehl aufrufen:

find /opt/lampp -name 'Zlib.*'

Was wird ausgegeben?

Wenn nichts ausgegeben wird, dann ruf bitte noch mal

/opt/lampp/bin/cpan install Compress::Zlib

auf. Und veröffentliche hier mal die - sagen wir mal - letzten 10 Zeilen der Ausgabe dieses Befehls.

Liebe Grüße
Oswald


hiho

ich muss weinen :(

bei find /opt/lampp -name 'Zlib.*'
findtet er nichts.

habe mir Entwicklungspaket jetzt runtergeladen, irgendwie waren es vorrher mehr meldungen die ich bestätigen sollte.

die letzten zeilen:

Code: Select all
.
.
Compress-Zlib-1.41/README
Removing previously used /root/.cpan/build/Compress-Zlib-1.41

  CPAN.pm: Going to build P/PM/PMQS/Compress-Zlib-1.41.tar.gz

Parsing config.in...
Building Zlib enabled
Looks Good.
Up/Downgrade complete.
Checking if your kit is complete...
Looks good
Writing Makefile for Compress::Zlib
  /usr/bin/make  -- NOT OK
Running make test
  Can't test without successful make
Running make install
  make had returned bad status, install seems impossible
You have new mail in /var/spool/mail/root
linux:~ #


*schnief*

MfG
Vogelbecker
 
Posts: 13
Joined: 08. February 2006 13:51

Postby Oswald » 17. February 2006 08:57

Hallo Vogelbecker!

Wie ich vermutet hatte, das Installieren von Zlib hatte nicht geklappt.

So wie es aussieht hast Du kein /usr/bin/make. Kannst Du mal nachgucken?

Wenn Du es nicht hast, dann installiere bitte das Paket "make" über die Paketverwaltung Deiner Distribution.

Und wo Du gerade schon dabei bist, dann überprüfe doch auch gleich mal ob bei Dir gcc installiert ist (einfach mal "gcc" in der Shell aufrufen). Wenn nicht, dann auch "gcc" installieren.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests