Xampp und vHost

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Xampp und vHost

Postby zloty » 10. February 2006 14:41

Ich ab unter /opt/lampp/etc/extra/httpd-vhosts.conf folgendes eingefügt
# Use name-based virtual hosting.
#
NameVirtualHost *:80

#
# VirtualHost example:
# Almost any Apache directive may go into a VirtualHost container.
# The first VirtualHost section is used for all requests that do not
# match a ServerName or ServerAlias in any <VirtualHost> block.
#
<VirtualHost *:80>
ServerAdmin zloty2@zloty2.dnsalias.net
DocumentRoot /opt/lampp/htdocs/lansuite
ServerName zloty2.dnsalias.net
ServerAlias zloty2.dnsalias.net *.zloty.dnsalias.net
ErrorLog logs/zloty2.dnsalias.net-error_log
CustomLog logs/zloty2.dnsalias.net-access_log common
</VirtualHost>


Danach in der /opt/lampp/etc/httpd.conf folgendes aktiviert.
# Virtual hosts
Include etc/extra/httpd-vhosts.conf


Nun dürfte ja wenn ich über http://zloty2.dnsalias.net von aussen connecte die lansuit-startseite kommen. Nur wird da nichts angezeigt bzw. die Seite wird garnicht geladen.

Der Lansuitordner bzw Dateien befinden sich in /opt/lampp/htdocs/lansuit.
zloty
 
Posts: 5
Joined: 09. February 2006 11:16

Postby deepsurfer » 10. February 2006 17:05

Nun dürfte ja wenn ich über http://zloty2.dnsalias.net von aussen connecte die lansuit-startseite kommen. Nur wird da nichts angezeigt bzw. die Seite wird garnicht geladen.


Ist derzeit auch nicht erreichbar.
Ping antwortet, aber sonst nix.
Entweder Server abgeschaltet oder Portforward (falls Router vorhanden) nicht richtig eingestellt.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby zloty » 10. February 2006 17:17

Server läuft. Rundns läuft. Eigentlich alles ok. Ports sind auch offen bzw geforwarded.
zloty
 
Posts: 5
Joined: 09. February 2006 11:16

Postby deepsurfer » 10. February 2006 19:13

hhmmm

Aufruf http://zloty2.dnsalias.net erhalte ich einen Fehler

nslookup zloty2.dnsalias.net = 84.154.189.119

Aufruf http://84.154.189.119 erhalte ich einen Fehler

nmap 84.154.189.119 <<---geht nun bis zum router
PORT STATE SERVICE
22/tcp open ssh
25/tcp open smtp
80/tcp open http
110/tcp open pop3
995/tcp open pop3s
1720/tcp filtered H.323/Q.931
3306/tcp open mysql
4000/tcp open remoteanything

hhmmm normalerweise sollte es gehen, es sei denn du hast noch eine Firewall am laufen die noch die Ports blocks.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests

cron