XAMPP für Linux und Outlook Web Access (OWA)

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP für Linux und Outlook Web Access (OWA)

Postby Fluke » 09. February 2006 20:50

Hallo,
wir haben bei uns in der Firma in etwa folgendes vor. Wir betreiben im internen LAN einen Exchange 2003 Server auf welchem ich bereits den Zugang zu OWA mittels HTTPS eingerichtet habe. Ein Benutzer kann intern, also im LAN direkt, sein Postfach sowohl über die URL: "https://IP-Exchangeserver/exchangessl" wie auch weiterhin über die standard URL "http://IP-Exchangeserver/exchange" öffnen. Daraufhin erscheint das bei OWA gewöhnliche Anmeldefenster wo man dann nach seinem Benutzername und Passwort gefragt wird.

An das Internet sind wir mittels SDSL und einer Netscreen 25 Hardwarefirewall angeschlossen. Mit Hilfe dieser Firewall wurde eine DMZ eingerichtet. In dieser DMZ befindet sich u.a. ein Suse Linux 10 Professional Server der derzeit bereits als Squid-Proxy-Server dient. Auf diesem Server habe ich nun auch eine bereits läuffähige XAMPP-Umgebung eingerichtet. Soweit sogut.
Die beiden Ports 80 und 443 wurden an der Hardwarefirewall vom Internet (also Untrust) in die DMZ auf den genannten Server forgewordet. Des weiteren darf der Linuxserver ebenfalls über die Ports 80 und 443 wiederrum mit dem internen Exchange Server kommunizieren. Der Linuxserver in der DMZ hat die IP "172.16.120.10" auf seiner NIC eth1 eingestellt. Auf der Netscreenfirewall ist wiederrum konfiguriert, dass wenn etwas für eine bestimmte öffentliche IP herein herein kommt dieser Traffic dann automatisch an den Linuxserver in der DMZ umgeleitet wird.

Nun habe ich, abweichend vom Standardinhalt, die folgenden Einstellungen in der Datei "/opt/lampp/etc/httpd.conf" vorgenommen bzw. hinzugefügt:

Code: Select all
 
Options -Indexes FollowSymLinks ExecCGI Includes
ServerTokens Prod

<VirtualHost 172.16.120.10:443>
DocumentRoot /opt/lampp/htdocs/owa
ServerName xxx.dyndns.org:443
ServerAdmin admin@xxx.dyndns.org

AddDefaultCharset UTF-8
RequestHeader unset accept-encoding
HostnameLookups Off
UseCanonicalName Off
ProxyPreserveHost On
SSLProxyEngine On
SSLProtocol All
SSLEngine On

ProxyPass /exchange https://xxx.dyndns.org/exchangessl/
ProxyPassReverse /exchange https://xxx.dyndns.org/exchangessl/

ProxyPass /exchweb http://xxx.dyndns.org/exchweb/
ProxyPassReverse /exchweb http://xxx.dyndns.org/exchweb/

ProxyPass /public http://xxx.dyndns.org/public/
ProxyPassReverse /public http://xxx.dyndns.org/public/

ProxyPass /oma http://xxx.dyndns.org/oma/
ProxyPassReverse /oma http://xxx.dyndns.org/oma/

ProxyPass /Microsoft-Server-ActiveSync http://xxx.dyndns.org/Microsoft-Server-ActiveSync
ProxyPassReverse /Microsoft-Server-ActiveSync http://xxx.dyndns.org/Microsoft-Server-ActiveSync/

ErrorLog logs/owa_ssl_error_log
TransLog logs/owa_ssl_access_log

SSLCertificateFile /opt/lampp/etc/ssl.crt/owa_server.crt
SSLCertificateKeyFile /opt/lampp/etc/ssl.key/owa_server.key

SetEnvIF User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown

</VirtualHost>


Die Schlüsseldatei "owa_server.key" habe ich mit Hilfe des folgenden Befehls angelegt:

Code: Select all
"openssl genrsa 1024 > /opt/lampp/etc/ssl.key/owa_server.key"


Aus dieser Schlüsseldatei habe ich dann wiederrum mit dem Befehl:

Code: Select all
"openssl req -new -x509 -key /opt/lampp/et/ssl.key/owa_server.key -out /opt/lampp/etc/ssl.crt/owa_server.crt -days 3651"


ein entsprechendes selbstsigniertes SSL Zertifikat erzeugt.

In die lokale Hosts-Datei des Linuxservers "/etc/hosts" habe ich das folgende eingetragen:

Code: Select all
IP-Exchange-Server (im internen LAN)   xxx.dyndns.org
LinuxserverIP                                       Linuxservername
127.0.0.1                                             localhost


Auf der Webseite "www.dyndns.org" habe ich dann selbst verständlich die richtige öffentliche IP-Adresse, über die der Linuxserver von ausserhalb erreichbar ist, für den DNS-Namen "xxx.dyndns.org" hinterlegt!

Soweit sogut. Nun habe ich testweise versucht mich mittels des "Konquerors" auf dem Linuxserver in der DMZ per OWA auf den internen Exchange Server zu verbinden. Dazu habe ich die URL "https://xxx.dyndns.org/exchange" verwendet. Dort sozusagen "lokal" auf dem Linuxserver in der DMZ hat der Zugriff auf OWA und somit auf den sich intern im LAN befindlichen Exchange Server wunderbar und problemlos funktioniert.

Nun habe ich mich jedoch wiederrum in einem 2. Schritt testweise mit einem Notebook ins Internet eingewählt und versucht dort, diesesmal also von extern, OWA zu öffnen. Dazu habe ich wiederrum die URL "https://xxx.dyndns.org/exchange" (dieses mal halt von extern) verwendet.
Daraufhin habe ich auch relativ schnell die Anmeldemaske zu Gesicht bekommen und mich schon gefreut, dass alles geklappt hat. Doch ich musste leider schon bald feststellen, dass ich mich zufrüh gefreut habe. Nachdem ich meinen Benutzernamen und mein Passwort eingegeben hatte bekam ich zwar den richtigen Frameaufbau von OWA zu Gesicht jedoch sah der Inhalt jedes Frames in etwa folgendermaßen aus:

Code: Select all
"... die Seite /exchangessl/Vorname.Name/Posteingang ist auf dem Server nicht verfügbar"

"Apache Server xxx.dyndns.org Port 443"


Das hat mich dann doch schon etwas verwundert zumal es lokal vom XAMPP-Server in der DMZ zuvor problemlos funktioniert hatte auf den internen Exchange 2003 Server zuzugreifen.

Hat hier jemand eine Idee woran dass jetzt noch liegen kann? Wie gesagt die Anmeldemaske von OWA erschien auch beim Zugriff von extern eben nur die eigentliche OWA Webseite wurde nicht richtig angezeigt.

Dabei kann es sich ja eigentlich nur noch um eine Kleinigkeit handeln die da noch nicht passt, oder!?

Muss an der Netscreen Firewall noch etwas umkonfiguriert werden?

Ich hoffe, dass mir dabei jemand weiterhelfen kann.

Gruß
Fluke[/code]
Das einzige Backup, das du wirklich brauchst ist das wofür du keine Zeit hattest
Fluke
 
Posts: 7
Joined: 09. February 2006 19:42
Location: Talheim

Postby deepsurfer » 10. February 2006 17:00

was steht denn in den

ErrorLog logs/owa_ssl_error_log
TransLog logs/owa_ssl_access_log
vielleicht geben die einen Hinweis auf den Vorgang.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Fluke » 13. February 2006 13:52

Hab den Fehler zwischenzeitlich selbst finden können. So muß die Konfig aussehen damit es funktioniert:

Code: Select all
Options -Indexes FollowSymLinks ExecCGI Includes
ServerTokens Prod

<VirtualHost 172.16.120.10:443>
DocumentRoot /opt/lampp/htdocs/owa
ServerName 172.16.120.10
ServerAdmin root@xxx.dyndns.org

AddDefaultCharset Off
RequestHeader unset accept-encoding
HostnameLookups Off
UseCanonicalName Off
ProxyPreserveHost On

ProxyPass /exchangessl https://IP-Exchangeserver/exchangessl/
ProxyPassReverse /exchangessl https://IP-Exchangeserver/exchangessl/

ProxyPass /exchweb https://IP-Exchangeserver/exchweb/
ProxyPassReverse /exchweb https://IP-Exchangeserver/exchweb/

ProxyPass /public https://IP-Exchangeserver/public/
ProxyPassReverse /public https://IP-Exchangeserver/public/

ProxyPass /oma https://IP-Exchangeserver/oma/
ProxyPassReverse /oma https://IP-Exchangeserver/oma/

ProxyPass /Microsoft-Server-ActiveSync https://IP-Exchangeserver/Microsoft-Server-ActiveSync/
ProxyPassReverse /Microsoft-Server-ActiveSync https://IP-Exchangeserver/Microsoft-Server-ActiveSync/

ErrorLog logs/owa_ssl_error_log
TransferLog logs/owa_ssl_access_log

SSLProtocol All
SSLEngine On
SSLProxyEngine On
SSLCertificateFile /opt/lampp/etc/ssl.crt/owa_server.crt
SSLCertificateKeyFile /opt/lampp/etc/ssl.key/owa_server.key

</VirtualHost>


Ein paar kleinere Probleme habe ich jedoch immer noch. Zum einen funktioniert der "Abmeldebutton" nicht richtig. Da wird auf einmal eine erneute Authentifizierung verlangt die dann aber fehlschlägt. Wie ich festgestellt habe sendet er diese Daten anscheinend über den Port 80 (also HTTP) anstatt über Port 443 (HTTPS).
Hat jemand eine Idee wie man das noch in den Griff bekommen kann?

Dann noch ein weiteres Problem. Wenn ich per OWA die öffentlichen Ordner anklicke öffnet sich auch wie üblich ein neues Browserfenster in welchem dann auch wie so üblich im linken Frame die öffentlichen Ordner in Form eines Treeviews dargestellt werden und zur Auswahl bereitstehen. Soweit sogut.
Versuche ich jedoch nun ein beliebiges Dokument, das in einem dieser öffentlichen Ordner abgelegt ist und auf welches ich auch Vollzugriff habe zu öffen, welches sich über mein "internes" Outlook mit meinem üblichen Benutzer problemlos öffnen lässt, wird plötzlich die Fehlerwebsite 403 mit dem Inhalt "Sie haben nicht die erforderliche Berechtigung, um die Seite anzuzeigen" geöffnet.
Ich habe das Ganze nun testweise auch mal intern, also vom LAN aus, per OWA versucht jedoch mit dem gleichen Ergebnis. Daher vermute ich, dass dies jetzt nicht speziell an der Konfiguration des Apache-Proxys liegt sondern eher eine Exchange Einstellung darstellt.
Hat da jemand bereits Erfahrung damit und kann mir sagen wie man das beheben kann?

Danke schon mal im voraus.

Gruß
Fluke
Das einzige Backup, das du wirklich brauchst ist das wofür du keine Zeit hattest
Fluke
 
Posts: 7
Joined: 09. February 2006 19:42
Location: Talheim


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests