Serverumzug

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Serverumzug

Postby hugen13 » 26. January 2006 10:53

Hallo,

konnte leider über die Suche nichts zu diesem Problem finden.

Ich habe einen neuen (schnelleren) Server aufgesetzt. Auf diesem läuft, wie auch auf dem alten, Debian 3.1 Sarge mit allen Updates. Nun habe ich mit rsync den Ordner lampp vom alten auf den neuen kopiert. Alle Dateien und Rechte sind identisch!

Wenn ich aber versuche, auf den SQL-Server über die Webseite -> phpMyAdmin zuzugreifen, kommt folgende Fehlermeldung:
"phpMyAdmin hat versucht eine Verbindung zum MySQL-Server aufzubauen, jedoch hat dieser die Verbindung zurückgewiesen..."
Auch der Aufruf der CD-Verwaltung endet mit einer Fehlermeldung:
"Kann die Datenbank nicht erreichen!
Läuft MySQL oder wurde das Passwort geändert?"

MySQL läuft, das Passwort wurde nicht geändert. Die Datei config.inc.php ist auf beiden Rechnern identisch.

Was habe ich vergessen?
hugen13
 
Posts: 2
Joined: 26. January 2006 10:31

Postby deepsurfer » 26. January 2006 12:37

hat der neue server den gleichen Hostnamen wie der "alte" ???

zusätzlich im neuen server die /etc/hosts anschauen ob da der eintrag 127.0.0.1 localhost vorhanden ist, wenn nicht dann hinzufügen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby hugen13 » 26. January 2006 14:27

Danke für die Antwort.

Nein, die Servernamen sind unterschiedlich, aber in den Konfigurationsdateien habe ich den Namen nirgends gefunden. Es ist immer nur 'localhost' drin.

In der Hosts-Datei ist 127 und localhost drin. Habe jetzt mal, um Schreibfehler auszuschließen, die Hostdatei vom alten Server kopiert und nur den Hostnamen geändert. Leider ohne Erfolg.

Apache und Ftp laufen problemlos. Nur bei Mysql komme ich nicht drauf.

Ergänzung: Ich habe die Lösung gefunden!
Habe auf der Konsole mit mysqladmin das Passwort zurückgesetzt und neu eingegeben. Jetzt gehts!
hugen13
 
Posts: 2
Joined: 26. January 2006 10:31

Postby deepsurfer » 26. January 2006 14:29

Ergänzung: Ich habe die Lösung gefunden!
Habe auf der Konsole mit mysqladmin das Passwort zurückgesetzt und neu eingegeben. Jetzt gehts!


hhmmmm...ok...das wäre weiter zu beochbachten und werds mir mal ein merkzelttel machen um das bei einem kommenden test mit zu checken.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests