Apache will nicht :(

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Apache will nicht :(

Postby kekz » 19. January 2006 22:18

Hallo,
ich habe vor, per vServer (SuSE 9.2) das xampp-System zu nutzen.
Xampp 1.5.1 habe ich problemlos installiert, und auch im Startskript sind keine Fehler zu erkennen.
Doch leider habe ich keinen Zugriff auf den apache-server per Browser :(
Auch im Virtuozzo wird kein httpd-Prozess verzeichnet.
MySQL und proftpd laufen problemlos.
Ich hatte auch mal testweise selber n lampp aufgesetzt, wo dann der apache ohne prob lief.
In der Error.log werden Fehler angezeigt (die hier im Forum anscheinend noch nicht gelöst worden sind):
Code: Select all
[Thu Jan 19 06:57:50 2006] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Jan 19 06:57:50 2006] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Thu Jan 19 06:57:51 2006] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Thu Jan 19 06:57:52 2006] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Jan 19 06:57:52 2006] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Thu Jan 19 06:57:52 2006] [notice] Digest: generating secret for digest authentication ...
[Thu Jan 19 06:57:52 2006] [notice] Digest: done
[Thu Jan 19 06:57:53 2006] [emerg] (13)Permission denied: couldn't grab the accept mutex
[Thu Jan 19 06:57:53 2006] [emerg] (13)Permission denied: couldn't grab the accept mutex
[Thu Jan 19 06:57:53 2006] [emerg] (13)Permission denied: couldn't grab the accept mutex
[Thu Jan 19 06:57:53 2006] [emerg] (13)Permission denied: couldn't grab the accept mutex
[Thu Jan 19 06:57:53 2006] [notice] Apache/2.2.0 (Unix) mod_ssl/2.2.0 OpenSSL/0.9.8a DAV/2 PHP/5.1.1 mod_apreq2-20050712/2.1.3-dev mod_perl/2.0.2 Perl/v5.8.7 configured -- resuming normal operations
[Thu Jan 19 06:57:53 2006] [alert] Child 8349 returned a Fatal error... Apache is exiting!
[Thu Jan 19 06:57:53 2006] [emerg] (22)Invalid argument: couldn't grab the accept mutex


Schon mal vielen Dank im Voraus,
kekz
kekz
 
Posts: 3
Joined: 19. January 2006 21:59

Postby Wiedmann » 19. January 2006 22:42

[Thu Jan 19 06:57:53 2006] [emerg] (13)Permission denied: couldn't grab the accept mutex

http://httpd.apache.org///docs/2.2/en/m ... cceptmutex
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby kekz » 19. January 2006 22:49

vielen Dank für die flotte Antowrt, doch leider kann ich damit jetzt net sonderlich viel anfangen :(
Gruß,
kekz
kekz
 
Posts: 3
Joined: 19. January 2006 21:59

Postby kekz » 20. January 2006 15:45

Ok, hat sich erledigt.
Hab in der httpd.conf einfach
Code: Select all
AcceptMutex flock

hinzugefügt.
Funzt jetzt einwandfrei :)
Gruß,
kekz
kekz
 
Posts: 3
Joined: 19. January 2006 21:59


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests