Sorry aber leider doch dooofffff

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Sorry aber leider doch dooofffff

Postby Rossi » 30. June 2003 13:51

Hey kann mir einer helfen?

Ich bekomme .htaccess nicht hin er ruft mir den login auf aber das passwort stimmt nicht.

Meine Dateien: .htaccess
Code: Select all
AuthType Basic
AuthName "Zugangsschutz"
AuthUserFile /.htpasswd (wo fängt der Path an)
require valid-user

.htpasswd
Code: Select all
test:INnA1BztLIaac

passwort ist test und Selfhtml gecrypt.

thx :?
Rossi
Rossi
 
Posts: 44
Joined: 03. March 2003 16:24
Location: Bensheim

Postby DJ DHG » 30. June 2003 15:28

Moin Moin

ich habe mal deine test user bei mir eingefügt

Code: Select all
test:INnA1BztLIaac


und der geht bei mir ohne probs!

AuthUserFile /.htpasswd (wo fängt der Path an)


hast du die .htpasswd im root ("/") liegen? oder ?

ich habe meine .htaccess und .htpasswd unter
Code: Select all
/opt/lampp/htdocs/dj-dhg.de/admin/.htpasswd


liegen und da geht alles auch dein test user...

mfg DJDHG
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

???

Postby Rossi » 30. June 2003 15:47

Erstmal Danke,

gut das es bei Dir geht und bei mir nicht.

Es ist alles gleich aber es geht trotzdem net :cry:

Hast Du vielleicht noch ne Idee denn ich bin am Ende meiner Lust.
Hab schon bei Apache Doco .htaccess nach gelesen ob was mit httpd.conf
net stimmt aber alles Super.

???

Gruß
Rossi
Rossi
 
Posts: 44
Joined: 03. March 2003 16:24
Location: Bensheim

ÄÄÄHHHH

Postby Rossi » 30. June 2003 15:50

Noch was was hast Du als Passwort eingegeben?

test oder INnA1BztLIaac

/opt/lampp/htdocs/chris/so/.htpasswd
Rossi
 
Posts: 44
Joined: 03. March 2003 16:24
Location: Bensheim

Postby DJ DHG » 30. June 2003 16:06

ich habe "test" eingeben!


erstell mal eine neue .htaccess mit folgendem inhalt

Code: Select all
AuthUserFile /opt/lampp/htdocs/test/.htpasswd
AuthType Basic
AuthName DJ-DHG_Admin_Bereich!
require valid-user


und eine .htpasswd mit dem inhlat von dir

test:INnA1BztLIaac


dann erstellste einen neuen ordner im htdocs verzeichniss, mit namen

test, und schmeist die beiden neuen datein mal rein.

testen! und dann wieder melden :mrgreen:
User avatar
DJ DHG
AF Moderator
 
Posts: 2455
Joined: 27. December 2002 13:50
Location: Kiel

Sorry aber hatte gestern kein Bock mehr

Postby Rossi » 01. July 2003 07:11

Joh,

...und was denkst Du :?:

es geht trotzdem nicht, ich testes heute Abend mal bei mir zu Hause. :?

Danke Dir

Rossi
Rossi
 
Posts: 44
Joined: 03. March 2003 16:24
Location: Bensheim

Postby Pc-dummy » 01. July 2003 17:27

Hi Rossi

Der Inhalt der dir DJDHG für die .htaccess angeben hat ist richtig!

Wenn du jetzt noch fehler hast, dann kann es z.b. an der falschen Pfadangabe liegen oder an dessen das du die .htpasswd nicht richtig erstellt hast.

Die richtige Befehlzeile um ein Passwd-file zu erstellen lautet so!
Code: Select all
/opt/lampp/bin/htpasswd -cbm <Pfad> <user> <passwd>


Das heist bei mir schaut die z.b. so aus:

/opt/lampp/bin/htpasswd -cbm /opt/lampp/etc/.users lampp hackme

noch ne möglichkeit währe das Password im Plaintext (nicht verschlüsselt) zu übergeben. (sehr unsicher!)

[code]
/opt/lampp/bin/htpasswd -cbp <Pfad> <user> <passwd>
[code]

MFG
Pc-Dumy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 5 guests