seltsames Phänomen?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

seltsames Phänomen?

Postby BlackbirdHakke » 23. December 2005 12:59

Moin..

hab XAMPP unter Ubuntu am laufen, eigentlich problemlos. Klick meine Verknüpfung auf dem Desktop, warte auf den screen, gebe das PW für root ein, xampp startet und ist verfügbar.

Im besten Fall. Im weniger guten Fall passiert folgendes: ich öffne unter XP im LAN eine der Seiten an denen ich gerade bastel, und es hagelt Fehlermeldungen seitens "Datenbank nicht erreichbar". Klasse. Sogar Testscripts eindeutig ohne script-Fehler verweigern den Dienst. ALso umgeschaltet auf den Linuxrechner, XAMPP beendet. Erneut gestartet - alles geht jetzt.

Ich konnte weder in den Logs oder sonstwie feststellen, warum der mySQL nicht mitstarten will, vor allem da das (vorerst) willkürlich passierte. Allerdings gebe ich bei einem solchen manuellen restart das root-PW etwas aufmerksamer ein, und somit langsamer-was soweit führte, dass ich testweise das korrekte(!) Passwort mal schnell tippte (ich kann das echt schnell ;) ), und mal langsam. Ergebnis: abhängig davon startete mySQL (und proFTP) mit (langsames PW) oder auch nicht mit (schnelles PW).

Kann das tatsächlich die Ursache sein? Liege ich da einem Trugschluss auf und es ist nur Zufall?

Um das genauer verfolgen zu können hab ich einen meiner früheren Fehler mit Absicht produziert, und den mySQL Dateien chmod 777 gegeben, was zu der Fehlermeldung "Warning: world-writable config file /opt/lampp/etc/my.cnf is ignored" führt. So sehe ich ja gleich, ob alles korrekt gestartet wird, oder nicht. Wirds nicht korrekt gestartet, und nur Apache läuft, kommt keine Meldung. Wird alles drei gestartet, kommt das warning dreimal.

Es laufen auf dem Ubuntu sonst keinerlei andere Apachen, mySQLs o.ä., auch keine weiteren Dienste die evtl Ports belegen würden etc. Es lässt sich augenscheinlich tatsächlich über die Geschwindigkeit von eingabe des PW und anschl. drücken der Returntaste steuern.. aber das kommt mir sehr unlogisch/unwahrscheinlich vor. Was könnte es sonst sein?

LG
~ich bin, denke ich~
Ishundia - das RPG
BlackbirdHakke
 
Posts: 89
Joined: 24. February 2004 08:51

Postby deepsurfer » 23. December 2005 13:26

Wie hast du die Verknüpfung aufgebaut bzw. was wird mit der der Verknüpfung ausgeführt ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby BlackbirdHakke » 23. December 2005 13:35

Tach,

den stinknormalen Startbefehl. /opt/lampp/lampp start. Dazu Ausführen als anderer Benutzer, Benutzername natürlich der rootname. Passwortabfrage kommt dann im Terminal, Terminal bleibt auch nach Beendigung geöffnet.

Ubuntu ist hoary, Linux ist 2.6.8, XAMPP ist 1.4.13, neuere hab ich bis dato nicht gebraucht, um meinem onlinesystem gleich zu bleiben mit den php-/mySQL Versionen.

LG
~ich bin, denke ich~
Ishundia - das RPG
BlackbirdHakke
 
Posts: 89
Joined: 24. February 2004 08:51

Postby BlackbirdHakke » 04. January 2006 09:24

Moin..

darf ich mal freundlich nachfragen? :wink:

LG
~ich bin, denke ich~
Ishundia - das RPG
BlackbirdHakke
 
Posts: 89
Joined: 24. February 2004 08:51

Postby KingCrunch » 04. January 2006 17:10

Ähm ... Ubuntu hat keinen Rootuser. Zumindest nicht serienmässig und es wird DRINGEND abgeraten ihn zu erstellen. Dafür gibts es nen eigenen Befehl
Code: Select all
sudo /opt/lampp/lampp start
[Nutzerpasswort]
Nicht jeder Fehler ist ein Bug ...
KingCrunch
 
Posts: 1724
Joined: 26. November 2005 19:25

Postby BlackbirdHakke » 04. January 2006 23:07

Schlaukopf. Der wird beim install erstellt, und mit su/sudo bedient. Steht irgendwo hier was anderes? Starte mal LAMPP ohne root ;)
Lediglich für X/WM gibts keinen rootlogin, da deaktivert (offiziell). Komplett ohne root geht nicht/gibts nicht.

Back to topic bitte.

LG
~ich bin, denke ich~
Ishundia - das RPG
BlackbirdHakke
 
Posts: 89
Joined: 24. February 2004 08:51


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests