xampp 1.5 - PHP 4 Problem

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

xampp 1.5 - PHP 4 Problem

Postby paulthoms » 13. December 2005 19:46

Ich benutze schon längere Zeit xampp auf einen internen Server (Suse) als Entwicklungsumgebung.
Bisher ohne jegliche Probleme.
Seit dem Umstieg auf die Version 1.5 habe ich ein Problem mit PHP 4, d.h. mit allem was mit mod_rewrite zu tun hat. Scripte die diese Funktionen beinhalten und auf der Vorgängerversion genau das taten, was sie sollten, versagen auf der Version 1.5 ihren Dienst (ohne Fehlermeldung !).

Schalte ich bei der Version 1.5 jedoch auf PHP 5 um tun diese Scripte ihren Dienst wieder wie eh und je ohne Fehler.

Da ich jedoch gerade die 4 er Version von PHP zum testen benötige (da diese neuerdings auch mein Provider verwendet) bin ich etwas ratlos -:)

Hat die verwendete 4er Version von PHP generell einen Bug?
paulthoms
 
Posts: 3
Joined: 13. December 2005 16:45

Postby Wiedmann » 13. December 2005 19:59

Hat die verwendete 4er Version von PHP generell einen Bug?

Welche 4er Version wird denn verwendet?

Ansonsten:
PHP4.4.1 hat einen Fehler im Zusammenhang mit Apache und mod_rewrite.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby paulthoms » 13. December 2005 20:18

Danke für die schnelle Antwort.

Ansonsten:
PHP4.4.1 hat einen Fehler im Zusammenhang mit Apache und mod_rewrite.


Ja die 4.4.1, welche im xampp Paket 1.5.0 vorhanden ist! Gibt es dafür schon eine Lösung? Da ich diese Version ja in absehbarer Zeit (Sicherheit) auf den Produktivserver verwenden möchte!
paulthoms
 
Posts: 3
Joined: 13. December 2005 16:45

Postby Wiedmann » 13. December 2005 20:21

Da ich diese Version ja in absehbarer Zeit (Sicherheit) auf den Produktivserver verwenden möchte!

Diese Version (4.4.1) will man auf einem Produktivserver nicht verwenden (tm)...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby paulthoms » 13. December 2005 20:34

Wass dann??
paulthoms
 
Posts: 3
Joined: 13. December 2005 16:45

Postby Wiedmann » 13. December 2005 22:19

Wass dann??

Kann man so einfach nicht sagen...
Je nach Software würde sich ja mittlerweile eine 5er-Version anbieten. Ansonsten bietet sich bei PHP4 4.4.0 (plus den Security-Patch) an oder man könnte sich auch an Zend halten und 4.3.11 installieren.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 7 guests