XAMPP und Perl - Problem mit LWP::UserAgent

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP und Perl - Problem mit LWP::UserAgent

Postby smuelle9 » 09. December 2005 14:20

Hallo, wer kann mir bei folgendem Problem weiterhelfen:

Ich habe mir vor kurzem XAMPP für Linux installiert und möchte mit einem Perl Script ein Request absetzen. Folgenden Quelltext benutze ich:

#####################################################
#!/opt/lampp/bin/perl

my $url = "http://@ARGV[0]:@ARGV[1]/@ARGV[2]/";

use CGI::Carp qw(fatalsToBrowser);
use strict;
use LWP::UserAgent;

my $ua = LWP::UserAgent->new();
my $request = HTTP::Request->new('GET', $url);
my $response = $ua->request($request);
print $response->content();
######################################################

Darauf erhalte ich folgende Fehlermeldung

Can't locate LWP/UserAgent.pm in @INC (@INC contains: /opt/lampp/lib/perl5/5.8.7/i686-linux /opt/lampp/lib/perl5/5.8.7 /opt/lampp/lib/perl5/site_perl/5.8.7/i686-linux /opt/lampp/lib/perl5/site_perl/5.8.7 /opt/lampp/lib/perl5/site_perl .) at -e line 1.
BEGIN failed--compilation aborted at -e line 1.

Wenn ich nun nach UserAgent.pm suche, (find /opt/ -name UserAgent.pm) kommt kein Treffer. Muß ich davon ausgehen, dass LWP in der bereitgestellten XAMPP Version 1.5.0 nicht vorhanden ist, oder mach ich etwas anderes falsch?

Danke, Steffen.
smuelle9
 
Posts: 3
Joined: 09. December 2005 14:04

Postby Wiedmann » 13. December 2005 11:53

Muß ich davon ausgehen, dass LWP in der bereitgestellten XAMPP Version 1.5.0 nicht vorhanden ist,

Ja, musst du.

(Ist ja aber bei Perl-Modulen nicht wirklich ein Problem --> CPAN)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

CPAN

Postby smuelle9 » 14. December 2005 10:01

Danke Wiedmann für die Antwort. Die Möglichkeit mit CPAN das fehlende Modul nach zu installieren hatte ich auch schon mit CPAN install LWP::UserAGent

Wenn ich nun aber mein perl Script laufen lasse folgt nachfolgende Fehlermeldung:

/opt/lampp/bin/perl: symbol lookup error: /opt/lib/perl/5.8.7/auto/Compress/Zlib/Zlib.so: undefined symbol: Perl_Gthr_key_ptr

Das Verzeichnis lib/ wurde erst durch CPAN angelegt.

Wo ist nun der Fehler bzw. wer hat hier welchen Fehler gemacht? Ich weiß an der Stelle leider nicht weiter.

Steffen
smuelle9
 
Posts: 3
Joined: 09. December 2005 14:04


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests