Auto-Start von XAMPP seit SUSE 10 nicht mehr möglich?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Auto-Start von XAMPP seit SUSE 10 nicht mehr möglich?

Postby uwe.schelling » 11. October 2005 14:00

Hallo,

folgende Situation:
Ich nutze XAMPP für Linux in der aktuellsten Version (schon ca. 1 Jahr lang als Webserver). Habe immer wieder aktualisiert
Der XAMPP läuft auf einem SUSE Prof. System.
Angefangen mit der 9.1, dann 9.2 und 9.3, nun hab ich heute ein Update auf das neue Release 10.0 gefahren.

Der Server läuft im Runlevel 3 (Also auf Konsole), und ich hab im /etc/init.d/rc3.d entprechend die Start und Stop Scripts eingebunden, sowie in der FAQ von XAMPP beschrieben (siehe folgenden Link)
http://www.apachefriends.org/de/faq-xam ... x.html#fsl

Seit dem Update auf die SUSE 10 ist es jedoch so, dass der XAMPP über die Befehle nicht mehr automatisch startet.
Ich hab die Befehle schon einmal gelöscht und entsprechend neu angelegt. Aber keine Reaktion.
Ein manueller Start ist ohne Probleme möglich, aber sehr unglücklich.

Was kann ich tun? Ist das Problem bei jemandem auch schon aufgetreten?
Muss man nun seit SUSE 10 irgendwie anders vorgehen?

Bin dankbar für jede Hilfe!

Gruß
Uwe
uwe.schelling
 
Posts: 4
Joined: 11. October 2005 11:29

Postby deepsurfer » 11. October 2005 14:10

Im SuSE 10 ist im YAST ein Grosser RUNLEVEL Editor zu finden.

Da SuSE derzeit viel an Bequemlichkeit von Windows nachbaut sind die reinen Unix-Strukturen etwas sehr umgebogen.

Wie bekannt kannst du YAST auch auf reinem Konsolenzugang aufrufen.
Einfach yast eingeben dann auf "System" und schon erscheint rechts der Runlevel editor.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Problem noch immer nicht gelöst.

Postby uwe.schelling » 11. October 2005 14:30

Sicher gibts dort den RUNLEVEL Editor.

Wenn du mir erzählst, wie ich dort einen neuen Systemdienst eintragen kann, dann ist mir sicher geholfen.

Aber ich kann dort nur
- zwischen einfach und expertenmodus wechseln
- den Standard-Runlevel festlegen
- Dienste einsehen
- für die bestehenden Dienste Runlevel in den sie laufen sollen festlegen
- Dienste Starten und Beenden
- Dienste aktivieren oder deaktivieren

Aber ich kann dort keine NEUEN Dienste (z. B. für den XAMPP) einrichten.
Oder hab ich Tomaten auf den Augen...

Von daher bin ich bisher den manuellen Weg gegangen.

Für Hilfe bin ich dankbar.

Gruß
Uwe
uwe.schelling
 
Posts: 4
Joined: 11. October 2005 11:29

Postby leo29041982 » 11. October 2005 18:26

Also bei mir hat folgendes geholfen:

Habe im Bootlog bemerkt das beim Hochfahren immer ein "lampp"-Skript in dem init-Ordner /etc/init.d/ gesucht wird.

Einfach von /opt/lampp/lampp nach /etc/init.d/ kopieren. Dann startete auch LAMPP richtig bei mir.
leo29041982
 
Posts: 2
Joined: 11. October 2005 18:16

Postby deepsurfer » 12. October 2005 13:59

Einfach von /opt/lampp/lampp nach /etc/init.d/ kopieren. Dann startete auch LAMPP richtig bei mir.


Nicht die feine englishe, wenns aber geht ...ok...

ansonsten sollten nur die start/stop scripte in
/et/init.d/rc.x eingetragen werden.

Die rc.x bedeutet gleich dem RunLevel.

Wurde aber auch in dem Thread über die Autostartfunktion beschrieben.

Werde heute und/oder Morgen den XAMPP-Devs einen Zugang zu meinem SuSE10 Testsystem einrichten, sodass die diesen Autostart-Driss nachtesten können..
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby uwe.schelling » 13. October 2005 07:44

ansonsten sollten nur die start/stop scripte in
/et/init.d/rc.x eingetragen werden.


Naja, wie gesagt, so hab ichs bisher gehabt. Nur seit dem Update auf SUSE 10 gehts einfach nicht mehr

Werde heute und/oder Morgen den XAMPP-Devs einen Zugang zu meinem SuSE10 Testsystem einrichten, sodass die diesen Autostart-Driss nachtesten können..


Das wäre prima :wink:

Gruß
Uwe[/quote]
uwe.schelling
 
Posts: 4
Joined: 11. October 2005 11:29

Postby leo29041982 » 15. October 2005 09:50

folgendes sollte gehen:

Code: Select all
#! /bin/sh
#
### BEGIN INIT INFO
# Provides:          LAMPP
# Required-Start:    $syslog $remote_fs $network
# Should-Start: $time ypbind sendmail
# Required-Stop:     $syslog $remote_fs $network
# Should-Stop: $time ypbind sendmail
# Default-Start:     2 3 5
# Default-Stop:      0 1 6
# Short-Description: Startet LAMPP
# Description:       Startet LAMPP-Paket
### END INIT INFO
# Check for missing binaries (stale symlinks should not happen)
# Note: Special treatment of stop for LSB conformance
FOO_BIN=/opt/lampp/lampp
test -x $FOO_BIN || { echo "$FOO_BIN not installed";
        if [ "$1" = "stop" ]; then exit 0;
        else exit 5; fi; }

. /etc/rc.status

# Reset status of this service
rc_reset

# Return values acc. to LSB for all commands but status:
# 0       - success
# 1       - generic or unspecified error
# 2       - invalid or excess argument(s)
# 3       - unimplemented feature (e.g. "reload")
# 4       - user had insufficient privileges
# 5       - program is not installed
# 6       - program is not configured
# 7       - program is not running
# 8--199  - reserved (8--99 LSB, 100--149 distrib, 150--199 appl)
#
# Note that starting an already running service, stopping
# or restarting a not-running service as well as the restart
# with force-reload (in case signaling is not supported) are
# considered a success.

case "$1" in
    start)
        echo -n "Starte LAMPP-Paket "
        ## Start daemon with startproc(8). If this fails
        ## the return value is set appropriately by startproc.
        $FOO_BIN start

        # Remember status and be verbose
        rc_status -v
        ;;
    stop)
        echo -n "Beende LAMPP-Paket "
        ## Stop daemon with killproc(8) and if this fails
        ## killproc sets the return value according to LSB.

        $FOO_BIN stop

        # Remember status and be verbose
        rc_status -v
        ;;
    try-restart|condrestart)
        ## Do a restart only if the service was active before.
        ## Note: try-restart is now part of LSB (as of 1.9).
        ## RH has a similar command named condrestart.
        if test "$1" = "condrestart"; then
                echo "${attn} Use try-restart ${done}(LSB)${attn} rather than condrestart ${warn}(RH)${norm}"
        fi
        $0 status
        if test $? = 0; then
                $0 restart
        else
                rc_reset        # Not running is not a failure.
        fi
        # Remember status and be quiet
        rc_status
        ;;
    restart)
        ## Stop the service and regardless of whether it was
        ## running or not, start it again.
        $0 stop
        $0 start

        # Remember status and be quiet
        rc_status
        ;;
    force-reload)
        ## Signal the daemon to reload its config. Most daemons
        ## do this on signal 1 (SIGHUP).
        ## If it does not support it, restart the service if it
        ## is running.

        echo -n "Reload service FOO "
        ## if it supports it:
        /sbin/killproc -HUP $FOO_BIN
        #touch /var/run/FOO.pid
        rc_status -v

        ## Otherwise:
        #$0 try-restart
        #rc_status
        ;;
    reload)
        ## Like force-reload, but if daemon does not support
        ## signaling, do nothing (!)

        # If it supports signaling:
        echo -n "Reload service FOO "
        /sbin/killproc -HUP $FOO_BIN
        #touch /var/run/FOO.pid
        rc_status -v

        ## Otherwise if it does not support reload:
        #rc_failed 3
        #rc_status -v
        ;;
    status)
        echo -n "Checking for service FOO "
        ## Check status with checkproc(8), if process is running
        ## checkproc will return with exit status 0.

        # Return value is slightly different for the status command:
        # 0 - service up and running
        # 1 - service dead, but /var/run/  pid  file exists
        # 2 - service dead, but /var/lock/ lock file exists
        # 3 - service not running (unused)
        # 4 - service status unknown :-(
        # 5--199 reserved (5--99 LSB, 100--149 distro, 150--199 appl.)

        # NOTE: checkproc returns LSB compliant status values.
        /sbin/checkproc $FOO_BIN
        # NOTE: rc_status knows that we called this init script with
        # "status" option and adapts its messages accordingly.
        rc_status -v
        ;;
    probe)
        ## Optional: Probe for the necessity of a reload, print out the
        ## argument to this init script which is required for a reload.
        ## Note: probe is not (yet) part of LSB (as of 1.9)

        test /etc/FOO/FOO.conf -nt /var/run/FOO.pid && echo reload
        ;;
    *)
        echo "Usage: $0 {start|stop|status|try-restart|restart|force-reload|reload|probe}"
        exit 1
        ;;
esac
rc_exit


in einer "/etc/init.d/lampp" Datei machen und mit "insserv" in rcd-Ordner einbinden.
leo29041982
 
Posts: 2
Joined: 11. October 2005 18:16

Postby jpg » 16. October 2005 14:49

wenn ihr wüsstet wie lange ich da rumgebastelt habe!

habe das auch schon seit suse linux 9.1 im gebrauch!
könnt ihr das nicht auch auf die haupt seite schreiben?

Aber es tut jetzt - THX! :-D

lg JPG
jpg
 
Posts: 2
Joined: 02. October 2004 21:18


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests