sendmail und proftp...

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

sendmail und proftp...

Postby shaftie » 16. June 2003 14:39

hallo apachefriends...
ich habe im Moment ein Problem mit sendmail und proftp... der beim lampp mitgelieferte proftp- server verteilt die rechte nur auf htdocs- ebene... wie kann ich das auf die public_htmls der user UND auf die htdocs (je nach rechten) ändern?

Und meine Frage zu sendmail:

Wie muss ich in der php.ini sendmail eintragen? Muss ich sendmail extra starten? ...

Grüße

shaftie
shaftie
 
Posts: 51
Joined: 12. June 2003 07:02
Location: Göttingen

Postby Pc-dummy » 16. June 2003 17:16

Hi shaftie

In bezug auf Sendmail kann ich dir leider nicht helfen :(

Wegen Proftpd:

du willst dass jeder user in seinem public_html verzeichnis gleichzeitig sein ftp verzeichnis hatt?

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby pfiffikus » 16. June 2003 18:03

Zu ProFTP:

Ergänze diese Zeilen:
<Directory ~/*>
AllowOverwrite on
</Directory>

Kommentiere diese Zeile aus:
#DefaultRoot /opt/lampp/htdocs

Schreibe diese Zeile:
DefaultRoot ~

Lampp neu starten und du wirst hüpfen vor Freude!
pfiffikus
 
Posts: 47
Joined: 01. June 2003 16:33
Location: Gera/Thüringen
Operating System: Windows 8

Postby shaftie » 16. June 2003 18:16

danke =)

und was ist mit sendmail?
shaftie
 
Posts: 51
Joined: 12. June 2003 07:02
Location: Göttingen

Postby pfiffikus » 16. June 2003 20:26

Da ich davon (noch) keine Ahnung habe und auch nicht so tun möchte, als ob ich Ahnung hätte, hab ich dazu nix geschrieben.

Aber es gibt sicher Leute, die sich damit auskennen.
pfiffikus
 
Posts: 47
Joined: 01. June 2003 16:33
Location: Gera/Thüringen
Operating System: Windows 8

Postby shaftie » 16. June 2003 20:38

also das mit m ftp funzt soweit (thx! :) )... aber kann man nu trotzdem auf verzeichnisse zugreifen, die außerhalb der public_html liegen? Wenn net, nicht schlimm :P

ich muss nur erstmal mein sendmain zum laufen bringen..
shaftie
 
Posts: 51
Joined: 12. June 2003 07:02
Location: Göttingen

Postby pfiffikus » 16. June 2003 21:50

shaftie wrote:also das mit m ftp funzt soweit (thx! :) )... aber kann man nu trotzdem auf verzeichnisse zugreifen, die außerhalb der public_html liegen?


Probier doch mal:
DefaultRoot ~/public_html

(Ich habe es noch nicht probiert :x
pfiffikus
 
Posts: 47
Joined: 01. June 2003 16:33
Location: Gera/Thüringen
Operating System: Windows 8

Postby shaft|schule » 17. June 2003 08:40

also ichg meinte, dass man in die public_html UND in die htdocd zugreifen kann...

cu


shaftie
shaft|schule
 

Postby pfiffikus » 17. June 2003 14:45

Also dieses Verzeichnis lasse ich immer unverändert. Bei mir liegen und bleiben darin die originalen LAMPP-Seiten. Deshalb brauche ich dahin keinen ftp-Zugang und habe noch nie danach gesucht.

Aber möglicherweise hat sich schon jemand näher mit ProFTP befasst.
pfiffikus
 
Posts: 47
Joined: 01. June 2003 16:33
Location: Gera/Thüringen
Operating System: Windows 8

Postby shaftie » 17. June 2003 15:37

naja, ich kann die dateien, die darin liegen schlecht verschieben... vielleicht gibts wirklich noch leute, die sich näher damit auskennen -> plz post :)

und dann noch das sendmail- prob...

cu

shaftie
shaftie
 
Posts: 51
Joined: 12. June 2003 07:02
Location: Göttingen

Postby Oswald » 17. June 2003 15:44

Huhu shaftie!

Schmeiss einfach die Zeile mit dem DefaultRoot raus. Dann kann jeder Deiner Benutzer von ProFTPD aus auf alle Verzeichnisse zugreifen. Danach "wirken" dann natürlich noch die Unix-Zugriffsrechte.

Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby shaftie » 17. June 2003 15:59

also proFTp regt mich langsam auf ;)

im Moment will er garnix... nimmer connecten... nix

und sendmail sendet keine Email, und gibt keine Fehler aus... *wunder*

wäre nett ,wenn jemand ne idee hätte...

cyas

shaftie
shaftie
 
Posts: 51
Joined: 12. June 2003 07:02
Location: Göttingen

Postby Pc-dummy » 17. June 2003 17:17

Saftie:

ps -aux :spuckt den profptd aus?
netstat -an | grep 21 :spuckt auch was aus?

Und was steht in der /opt/lampp/var/profptd/start.err?

MFG
Pc-Dummy
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby shaftie » 17. June 2003 18:22

es scheint wieder zu gehen....
zu sendmail ;) : muss man sendmail in der php.ini eintragen? muss man es extra starten/konfigurieren?

cu

Roman
shaftie
 
Posts: 51
Joined: 12. June 2003 07:02
Location: Göttingen

Postby Oswald » 18. June 2003 00:50

Huhu shaftie!

Nein! Für sendmail musst Du nichts extra in der php.ini eintragen. Starten musst Du sendmail eigentlich auch nicht (Okay, es kann unter bestimmten Umständen notwendig sein, aber das lassen wir jetzt erst mal beiseite).

Probier mal folgendes aus:

echo huhu | mail osw@ld.pages.de

Die E-Mail-Adresse durch Deine E-Mail-Adresse ersetzten. Wenn Du nun eine E-Mail mit Inhalt "huhu" bekommst, dann funktioniert Dein sendmail. Wenn nicht, dann musst Du ihn noch konfigurieren. Welches Linux benutzt Du?

Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Next

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests