Apache 2x starten

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Apache 2x starten

Postby Toralf_ » 15. June 2003 18:31

So, kurze einleitung:

Ich habe nen server und dort läuft bereits ein apache, mysql usw.
allerdings möchte ich das ganze mal updaten und brauche deshalb den 2. apache server(den von lampp). Nur leider möchte er nicht starten da bereits ein apache daemon läuft. Da ich allerdings den normalen apache nicht beenden möchte kann ich auch den lampp server nicht testen. Hat jemand dumme ideen wie ich den lampp apache zum laufen bewegen könnte ?

MFG Toralf
Toralf_
 

Postby AlexPausB » 15. June 2003 18:36

Hey! Ne dumme Idee nicht, aber ne dumme Antwort ;-)

Ich glaube dat wird nicht gehen, was du da vorhast! Verstehe auch ehrlich gesagt nicht den Sinn dahinter :?
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf

Postby Toralf_ » 15. June 2003 18:45

ich will den neuen apache 2.x bereits konfigurieren und testen bevor ich ihn einsetzen um eine lange downtime zu vermeiden. Darum möchte ich den neuen apache testen bevor er zum einsatz kommt so das wenn ich dann fertig bin, den alten apache in den ruhestand schicken kann und 2.0 starten kann und das mit 1-2sec pause.

Ich glaube es ist nur lampp das verhindert das apache 2.0 gestartet wird. Vom apache her müsste es ja gehen.
Toralf_
 

Postby AlexPausB » 15. June 2003 19:15

Okay das leuchtet mir schon ein! Nur wäre es nicht empfehlenswert eine Entwicklungs- bzw. Testumgebung vor dem realen Server fern zu halten?

Mal angenommen es laufen beide Indianer gleichzeitig, woher soll dann der Server wissen, wann er welchen dem User anbieten soll?

Also ich bin davon überzeugt, dass das keinen Sinn macht und es auch nicht funktioniert! Wie aber heisst es so schön: Ich lasse mich gerne eines besseren belehren ;-)
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf

Postby Guest » 15. June 2003 19:27

indem ich dem einem port 80 lasse und dem anderen port 81 oder so schenke ? :)
Guest
 

Postby Kristian Marcroft » 16. June 2003 09:39

Anonymous wrote:indem ich dem einem port 80 lasse und dem anderen port 81 oder so schenke ? :)


Hi,

sehr gute Lösung :)
httpd.conf öffnen:

Nach "80" suchen
und Port in 81 ändern :)
Fertig...
So laufen beide Paralell und es funzt...
Viel Spass beim testen

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Toralf_ » 16. June 2003 13:49

das ändert aber nix an der sache das lampp sich weigert den apache zu starten. Er scheckt wohl nach nem daemon namen und da is ja bereits ein apache vorhanden.

Es liegt rein am startverhalten von lampp und nicht an den confs. Die könnten sonstwie falsch sein aber die checkt er nich mal sondern sagt einfach das ein apache daemon bereits läuft.
Toralf_
 

Postby Oswald » 16. June 2003 14:26

Huhu Toralf!

Änder einfach das lampp-Startskript! Datei /opt/lampp/lampp, Zeile 135:

if testport 80

Aus der 80 machst Du eine 81. Das war's schon. ;)

Lieben Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby Toralf_ » 16. June 2003 15:49

Boah dafür hast du dir nen megaknuddel verdient :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen:
Toralf_
 

Postby AlexPausB » 16. June 2003 18:39

Und isch hab wieder wat gelernt... sorry Toralf :?
AlexPausB
 
Posts: 471
Joined: 05. February 2003 11:19
Location: Fdorf


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests