Php Extensions unter Xampp?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Php Extensions unter Xampp?

Postby shevegen » 04. October 2005 20:05

Hi, ich wollte mal ffmpeg + php testen, ffmpeg läuft bei mir schon seit Monaten tadellos.

http://ffmpeg-php.sourceforge.net/

Bei der Installationsangabe wird gesagt,
"Unpack the archive and copy the ffmpeg extension directory into your the php
sources extensions directory"

Wo ist das php extensions directory?

PS: Ich habe das devel Paket von Xampp.

Danke für Hilfe!
User avatar
shevegen
 
Posts: 107
Joined: 08. June 2004 04:52

Postby Wiedmann » 04. October 2005 20:09

into your the php sources extensions directory"

Du musst dir den PHP-Quellcode herunterladen. Da ist dann dieses Verzeichnis drin.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby shevegen » 05. October 2005 12:26

okay, danke
User avatar
shevegen
 
Posts: 107
Joined: 08. June 2004 04:52

Postby manga » 18. October 2006 08:13

hi will auch ffmpeg-php installieren, ffmpeg hab ich schon über apt-get geholt jetzt fehlt noch in lampp die ffmpeg-php !

Kann mir bitte einer eine Schritt-für-Schritt Anleitung machen ?

Debian OS
manga
 
Posts: 2
Joined: 16. October 2006 14:34

Postby canonball » 09. January 2007 19:57

also die instructions auf der seite sehen so aus :
Building into the PHP binary
Unpack the archive and copy the ffmpeg-php extension directory into your the PHP sources extensions directory.

1. tar -xjf ffmpeg-php-X.x.x.tar.gz
2. cp ffmpeg-php /path/to/php_sources/ext

Run autoconf in your php source directory to update the configure script.

1. cd /path/to/php_sources
2. autoconf

Configure PHP with the ffmpeg option.

1. ./configure [other options...] --with-ffmpeg=yes

Now build and install PHP. If everything went as planned, ffmpeg-php is now built into the PHP binary and no further configuration is required.
Building as an Extension
Build and install PHP if it is not already installed
Unpack the archive

1. tar -xjf ffmpeg-php.X.x.x.tar.gz

Change to the ffmpeg-php extension directory and run phpize (included with your PHP installation) to build configuration files.

1. cd ffmpeg-php
2. phpize

Configure and build the extension.

1. ./configure && make

Install the shared extension.

1. make install (as root)


so ich habe den ffmpeg-php ordner im /opt/lampp/lib/php/extensions
und wenn ich denn wieder in /opt/lampp/lib/php gehe und autoconf ausführe kommt bei mir nur


autoconf: no input file


was mach ichfalsch ?

p.s benutze debian sarge 3.1
canonball
 
Posts: 33
Joined: 17. June 2006 10:00

Postby deepsurfer » 10. January 2007 00:19

Hast du auch das Developer Paket von XAMPP bei dir Installiert ??
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby canonball » 10. January 2007 18:14

ach das brauch ich dann erst
canonball
 
Posts: 33
Joined: 17. June 2006 10:00

Postby canonball » 10. January 2007 21:13

also ich brauch erstmal das developer tool um die extension ffmpeg-php hinzuzufügen ?

wenn ja wo bekomm ich das developer tool her ?
canonball
 
Posts: 33
Joined: 17. June 2006 10:00

Postby Wiedmann » 10. January 2007 22:02

wenn ja wo bekomm ich das developer tool her ?

Von da wo es auch den XAMPP gibt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby canonball » 11. February 2007 14:26

so ok habe jetzt das developer tool installiert mit
Code: Select all
tar xvfz xampp-linux-devel-1.5.5a.tar.gz -C /opt


und standradmässig liegt der php ordner doch in /opt/lampp/lib/php wo ich dann auch autoconf und ./configure ausführen muss oder nicht ?

und dass funktioniert trotz developer tool nicht.

ich weis langsam nichtmehr weiter ^^
canonball
 
Posts: 33
Joined: 17. June 2006 10:00

Postby Wiedmann » 11. February 2007 16:56

wo ich dann ./configure ausführen muss oder nicht ?

Nein. Du musst dieses ./configure im Ordner ausführen, wo du die ffmpeg-Extension entpackt hast.

BTW:
In deinen Instructions oben musst du dich an den Part "Building as an Extension" halten.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby canonball » 12. February 2007 18:18

ich kann weder phpize noch autoconf noch ./configure in dem extensions ordner ausführen.

also normalerweise müsste das funktionieren mit phpize und folgende ?
canonball
 
Posts: 33
Joined: 17. June 2006 10:00

Postby Wiedmann » 12. February 2007 18:52

ich kann weder phpize

Das sollte in "/opt/lampp/bin" liegen?
Wenn dieser Pfad nicht in PATH aufgeführt ist, musst du beim Aufruf natürlich den Pfad mit angeben.

noch autoconf

Welches "autoconf"? Im Abschnitt "Building as an Extension" taucht das nirgends auf:
Wiedmann wrote:In deinen Instructions oben musst du dich an den Part "Building as an Extension" halten.


noch ./configure

Diese Datei wird durch "phpize" erstellt.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby canonball » 12. February 2007 21:52

danke wiedmann für deine hilfe, und das du einem immer wieder hilfst auch wenn es noch so verzweifelnd ist :D .

also hab es jetzt hinbekommen die extension einzupflegen, ABER ich muss nochmal ffmpeg an sich installieren

da folgendender error kam :
Code: Select all
ffmpeg headers not found. Make sure you've built ffmpeg as shared libs using the --enable-shared option


aber das bekomm ich alleine hin :D
canonball
 
Posts: 33
Joined: 17. June 2006 10:00

Postby Hendricius » 17. May 2007 02:48

Habe alles probiert und auch so beschrieben wie in der Anleitung.

1. ffmpeg-php in dem php-Extensions Ordner installiert
(Sieht so aus: /opt/lampp/lib/php/extensions/no-debug-non-zts-20060613/ffmpeg-php/)

2. php.ini geändert,
extension="ffmpeg-php/modules/ffmpeg.so"
hinzugefügt.

3.
/opt/lampp/lampp phpstatus
ausgeführt, dann kommt immer dieser Error:

PHP Startup: Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20060613/ffmpeg-php/modules/ffmpeg.so' - /opt/lampp/lib/php/extensions/no-debug-non-zts-20060613/ffmpeg-php/modules/ffmpeg.so: wrong ELF class: ELFCLASS64 in Unknown on line 0
5.2.1


habe Xorg Libs installiert, dennoch kommt der gleiche Error.

Danke für die Hilfe![/quote]
Hendricius
 
Posts: 15
Joined: 04. April 2007 13:50

Next

Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests