Lamp 1.0 funktioniert gar nicht ?!?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

Lamp 1.0 funktioniert gar nicht ?!?

Postby lampneuling » 14. June 2003 12:08

Hallo Apachefriends,

Ich habe mir Lamp 1.0 auf meine Debian Kiste gezogen.

Mit

tar xzvf lamp1.0.tar.gz -C /opt

als root entpackt.

Dann gehe ich hin und öffne Konqueror als normaler User (ich bin in KDE als normaler User eingeloggt, das entpacken oben habe ich in der Konsole nach einem su - gemacht.) und gebe

http://localhost ein.

Da bekomme ich die Fehlermeldung,

Forbidden,
You don't have permission to access / on this server.

Außerdem läuft MySQL nicht (ich sehe das, wenn ich ps ax mache)!

Ich habe hier mal geforscht, auf Grund dessen mal die Rechte und Owner der Verzeichnisse geprüft.

Hier das Listing:
#ls -al /opt/lampp
total 108
drwxr-xr-x 16 root root 4096 Jun 2 09:20 .
drwxr--r-- 3 root root 4096 Jun 14 14:53 ..
-rw-r--r-- 1 root root 17984 May 22 2002 COPYING
-rw-rw-r-- 1 root root 11721 Jun 1 20:08 RELEASENOTES
drwxr-xr-x 2 root root 4096 Jun 1 22:58 bin
drwxr-xr-x 2 root root 4096 May 31 01:38 cgi-bin
drwxr-xr-x 3 root root 4096 May 31 01:38 error
drwxr-xr-x 6 root root 4096 May 31 04:12 etc
drwxr-xr-x 5 nobody root 4096 Mar 26 22:06 htdocs
drwxr-xr-x 3 root root 4096 May 31 01:38 icons
-rwxr-xr-x 1 root root 10563 Jun 2 09:20 lampp
drwxr-xr-x 8 root root 4096 Jun 1 22:58 lib
drwxr-xr-x 24 root root 4096 Apr 8 23:32 licenses
drwxr-xr-x 2 root root 4096 Jun 14 14:57 logs
drwxr-xr-x 2 root root 4096 Jun 1 22:58 modules
drwxr-sr-x 9 root root 4096 May 11 12:10 phpmyadmin
drwxr-xr-x 2 root root 4096 Jun 1 22:58 sbin
drwxr-xr-x 10 root root 4096 Feb 10 22:56 share
drwxr-xr-x 4 root root 4096 Jun 14 14:57 var

Dann noch hier die Datei /opt/lampp/var/mysql/debian.err (wegen dem,das MySQl nicht läuft):
030614 14:54:51 mysqld started
030614 14:54:51 Can't start server : Bind on unix socket: Permission denied
030614 14:54:51 Do you already have another mysqld server running on socket: /opt/lampp/var/mysql/mysql.sock ?
030614 14:54:51 Aborting

030614 14:54:51 /opt/lampp/sbin/mysqld: Shutdown Complete

030614 14:54:51 mysqld ended

030614 14:57:01 mysqld started
030614 14:57:01 Can't start server : Bind on unix socket: Permission denied
030614 14:57:01 Do you already have another mysqld server running on socket: /opt/lampp/var/mysql/mysql.sock ?
030614 14:57:01 Aborting

030614 14:57:01 /opt/lampp/sbin/mysqld: Shutdown Complete

030614 14:57:01 mysqld ended


Ich hoffe ihr könnt mir helfen

Vielen Dank im Voraus
lampneuling
 
Posts: 3
Joined: 14. June 2003 11:52

Postby shaftie » 14. June 2003 12:25

also: verständnisproblem? Du hast das Biest schon gestartet?

-> /opt/lampp/lampp start

wenns daran liegt ist es der einfachste fall... ansonsten habe ich keine ahnung :P
shaftie
 
Posts: 51
Joined: 12. June 2003 07:02
Location: Göttingen

Schon gestartet

Postby Guest » 14. June 2003 14:30

Hallo schaftie,

Ja ich habe lampp gestartet, genau wie du es auch geschrieben hattest und zwar als root.

Dann gehe ich in meinen Browser und es funzt nix >-(
Guest
 

Noch was

Postby Guest » 14. June 2003 14:33

Ich habe mich auch mal als root in KDE eingeloggt, damit Konqueror als root startet. Auch dann gibt er mir die Fehlermeldung aus!!

Und ich dachte, dass das ein Paket zum auspacken und benutzen ist und nicht schon wieder zum Durchlesen von zwanzig Mailinglisten,Büchern, Bibliotheken, dem lernen von fünf Scriptsprachen und dem rauspfeffern des Computers aus dem Fenster :evil:

Ich hoffe trotzdem, jemand kann mir helfen :cry:
Guest
 

Postby pfiffikus » 15. June 2003 00:13

Kann es sein, dass auf deiner Maschine schon ein MySQL läuft, wenn Du versuchst, LAMPP zu starten?

Forbidden,
You don't have permission to access / on this server.


Kam diese Meldung auch, bevor du LAMPP gestartet hettest?
pfiffikus
 
Posts: 47
Joined: 01. June 2003 16:33
Location: Gera/Thüringen
Operating System: Windows 8

Postby lampneuling » 15. June 2003 07:27

Hallo Pfiffikus,

Nein, ich habe bei der Installation meiner Linux Distri peinlich genau darauf geachtet, dass weder Apache noch MySQL noch PHP installiert wird.
Also können diese gar nicht laufen. Ich habe also eine Installation für LAMPP gemacht.

Bevor noch andere diesbezügliche Fragen kommen: Vorgestern hatte ich mal die 0.9er LAMPP draufgespielt, irgendwie an den Rechten für das /opt Verzeichnis gespielt und es hat bis auf MySQL alles funktioniert.

Leider habe ich mir die "zufällige Rechtevergabe" nicht gemerkt. :oops:

Nun wollte ich gestern mal "schnell" die 1.0er Version installieren:
a) weil bei der 0.9er MySQL nicht lief, dachte ich mir bei der 1.0er wirds wohl besser
b) ich zur Zeit keine Lust und keine Zeit habe, stundelang herumzukonfigurieren, weshalb mich das ganze jetzt noch mehr frustriert.

Also nochmal unter dem Strich: Ich habe nichts laufen außer Linux,KDE usw. Nichts was LAMPP in die Quere kommen könnte. Die Rechtevergabe für /opt seht ihr oben in meinem ersten Posting.

Wie kriege ich das hin, das ich überhaupt auf die erste Seite vom LAMPP komme?
Wie bekomme ich MySQL zum laufen?

Für jede Antwort, die mich meiner Probleme Lösung näher bringt, danke ich im Voraus
lampneuling
 
Posts: 3
Joined: 14. June 2003 11:52

Postby Pc-dummy » 15. June 2003 09:27

hi lampneuling

Sag mir mal bitte was in der /opt/lampp/logs/error_log steht,
und was in der /opt/lampp/var/mysql/<hostname>.err[/i] steht.

MFG
Pc-Dummy

P.s.: So auf den ersten blick passen die dateirechte
Gentoo/X86_64, AMD Athlon 64 FX-53, 1,5 GB INFINEON Ram, Audigy 2 ZS Platinum Pro, 300 GB Platten, LG-DVD Brenner
Pc-dummy
AF Moderator
 
Posts: 784
Joined: 29. December 2002 01:46
Location: AT-Vorarlberg-Feldkirch

Postby pfiffikus » 15. June 2003 09:39

Hallo lampneuling,

Wie kriege ich das hin, das ich überhaupt auf die erste Seite vom LAMPP komme?
Wie bekomme ich MySQL zum laufen?


http://localhost

Die Installation von LAMPP funktioniert üblicherweise hervorragend, solange man die auf der Webseite gezeigten Instruktionen 1:1 befolgt.

Die Rechte ändere lieber, falls Dein LAMPP mal läuft, mittels
/opt/lampp/lampp security

Schau mal nach, ob im Verzeichnis
/opt/lampp/htdocs
eine Datei index.html liegt! Solange Du an der httpd.config nichts geändert hast, sollte diese Datei angezeigt werden.
pfiffikus
 
Posts: 47
Joined: 01. June 2003 16:33
Location: Gera/Thüringen
Operating System: Windows 8

Postby lampneuling » 15. June 2003 13:53

Hallo pfiffikus und PC-Dummy,

Ich habe heute morgen mein Debian neu installiert, dann habe ich lampp1.0 neu entpackt, plötzlich geht es !???! Verstehe einer, wer will.

Hier poste ich das Verzeichnis (entpackt heute morgen):
total 108
drwxr-xr-x 16 root root 4096 Jun 2 09:20 .
drwxr-xr-x 3 root root 4096 Jun 15 16:31 ..
-rw-r--r-- 1 root root 17984 May 22 2002 COPYING
-rw-rw-r-- 1 root root 11721 Jun 1 20:08 RELEASENOTES
drwxr-xr-x 2 root root 4096 Jun 1 22:58 bin
drwxr-xr-x 2 root root 4096 May 31 01:38 cgi-bin
drwxr-xr-x 3 root root 4096 May 31 01:38 error
drwxr-xr-x 6 root root 4096 May 31 04:12 etc
drwxr-xr-x 5 nobody root 4096 Mar 26 22:06 htdocs
drwxr-xr-x 3 root root 4096 May 31 01:38 icons
-rwxr-xr-x 1 root root 10563 Jun 2 09:20 lampp
drwxr-xr-x 8 root root 4096 Jun 1 22:58 lib
drwxr-xr-x 24 root root 4096 Apr 8 23:32 licenses
drwxr-xr-x 2 root root 4096 Jun 15 16:35 logs
drwxr-xr-x 2 root root 4096 Jun 1 22:58 modules
drwxr-sr-x 9 root root 4096 May 11 12:10 phpmyadmin
drwxr-xr-x 2 root root 4096 Jun 1 22:58 sbin
drwxr-xr-x 10 root root 4096 Feb 10 22:56 share
drwxr-xr-x 4 root root 4096 Jun 1 22:57 var

Seht ihr einen Unterschied zu dem Listing von oben? Ich nicht.


Dann hier mein neues /opt/lampp/var/mysql/debian.err:
030615 16:33:33 mysqld ended

030615 16:34:59 mysqld started
/opt/lampp/sbin/mysqld: ready for connections.
Version: '4.0.13-log' socket: '/opt/lampp/var/mysql/mysql.sock' port: 3306
030615 16:35:14 /opt/lampp/sbin/mysqld: Normal shutdown

030615 16:35:14 /opt/lampp/sbin/mysqld: Shutdown Complete

030615 16:35:14 mysqld ended

030615 16:35:43 mysqld started
/opt/lampp/sbin/mysqld: ready for connections.
Version: '4.0.13-log' socket: '/opt/lampp/var/mysql/mysql.sock' port: 3306

Auf jeden Fall funktioniert mein MySQL jetzt (plötzlich). Keine Ahnung wieso!?!

Jetzt habe ich aber ein neues aber ähnliches Problem:
Wenn ich ein Verzeichnis unter htdocs packe und auf ein .php meinen Browser lenke, dann sagt er wieder
Forbidden
You don't have permission ...... und so weiter.

Was ist das Geheimnis hinter diesen Zugriffsrechten? Wenn ich auf die index.html Datei der LAMPP Dist unter htdocs zugreifen darf, wieso nicht auf ein Verzeichnis unter htdocs, obwohl ich die Lese/Schreibrechte dementsprechend setze(also rwxr-xr-x für Gruppe nobody,User root)?

Ich danke euch, ohne euch wäre ich aufgeschmissen!!
lampneuling
 
Posts: 3
Joined: 14. June 2003 11:52

Postby pfiffikus » 15. June 2003 17:10

lampneuling wrote:Seht ihr einen Unterschied zu dem Listing von oben? Ich nicht.

Jetzt habe ich aber ein neues aber ähnliches Problem:
Wenn ich ein Verzeichnis unter htdocs packe und auf ein .php meinen Browser lenke, dann sagt er wieder
Forbidden
You don't have permission ...... und so weiter.

Was ist das Geheimnis hinter diesen Zugriffsrechten? Wenn ich auf die index.html Datei der LAMPP Dist unter htdocs zugreifen darf, wieso nicht auf ein Verzeichnis unter htdocs, obwohl ich die Lese/Schreibrechte dementsprechend setze(also rwxr-xr-x für Gruppe nobody,User root)?

Ich danke euch, ohne euch wäre ich aufgeschmissen!!


An den Zugriffsrechten im Verzeichnis /opt/lampp/ hattest du offensichtlich nichts geändert und hast es diesmal offensichtlich auch nicht.

Apache meldet
"Forbidden
You don't have permission ......"
auch in Fällen, in denen das Recht auf den Ordnerzugriff zwar gegeben ist, jedoch keine Datei "index.html" zu finden ist.

Du hast ein Verzeichnis unter htdocs GEPACKT :?: :!:
Du solltest die Dateien in dieses Verzeichnis kopieren, ohne zu packen. Im gepackten Zustand gibt es wahrscheinlich keine Datei "index.html" mehr.

Probiere doch mal ein anderes Vorgehen:
Du editierst als root die Datei /opt/lampp/etc/httpd.conf.

Etwa in der Mitte (ich zitiere gerade aus dem Kopf, bitte nicht über Tippfehler meckern!) findest du eine Zeile:
DocumentRoot /opt/lampp/htdocs

Vor diese Zeile setzt du ein # und ergänzt folgende Zeile:
DocumentRoot /home/lampneuling/public_html

Abhängig von den Verzeichnisnamen in Debian und deinem Benutzernamen musst du eventuell ein wenig umbenennen.

Es versteht sich von selbst, dass dein Verzeichnis
/home/lampneuling/public_html
eine Datei "index.html" enthalten muss, auf die jeder lesenden Zugriff haben muss.

Viel Spaß beim Probieren!
pfiffikus
 
Posts: 47
Joined: 01. June 2003 16:33
Location: Gera/Thüringen
Operating System: Windows 8


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests