MYSQL-Problem nach wechsel von Windows zu Linux

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

MYSQL-Problem nach wechsel von Windows zu Linux

Postby juki01 » 02. October 2005 10:58

Tach,
habe XAMPP (LAMPP) auf Linux-WS installiert. Läuft auch ohne Probleme. Wenn jetzt aber z.b. ein Install-PHP, der mir per config eine Datenbank anlegen soll - im htdocs läuft-, gibt es einen Fehler beim anlegen der DB. Im XAMPP-ADMIN kann ich aber auf die Beispiele z.B. das Gästebuch zugreifen. Bei WIN-XAMPP hatte ich dies nicht. Was mache ich falsch? Für eine Antwort bedanke ich mich im voraus.

JUKI
juki01
 
Posts: 7
Joined: 02. October 2005 10:36

Postby Wiedmann » 02. October 2005 11:05

gibt es einen Fehler beim anlegen der DB.

:?:
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby juki01 » 02. October 2005 11:33

Das Install.php Skript meldet : Unknown Database . Mehr nicht.
juki01
 
Posts: 7
Joined: 02. October 2005 10:36

Postby Wiedmann » 02. October 2005 11:48

Unknown Database . Mehr nicht.

Das langt doch. Meinst du nicht?

z.B.: Die Datenbank die du im "install.php" angibts, wird es halt nicht geben. Oder du sprichst die DB mit verschiedenen Namen an. Oder...

Ist ein eigenes Script?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby juki01 » 02. October 2005 12:00

Danke für Deine schnellen Antworten.

Habe die DB jetzt von Hand in lampp/var/mysql/"name" angelegt. Das Install.php läuft jetzt weiter bis zu dem Punkt wo Tabellen angelegt werden müssen. Dann Fehler: Kann TB nicht erstellen. Habe mit eigenem Sk versucht und dann zum Test mit einem Standard GBook-Sk geht aber auch nicht. Fehlen da wohl irgendwelche Zugriffsrechte (w) des Htdocs auf mysql?
juki01
 
Posts: 7
Joined: 02. October 2005 10:36

Postby Wiedmann » 02. October 2005 12:10

Fehlen da wohl irgendwelche Zugriffsrechte (w) des Htdocs auf mysql?

Ich sag jetzt mal nein (aber was nicht stimmt verrät dir ja die Fehlermeldung die ich ich nicht kenn). BTW: Was hat "htdocs" mit "mysql" zu tun?

Habe die DB jetzt von Hand in lampp/var/mysql/"name" angelegt.

Was machts du von Hand in <lampp/var/mysql/"name">? Auch wenn du DB's "von Hand" anlegst, hat in diesem Verzeichnis nur der MySQLD was zu suchen.

Das Install.php läuft jetzt weiter bis zu dem Punkt wo Tabellen angelegt werden müssen.

Nachdem die Tabellen auch nicht tun (mit was für einer Fehlermeldung?) rat ich jetzt mal, dass du irgendwo in deinem Script munter Gross- und Kleinschreibung mischt?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby juki01 » 02. October 2005 16:14

Das "Hand anlegen", für einen Test, habe ich natürlich mit der MYSQL-Admin Bedienoberfläche gemacht. Der Install Sk ist aus phpbook 1.5, ich denke der ist schon o.k. Fehlermeldung: Kann Tabelle "name" .... nicht anlegen. Was könnte ich noch tun?
juki01
 
Posts: 7
Joined: 02. October 2005 10:36

Postby Wiedmann » 02. October 2005 17:01

Der Install Sk ist aus phpbook 1.5, ich denke der ist schon o.k. Fehlermeldung

Und welches dieser Scripte die sich "phpbook" nennen?

Aber ich mal beim Herstellersupport nachfragen. "Normale" Scripte haben i.d.R. kein Problem um auf dem XAMPP installiert zu werden (was sagen die Requirements?).

habe ich natürlich mit der MYSQL-Admin Bedienoberfläche gemacht.

Datenbanken / Tabellen kannst ja anlegen wie du siehst. UNd phpMyAdmin ist auch nur ein ganz normales PHP-Script wie jedes andere auch.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests