[FEHLER] tar: Error exit delayed from previous errors

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

[FEHLER] tar: Error exit delayed from previous errors

Postby ClausVB » 12. June 2003 11:36

Ich habe einen SuSe 8.0 Server.

Ich habe das "lampp-1.0.tar.gz" heruntergeladen.

Es hat ca. 19,3 MB (genau 20.276.787 Bytes). Ich habe es 2x runtergeladen und es hat immer diese Größe.

Wenn ich unter
/usr/src
den Befehl
tar xvfz lampp-1.0.tar.gz -C /opt
eingebe, erscheint folgender Fehler.

lampp/lib/perl5/5.8.0/ExtUtils/Mkbootstrap.pm
lampp/lib/perl5/5.8.0/ExtUtils/xsubpp
lampp/lib/perl5/5.8.0/ExtUtils/MM_Unix.pm
lampp/lib/perl5/5.8.0/ExtUtils/Liblist.pm
tar: Skipping to next header
lampp/lib/perl5/5.8.0/ExtUtils/Liblist.pm
tar: Skipping to next header
lampp/lib/perl5/5.8.0/ExtUtils/Liblist.pm
tar: Skipping to next header

gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error exit delayed from previous errors


Interessanterweise kann ich mit Windows das tar.gz auspacken in ein reines TAR-File.

Dieses Tar-File ist dann 68,6 MB groß und wenn ich dass dann per FTP und SCP auf den Linux-Server schiebe, dann erscheint folgender Fehler:

lampp/modules/mod_auth.so
lampp/modules/mod_imap.so
lampp/modules/mod_usertrack.so
lampp/modules/httpd.exp
lampp/modules/mod_info.so
tar: Unexpected EOF in archive
tar: Error exit delayed from previous errors


Also an einer anderen Stelle als das tar.gz.

Ich habe keine Ahnung woran das liegt. Die anderen Pakete (lampp-devel + webmin) lassen sich problemlos auspacken.

Speicherplatz: 510 MB frei. Unter /usr habe ich noch 2,2 GB, aber da schlägt der Befehl auch fehl.

Hat jemand einen Lösungsvorschlag?
User avatar
ClausVB
 
Posts: 32
Joined: 12. June 2003 10:46
Location: NRW - Germany

Postby Oswald » 12. June 2003 11:41

Hallo Claus!

Okay, auf den ersten Blick sieht es so aus, als ob die Datei kaputt ist. Kann ich mir jetzt zwar nicht vorstellen, da die Größe stimmt und Du sie ja schon 2x heruntergeladen hast. Prüfen wir aber erst mal das.

Ruf bitte mal md5sum lampp-1.0.tar.gz (unter Linux) auf. Es sollte folgendes erscheinen:

94072eba3d58cd6bcf35be13ac0267a7 lampp-1.0.tar.gz

Und das würde bedeuten, dass die Datei in Ordnung ist. Wenn das der Fall ist, dann müssen wir mal weiterschauen...

Lieben Gruß,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby ClausVB » 12. June 2003 12:22

Kai Seidler wrote:Ruf bitte mal md5sum lampp-1.0.tar.gz (unter Linux) auf. Es sollte folgendes erscheinen:
94072eba3d58cd6bcf35be13ac0267a7 lampp-1.0.tar.gz


Danke für die schnelle Antwort.

Ich bekomme nicht die Antwort die Du erwartest, sondern die MD5-Summe ist eine andere:

Code: Select all
linux:/usr/src # md5sum lampp-1.0.tar.gz
3b969de385dc20767a9c15ddcfbc8aa1  lampp-1.0.tar.gz
linux:/usr/src #
User avatar
ClausVB
 
Posts: 32
Joined: 12. June 2003 10:46
Location: NRW - Germany

Postby Guest » 12. June 2003 13:47

Mal ne blöde Frage:

Das Dateien wie die
libncurses.so
0 Bytes haben ... kann doch nicht richtig sein, oder?

Vielleicht benutzt der LAMPP ja die vom System ...
Guest
 

Postby Oswald » 12. June 2003 15:33

Also wenn die Checksumme nicht stimmt, dann ist das Archiv einfach Schrott. Muss man jetzt mal so direkt sagen.

Ich hab's grad mal getestet und LAMPP von http://unc.dl.sourceforge.net/sourcefor ... 1.0.tar.gz heruntergeladen. Die Checksumme stimmt und die Datei lässt sich auch ohne Fehler auspacken. Probier es doch bitte noch mal. Und nach dem Downloaden auch gleich mal wieder md5sum aufrufen.

Bin gespannt...

Gruß,
Oswald ;)
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby ClausVB » 16. June 2003 10:04

Ich bin Deinem Link gefolgt und habe das Paket jetzt aus Dublin, Irland genommen.

Das hat die richtige Checksumme und ließ sich auch problemlos entpacken.

Ich bin von dem Paket ganz schwer begeistert.

Riesen Lob!

Und vielen Dank für Deine Hilfe.

Gruß
Claus
User avatar
ClausVB
 
Posts: 32
Joined: 12. June 2003 10:46
Location: NRW - Germany

Postby Oswald » 16. June 2003 14:23

Huhu Claus!

Prima. Klasse, dass es nun funktioniert.

Ich hoffe, dass das Problem mit dem fehlerhaftem Archiv nicht sonst noch irgendwo auftritt.

Liebe Grüße,
Oswald

PS: Und danke für das Lob! *freu*
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 2 guests