htaccess wenn htdocs verschoben?

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

htaccess wenn htdocs verschoben?

Postby baeckerman83 » 10. September 2005 19:22

Hi!
Ich wollte einen Ordner per Passwort vor unerlaubtem Zugriff sichern.
Habe aber in der conf datei die Pfade für HTdocs nach /Ben/internet geändert.
Muss ich da für die htaccess auch was eintragen? Wenn ja wo? ich bekomme nämlich immer die PW abfrage, aber ich kann diese nicht beantworten, also komme nicht in den Ordner rein!
meine
Code: Select all
.htacces: AuthName "Dateien"
AuthType Basic
AuthUserFile /Ben/internet/upben/downloads/.htpasswd
require valid-user


meine
Code: Select all
.passwd:admin:$1$55v82XIg$Q4nUUOU1ENW0bNbNj.iPC.


die .htpasswd liegt in dem Ordner so wie der Pfad heißt un die .htaccess ist auch im selben Ordner!
baeckerman83
 
Posts: 12
Joined: 08. September 2005 16:52

Postby deepsurfer » 11. September 2005 09:27

Code: Select all
meine
Code:
.passwd:admin:$1$55v82XIg$Q4nUUOU1ENW0bNbNj.iPC.


.htpasswd:admin:$1$55v82XIg$Q4nUUOU1ENW0bNbNj.iPC.
mal nachbessern und testen
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby baeckerman83 » 11. September 2005 10:01

Geht dann auch nicht. Muss ich in der httpd.conf da noch irgendwas umschreiben?
baeckerman83
 
Posts: 12
Joined: 08. September 2005 16:52

Postby Wiedmann » 11. September 2005 10:37

.passwd:admin:$1$55v82XIg$Q4nUUOU1ENW0bNbNj.iPC.

In die Passwortdatei gehört nur:
user:passwordhash

Also wenn das gehen soll für einen einen benutzer "Admin" dann so:
Code: Select all
admin:$1$55v82XIg$Q4nUUOU1ENW0bNbNj.iPC.


Warum benutzt du nicht das Tool "htpasswd"? Das würde die Passwortdatei gleich korrekt schrieben.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby baeckerman83 » 11. September 2005 11:06

In der htpasswd steht ja auch nur:
admin:$1$55v82XIg$Q4nUUOU1ENW0bNbNj.iPC.

aber es geht nicht. Mein Passwort wird nicht angenommen!
baeckerman83
 
Posts: 12
Joined: 08. September 2005 16:52

aenliches Problem

Postby dingos » 11. September 2005 17:52

Hallo,
erst mal herzlichen Glueckwusch zu XAMPP .. das macht das Leben wesentlich einfacher.

Ich hab ein aehnliches Problem, und zwar laueft bei mir die .htaccess nicht nachdem
ich das DocumentRoot geaendert habe. Das Verzeichnis wird richtig geroutet, allerdings
mod_rewrite + htaccess laufen nicht. Bin im Moment ratlos. :roll:
dingos
 
Posts: 7
Joined: 11. September 2005 17:45

Postby Reyx » 12. September 2005 16:59

@dingos
Wie sind denn deine AllowOverride-Einstellungen für das neue Root-Verzeichnis? Hast du da vielleicht irgendwas geändert?
Reyx
 
Posts: 9
Joined: 07. June 2005 19:45

Postby dingos » 12. September 2005 20:14

Reyx wrote:@dingos
Wie sind denn deine AllowOverride-Einstellungen für das neue Root-Verzeichnis? Hast du da vielleicht irgendwas geändert?


eigentlich nicht ... ich hab nur schon versucht den apache, mysql, php so zu installieren, vielleicht liegts daran ... ich mach das Ding grad platt und fang von vorn an ... das wird wohl das beste sein.
dingos
 
Posts: 7
Joined: 11. September 2005 17:45

Postby deepsurfer » 13. September 2005 11:15

aha, also benutzt du kein XAMPP....
(wäre gut gewesen dies zu erwähnen, da man hier zuerst davon ausgeht und in XAMPP diese Funktion schon vorhanden ist)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 4 guests