XAMPP auf IPcop - Apache startet nicht

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

XAMPP auf IPcop - Apache startet nicht

Postby EDsteve » 28. August 2005 21:55

Hi all,

hab ein kleines problemchen mit meinem XAMPP auf IPcop mit Samba-Addon.

Wenn ich XAMPP starte, bekomm ich beim start vom apache folgende meldung:

"XAMPP: Another webserver daemon with SSL is already running"

ohne samba hab ich damit keine probleme. Muss also irgendwie an dem Samba-Addon liegen. Wird denn mit Samba ein Webserver mitinstalliert?
Was kann ich machen, dass XAMPP den apache starten kann?

vielen dank schonmal.

grüße ED

- Keep on going -
EDsteve
 
Posts: 15
Joined: 28. August 2005 21:43

Postby deepsurfer » 28. August 2005 22:02

im IPCOP wurde der SSL Port wieder auf normal gemacht also 443, dieser wird auch von XAMPP angesprochen.

zwei möglichkeiten:
1. IPCOP den SLL auf einen anderen PORT
oder
2. den XAMPP auf einen anderen SSL PORT

http://faq.kwm-web.info/doku.php?id=apa ... rt_aendern


Darf ich aber fragen warum bzw. wozu Du einen XAMPP auf die IP des IPCOP legst ?
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby EDsteve » 28. August 2005 22:33

Hi und vielen dank für deine schöne antwort (kurz und knapp mit link. So solls sein :-),

Hab jetzt in der ssl.conf die beiden 443 nummern gegen 444 getauscht, was aber leider nichts gebracht hat. Hab ich da was vergessen?

XAMPP daher auf dem IPcop, weil ich nur ein rechner laufen haben will und ich FTP und WWW server incl. allen zusätzen (PHP, Perl,...) benötige.

Grüße ED
und danke
EDsteve
 
Posts: 15
Joined: 28. August 2005 21:43

Postby deepsurfer » 28. August 2005 23:10

ok...hab grad im IPcopForum dein Beitrag gelesen.
Du hast doch festgestellt das der XAMPP nicht startet nachdem du das SAMBA installiert hast.

Hast du nochmal die gegenprobe gemacht und samab abgeschaltet und XAMPP getestet ??

Ansonsten hier eine kleine anleitung wie du herausfindest was da den 443 blockiert.
http://faq.kwm-web.info/doku.php?id=apa ... rmeldungen
bischen scrollen dann kommt LINUX Anweisungen.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby Kristian Marcroft » 29. August 2005 00:58

Hi,

2 möglichkeiten:

1. /opt/lampp/lampp stopssl <- wenn du kein SSL benötigst mit XAMPP stelle es ab. Auf einem non Standardport sowieso sinnlos.

2. /opt/lampp/lampp editieren. Such dort mal nach "443" und ersetze es durch 444 ;)

Das lampp Script testet vor jedem start ob der Port belegt ist. und das ist er ja.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby deepsurfer » 29. August 2005 01:03

Kris war schneller..... ;)
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian

Postby EDsteve » 29. August 2005 01:15

was für ein service hier.

Habe soeben punkt zwei ausgeführt und klappt prima. Werde die lösung gleich noch im IPcopforum posten mit dank an dieses forum :-)

-keep on going-
EDsteve
 
Posts: 15
Joined: 28. August 2005 21:43

XAMPP auf IPcop - Apache startet nicht

Postby speerlinde » 23. April 2008 21:24

Ein Hallo an alle User hier Forum.

Sicherlich, das war schon klar, wurde hier eine Problemloesung erarbeitet.

In diesem Forum gibt es so viele Tips und Tricks, dass ich doch mehr lese
als Beitraege zu verfassen. Dafuer an dieser Stelle erst einmal ein Danke.

Warum schreibe ich denn hier diesen Beitrag?
Ich werde diese Frage mit einer Weiteren beantworten.
Wie gelingt es mir den IPCOP unter LAMPP auszufuehren?

Irre diese letzt genannte Frage!?
Da bin ich mir persoenlich sehr sicher.

Warum?

Mein IPCOP ist ausschliesslich eine FIREWALL.
Mein LAMPP erfuellt ganz andere Aufgaben tadellos.


In einem Bildnis gesprochen:
" Es ist auch moeglich eine Ziege mit einem Schaf zu kreuzen."

Das hatten wir ja schon; in dieser "schoenen" realen Welt.......



Liebe Gruesse Euch allen an den Hackbrettern im Netz der Netze.

SpeerLinde
speerlinde
 
Posts: 8
Joined: 12. October 2007 17:41

Postby deepsurfer » 14. June 2008 13:04

Öhhhhm Sorry "speerlinde", aber Du hast doch nicht wirklich vor
den IPcop IN XAMPP ein zu bauen, denn dass ist (mit verlaub) absoluter humbug.

Was bringt Dir ein Firewall System das erst "hinter" einem HTTPrequest aktiv ist ??

Könnte aber auch sein das Du durchaus auch nur Kommentarisch etwas falsch Formuliert hast, hoffe das dies zutrifft.
chirio Deep
Wie sagte einst der MCP aus Tron auf dem Bildschirm zu schreiben Pflegte
" ... end of communication ... "
User avatar
deepsurfer
AF Moderator
 
Posts: 6440
Joined: 23. November 2004 10:44
Location: Cologne
Operating System: Win-XP / Win7 / Linux -Debian


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 1 guest