LAMPP nach einem Stromausfall

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

LAMPP nach einem Stromausfall

Postby pfiffikus » 01. June 2003 16:50

Nach einem Stromausfall gestern (mein Quadratlatsch auf dem roten Knopf der Steckerleiste) war mein Rechner nicht mehr über FTP zu erreichen.

Beim Kommando "lampp start" wurde behauptet, "LAMPP-ProFTPD läuft bereits". Stimmte aber nicht.

Meine Ursachenforschung ergab, dass die Datei "/opt/lampp/var/proftpd.pid" noch existierte. Nachdem ich die Datei manuell gelöscht habe, startete ProFTPD wieder.

Kann man den Test, ob ProFTPD läuft, nicht auch anders lösen? Ist er denn nötig? Immerhin hat Apache auch keine Schwierigkeiten mit einer noch vorhandenen PID-Datei "/opt/lampp/logs/httpd.pid" gehabt. Es geht also!

Pfiffikus
pfiffikus
 
Posts: 47
Joined: 01. June 2003 16:33
Location: Gera/Thüringen
Operating System: Windows 8

Postby Oswald » 01. June 2003 17:03

Huhu pfiffikus!

Klar kann man das und das wird auch in der nächsten LAMPP-Version so drin sein. Irgendwo gibt es auch schon einen Thread in diesem Forum zu dem Thema.

Hatte es - wie Du schon richtig bemerkt hast - beim Apache und beim MySQL auch schon so eingebaut, nur den ProFTPD hatte ich vergessen.

Liebe Grüße,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests