xampp & Horde IMP - IMAP Problem

Irgendwelche Probleme mit XAMPP für Linux? Dann ist hier genau der richtige Ort um nachzufragen.

xampp & Horde IMP - IMAP Problem

Postby simatrix » 19. July 2005 13:16

Hallo,

ich habe da ein recht spezifisches Problem mit der IMAP Unterstützung.
:cry:

Installiert ist:
Suse 9.3 (9.2)
xampp 1.4.14
Horde 3.0.4
IMP H3 (4.0.3)

Die Installation von xampp und Horde/IMP hat wunderbar geklappt.
Alle Funktion stehen unter xampp zur Verfügung.
IMP funktioniert wunderbar.
Einziges Problem ist jedoch das Anzeigen von Mails auf einem IMAP Server (sowohl mercury als auch web.de).
Ich bekomme angezeigt, dass Mails da sind, die Übersichtsliste mit den eigentlichen Mails baut sich jedoch nicht auf.
(Anzeige: In diesem Ordner sind keine Nachrichten vorhanden)

Ich habe schon einige Zeit bei Google/Horde verbracht jedoch keine Lösung gefunden.
Als einzigen Ansatzpunkt habe ich PHP-Imap und den c-client und damit verbundene Probleme.

Kennt jemand dieses (oder ein ähnliches Problem) und eine Behebung.

Oder wie kann man die beiden Komponenten in xampp Erneuern, überprüfen oder deinstalleren


Bin für jede Hilfe dankbar...

Viele Grüße
simatrix
simatrix
 
Posts: 4
Joined: 19. July 2005 12:54

Postby Oswald » 19. July 2005 18:03

Hallo simatrix!

Lustigerweise habe ich gerade letzte Woche eine Horde/IMP-Installation durchgeführt unter XAMPP durchgeführt. Allerdings habe ich hier einen Cyrus IMAPD am Laufen und damit gab es keine Probleme.

Das Einzige was Du jetzt machen kannst ist PHP neu zu installieren. Dabei hast Du dann auch die Möglichkeit c-client auszutauschen. Allerdings durch was?

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby simatrix » 20. July 2005 07:42

Hallo,

vielen Dank für die Antwort.
Die verwendete imap Version in xampp ist 2002a (?)
Ich habe mal nachgesehen und eine neuere Version imap-2004e gefunden.
Wie kann ich die in xampp "austauschen" ?
Komisch das bei mir der Fehler bei 2 verschiedenen Imap's auftritt.

Kann es sein dass da irgendwie meine Suse Distri noch dazwischenfunkt ?
Achja ich habe es auf einem Vmware 5 Image laufen, aber das kann ja nun wirklich keinen Einfluss haben :?

Vielen Dank
simatrix
simatrix
 
Posts: 4
Joined: 19. July 2005 12:54

Postby Oswald » 20. July 2005 09:07

Hallo simatrix!

Oh, der c-client-2004e ist total an mir vorbeigegangen. Gerade compiliere ich PHP neu mit ihm. Wenn Interesse besteht, dann biete ich Dir gerne eine BETA-Version von XAMPP für Linux mit dem neuen 2004e zum Download an.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby simatrix » 20. July 2005 13:37

Hallo Oswald,

ja gerne :lol:


Viele Grüße
simatrix
simatrix
 
Posts: 4
Joined: 19. July 2005 12:54

Postby Oswald » 20. July 2005 13:57

Hallo simatrix!

Prima! Dann hab ich damit auch gleich jemandem, der die erste Beta nebebei testet. ;)

Den Download der xampp-linux-1.4.15-beta1.tar.gz findest Du hier:

http://www.apachefriends.org/de/xampp-beta.html

An der Version ist neu:

Code: Select all
New in this version of XAMPP:
    - New version of OpenSSL (0.9.8)
    - New version of zlib (1.2.2)
    - New version of Perl (5.8.7)
    - New version of PHP (4.4.0)
    - New version of phpMyAdmin (2.6.3-pl1)
    - New version of mod_perl (2.0.1)
    - Added phpMyAdmin's XAMPP theme (Thanks to Michael Keck)
    - New version of FreeTDS (0.63)
    - New version of MySQL (4.1.13)
    - New version of IMAP C-Client (2004e)


Bin gespannt ob es daran lag....

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux

Postby simatrix » 20. July 2005 19:01

Hallo Oswald,

genial :lol: :lol: :lol: :lol:

Es funktioniert, auf meinem schnell zusammengebastelten System kann ich nun auch die Mails per IMAP sehen.

Also von meiner Seite kann ich bestätigen, dass xampp Problemlos mit horde/imp zusammenarbeitet.

Ein riesiges Lob, xampp ist einfach genial!

Vielen Dank
Gruss simatrix

p.s.
auf die schnelle habe ich auch keine Probleme festgestellt, wir werden die nächsten Tage mal eine Tesumgebung für das Webinterface aufbauen. Da bekommen wir bestimmt noch mehr Infos.
simatrix
 
Posts: 4
Joined: 19. July 2005 12:54

Postby Oswald » 21. July 2005 10:29

Huhu simatrix!

Super! Danke Dir auch für's testen und für die Info, dass es die neue IMAP-Client-Bibliothek gibt. Hab ich - wie gesagt - total verpasst.

Liebe Grüße
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
Operating System: Linux


Return to XAMPP für Linux

Who is online

Users browsing this forum: No registered users and 3 guests